post #1 of 1
Thread Starter 
It's now back to its quiet self. I took the pump and res assembly out of the loop. Opened her up, saw nothing wrong (no cut off cable, broken solder joint, moisture or anything like that), cleaned her bottom with contact cleaner (which also repels moisture...and makes your lips crack for the rest of the day after you inhale it for more than 10 seconds. I suppose "Use in a well-ventilated area" isn't bad advice after all rolleyes.gif), assembled it all together. And now she's purring along @ 1800 RPM, enjoying her refound PWM signal...
No idea what I did but it's not the first time I open something up, look at it and do some stuff and it somehow magically fixes things. Perhaps I'm some electro-jesus ....
Honestly, don't care, happy as a clam to have things working properly again.

Solution: Disassemble the pump again, fiddle around and pretend like you know what you're doing and put everything back together. Fill, bleed, smoke a cigarette and plug in the PWM connector. FIXED

Cleaned and rebuild my watercooling loop. After leaktesting and bleeding I hooked everything up but it seems like my MCP35X doesn't respond to PWM any more. It's running at 4500+ RPM constantly and quite frankly, it's driving me crazy tongue.gif

  • Same pump as before, only thing that changed is the top and reservoir. It has the Koolance metal body as well as it did before
  • Same PWM cable, didn't remove the connector or anything like that, wired up correctly.
  • Same motherboard as before, has worked flawlessly using the BIOS PWM control

Basically, same motherboard and pump that worked before.

Things I have tried to no avail
  • Turning it on and off again ( thumb.gif ): my whole rig and disabling/enabling PWM control in the BIOS. Changing the mode.
  • Wiggling the cables at the back of the pump (could've been that I damaged a cable during assembly...)
  • Changing fan header
  • Checking the fan header with a voltage and a PWM controllable fan (both responded positively)
  • Tried Fan XPert 2 and speedfan
  • Cursing at the pump biggrin.gif

So yeah... if you guys have any guidelines on what I should look for, try out etc. that would be great.
Can you measure a PWM signal with a DMM ? (I don't think so, that's more oscilloscope territory IIRC)

Any help will be greatly appreciated because I'm a tad allergic to noise and this whine is absolutely pissing me off sozo.gif

EDIT: Aside from the pump's tacho and PWM lead, there's nothing connected to any of the motherboard fan headers. Where as before, there were 3 fans connected to several headers on the motherboard. But nothing to either CPU header except for the pump's tacho and PWM lead.
Perhaps the motherboard doesn't want to give a signal because there's no load?
Going to poke around a bit after I cleaned the house. Solution, if found, will be posted of course.

Perhaps it has a bad ground? Is PWM affected by the ground connection? I presume so

Checked the molex connector because I think I unhooked that one. 12V line and ground are in the right sockets...
Fortunately I remember that I can check the PCB without unhooking the pump from the loop because draining would be a PITA. Sadly, I can't seem to locate my DMM.
Checked the cables, used a different socket on the PSU for the Molex cable the pump is hooked into .... Nothing.
Getting really frustrated mad.gif
Edited by Bloitz - 11/18/13 at 2:17pm
Black Betty
(16 items)
Black Betty
(16 items)