Overclock.net › Forums › Components › Other Peripherals › brand new slot load won't take disc (2nd one, same result)
New Posts  All Forums:Forum Nav:

brand new slot load won't take disc (2nd one, same result)

post #1 of 3
Thread Starter 
So I have a fractal midi tower with slot load dvd front bay and when I initially went to this tower, I decided to put a slot load drive in. I have a slimline sata power line going directly to the power supply, and the slimline sata data to the mobo. When I slide the disc in, nothing happens. I can put the disc almost all the way in but nothing initiates or grabs the disc. I can double click on the drive on desktop and the motor will spit it out, but it wont take it in or function. THought it was a bad drive so I ordered a different one, but same result. Not sure what could be the problem. Any suggestions to try?
post #2 of 3
Did you try different disks?
post #3 of 3
Thread Starter 
Found the issue. The silverstone sata + slimline sleeved cable adapter I was using was sending little to no voltage to the drive. It's a shame I bought a second drive before figuring this out. Apparently, by the newegg reviews, I wasn't the only one having the issue. This cable is garbage and I hope others may stumble along this post before they make the same mistake. Here's a link to the said cable in question:

http://www.newegg.com/Product/Product.aspx?Item=N82E16812162024
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Peripherals
Overclock.net › Forums › Components › Other Peripherals › brand new slot load won't take disc (2nd one, same result)