Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › 7950 driver installed, but Standard VGA taking over
New Posts  All Forums:Forum Nav:

7950 driver installed, but Standard VGA taking over

post #1 of 3
Thread Starter 
EDIT: Problem Solved

I have the latest drivers for my 7950 installed and it shows up as working properly in the device manager, but Windows insists on also installing a standard VGA driver. When the Steam hardware survey pops up, it is detecting the standard VGA and not the 7900 series driver. I've only played BFBC2, SC2, and ME2 since building this computer and they seem to be running fine. I've tried disabling the standard VGA and Steam still detects it as my driver. I've tried uninstalling it but Windows stubbornly reinstalls it on restart, even with the 7900 series driver already installed.



Is this something to be concerned about? Is it using the Standard VGA driver over the 7900 series? Can this be fixed? TYIA.
Edited by durch - 11/21/13 at 9:02am
White Whale
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-4770K Gigabyte GA-Z87X-UD4H MSI TwinFrozrIII 7950 2x8GB Crucial Ballistix Sport XT 
Hard DriveCoolingOSMonitor
250GB Samsung Evo Noctua NH-D14 Windows 7 Professional 64-bit 24" Samsung ToC T240 1920x1200 
KeyboardPowerCaseMouse
Saitek Eclipse (Blue LED) 660W Seasonic Platinum SS-660XP Corsair 600T (white) OCZ Equalizer 
Mouse Pad
XTrac Ripper 17" x 12" 
  hide details  
Reply
White Whale
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-4770K Gigabyte GA-Z87X-UD4H MSI TwinFrozrIII 7950 2x8GB Crucial Ballistix Sport XT 
Hard DriveCoolingOSMonitor
250GB Samsung Evo Noctua NH-D14 Windows 7 Professional 64-bit 24" Samsung ToC T240 1920x1200 
KeyboardPowerCaseMouse
Saitek Eclipse (Blue LED) 660W Seasonic Platinum SS-660XP Corsair 600T (white) OCZ Equalizer 
Mouse Pad
XTrac Ripper 17" x 12" 
  hide details  
Reply
post #2 of 3
Quote:
Originally Posted by durch View Post

I have the latest drivers for my 7950 installed and it shows up as working properly in the device manager, but Windows insists on also installing a standard VGA driver. When the Steam hardware survey pops up, it is detecting the standard VGA and not the 7900 series driver. I've only played BFBC2, SC2, and ME2 since building this computer and they seem to be running fine. I've tried disabling the standard VGA and Steam still detects it as my driver. I've tried uninstalling it but Windows stubbornly reinstalls it on restart, even with the 7900 series driver already installed.



Is this something to be concerned about? Is it using the Standard VGA driver over the 7900 series? Can this be fixed? TYIA.

just a wild guess . . . it could be your integrated gpu (igpu). try disabling it inside BIOS. Also, try disabling it first in the Device Manager. Rightclick and disable device.
Edited by rdr09 - 11/20/13 at 12:40pm
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 8 / 1600 
Hard DriveCoolingOSMonitor
1000 360/240 7 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 8 / 1600 
Hard DriveCoolingOSMonitor
1000 360/240 7 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by rdr09 View Post

just a wild guess . . . it could be your integrated gpu (igpu). try disabling it inside BIOS. Also, try disabling it first in the Device Manager. Rightclick and disable device.

Yup, that fixed it. Disabling it in the Device Manager was something I had already tried, and it didn't fix the issue. But disabling the integrated GPU in the BIOS fixed the problem. The standard VGA adapter no longer appears in the Device Manager, and Steam correctly identifies the 7900 series driver.

Thank you for the help. Coming from a Q6600 build I had for 5 years, I completely forgot these things have integrated GPU's in them. Who knows how long it would have taken me to remember that haha.
White Whale
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-4770K Gigabyte GA-Z87X-UD4H MSI TwinFrozrIII 7950 2x8GB Crucial Ballistix Sport XT 
Hard DriveCoolingOSMonitor
250GB Samsung Evo Noctua NH-D14 Windows 7 Professional 64-bit 24" Samsung ToC T240 1920x1200 
KeyboardPowerCaseMouse
Saitek Eclipse (Blue LED) 660W Seasonic Platinum SS-660XP Corsair 600T (white) OCZ Equalizer 
Mouse Pad
XTrac Ripper 17" x 12" 
  hide details  
Reply
White Whale
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-4770K Gigabyte GA-Z87X-UD4H MSI TwinFrozrIII 7950 2x8GB Crucial Ballistix Sport XT 
Hard DriveCoolingOSMonitor
250GB Samsung Evo Noctua NH-D14 Windows 7 Professional 64-bit 24" Samsung ToC T240 1920x1200 
KeyboardPowerCaseMouse
Saitek Eclipse (Blue LED) 660W Seasonic Platinum SS-660XP Corsair 600T (white) OCZ Equalizer 
Mouse Pad
XTrac Ripper 17" x 12" 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › 7950 driver installed, but Standard VGA taking over