Overclock.net › Forums › Components › Mice › Deathadder 3.5G Problems
New Posts  All Forums:Forum Nav:

Deathadder 3.5G Problems

post #1 of 4
Thread Starter 
So I just got my new DA 3.5g after not liking the feel of the 4G version. This is coming from an Abyssus, so I was assuming that the DA 3.5G would be the same performance as that at least. After installing the legacy drivers and setting my DPI to my preferred 450 and polling to 1000Hz, I noticed some things just didn't feel the same. It seems as though the 450 setting is actually quite a bit higher than advertised. I had to go from 2.2 to 1.8 in CS:GO to get the same sensitivity. Also when I move the mouse quickly, it malfunctions at a much lower speed than my Abussus. It just kind of stops. So now I'm wondering if I got a faulty mouse or maybe it's Windows 8.1? I use raw input BTW so it shouldn't be anything related to that.

EDIT:
So it seems all the DPI settings seem to be higher than advertised. I was assuming it should almost be identical to the Abyssus. Regardless of that it still malfunctions at very low speeds at all DPI settings. And the button on the bottom of the mouse that is used to change profiles doesn't seem to work either.
Edited by reddy89 - 11/21/13 at 5:22pm
post #2 of 4
Back when I had that mouse before the mouse wheel acted up in 4 RMAs in a row I always used 1800 DPI because you get far higher maximum perfect control speeds with that, just like the 3G. Also, I found that the polling rate is quite unstable in some directions of movement especially at 1000 Hz, one big reason why I switched mice.
L1m1t
(22 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5 GHz ASUS P8Z68-V LX ASUS DirectCU II GTX 770 OC Patriot G2 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black Kingston SSDNow Cooler Master Hyper 212+ Windows 8.1 x64 
MonitorKeyboardPowerCase
ASUS VG248QE SteelSeries 6Gv2 MX Red Corsair TX650 NZXT Source 210 
MouseMouse PadAudioAudio
Zowie FK1 Puretrak Talent ASUS Xonar DG Sennheiser PC350 
AudioAudioAudioAudio
Creative Fatal1ty HS-800 Shure SRH440 Audio Technica ATH-M40x AKG K701 
AudioAudio
beyerdynamic DT770 AKG K550 
  hide details  
Reply
L1m1t
(22 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5 GHz ASUS P8Z68-V LX ASUS DirectCU II GTX 770 OC Patriot G2 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black Kingston SSDNow Cooler Master Hyper 212+ Windows 8.1 x64 
MonitorKeyboardPowerCase
ASUS VG248QE SteelSeries 6Gv2 MX Red Corsair TX650 NZXT Source 210 
MouseMouse PadAudioAudio
Zowie FK1 Puretrak Talent ASUS Xonar DG Sennheiser PC350 
AudioAudioAudioAudio
Creative Fatal1ty HS-800 Shure SRH440 Audio Technica ATH-M40x AKG K701 
AudioAudio
beyerdynamic DT770 AKG K550 
  hide details  
Reply
post #3 of 4
Thread Starter 
Well the malfunction speed seems to be the same on all the DPIs. And it is significantly lower than my Abyssus. In fact, I could not reach the malfunction speed of the Abyssus while playing.

I'm using driver 3.05 and firmware 2.45. I don't know if that is the latest as it seems the razer download section doesn't have any firmware updates anymore. I also uninstalled the driver to see if that affected anything. Issues persist.
post #4 of 4
Razer quality has not been very good, I'm afraid. I would return and get a Logitech if that's an option for you.
MicroATX
(12 items)
 
   
CPUMotherboardGraphicsRAM
Intel 4770K @ 4.4 Ghz Asus ROG Maximus GENE VII EVGA GTX 780 Ti SC SLI Corsair Dominator Platinum 32GB 2.8Ghz 
Hard DriveHard DriveCoolingOS
PNY XLR8 120GB RAID 0 WD Black 3TB Scythe Ashura Shadow Windows 10 Pro 
MonitorKeyboardPowerCase
Dell U3014 HP Elite V2 Corsair AX1200i Corsair Carbide Air 240 
CPUGraphicsRAMHard Drive
Intel Core i7 2860QM AMD FirePro M8900 2GB Elpida 16GB 1333Mhz 2x HGST 7200RPM 1TB RAID 0 
Hard DriveOSMonitorKeyboard
Intel 525 MSATA 90GB Windows 8.1 Pro 27" HP ZR2740w 2560x1440 HP Elite V2 
MouseAudioOtherOther
Logitech G700 Bowers & Wilkins MM1 Dell 5620 WWAN Intel AGN 6300 
  hide details  
Reply
MicroATX
(12 items)
 
   
CPUMotherboardGraphicsRAM
Intel 4770K @ 4.4 Ghz Asus ROG Maximus GENE VII EVGA GTX 780 Ti SC SLI Corsair Dominator Platinum 32GB 2.8Ghz 
Hard DriveHard DriveCoolingOS
PNY XLR8 120GB RAID 0 WD Black 3TB Scythe Ashura Shadow Windows 10 Pro 
MonitorKeyboardPowerCase
Dell U3014 HP Elite V2 Corsair AX1200i Corsair Carbide Air 240 
CPUGraphicsRAMHard Drive
Intel Core i7 2860QM AMD FirePro M8900 2GB Elpida 16GB 1333Mhz 2x HGST 7200RPM 1TB RAID 0 
Hard DriveOSMonitorKeyboard
Intel 525 MSATA 90GB Windows 8.1 Pro 27" HP ZR2740w 2560x1440 HP Elite V2 
MouseAudioOtherOther
Logitech G700 Bowers & Wilkins MM1 Dell 5620 WWAN Intel AGN 6300 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Deathadder 3.5G Problems