Overclock.net › Forums › Intel › Intel Motherboards › SABERTOOTH Z77 Network Card Issue
New Posts  All Forums:Forum Nav:

SABERTOOTH Z77 Network Card Issue

post #1 of 3
Thread Starter 
For some reason I can't get the On board Ethernet to work. Re installed the OS and proper drivers from the ASUS website and just won't work. Had to buy a Ethernet card to get internet on my new build. Also called ASUS up and they couldn't figured it out either. Wondering if anyone else had this issue?
post #2 of 3
can you find the device in device manager? I've had problems with a realtek device, oem driver wouldn't load... had to get device properties and google device id to find the right driver. not sure if they ran out of parts when making my board or what, no one every said anything about their drivers not working. (BTW- it was an HP laptop that gave me these problems). remember you can force drivers, but doesn't always help.
HAF Dragon
(17 items)
 
Blue Dragon
(11 items)
 
W10M
(8 items)
 
CPUMotherboardGraphicsGraphics
AMD FX 9370 Asus Crosshair V Formula Z Asus R9-290 DCUII ~ ɌЭÐ M§D Asus R9-290 DCUII ~ ɌЭÐ M§D 
RAMHard DriveHard DriveHard Drive
AMD Radeon™ RP1866 Performance Series OCZ VERTEX 3 OCZ VERTEX 3 Seagate Hybrid drive 
CoolingOSMonitorKeyboard
CoolerMaster Seidon 240M WINDOWS 7 ULTIMATE 64-BIT BenQ XL2420T LOGITECH G19 
PowerCaseMouseAudio
Coolmax 1200W gold+ Coolermaster HAF 912 LOGITECH G300 Sound Blaster Tactic 3D Omega 
Other
ASUS PCE-AC68 WIRELESS ADAPTER 
CPUMotherboardGraphicsGraphics
AMD FX 4130 MSI 990FXA-GD80 MSI 7870 HAWK MSI 7870 HAWK 
Hard DriveOSMonitorKeyboard
OCZ VERTEX 4 WINDOWS 7 ULTIMATE 64-BIT BenQ XL2420T LOGITECH G19 
PowerCaseMouse
seasonic m12II 850w ANTEC NINE HUNDERED LOGITECH G300 
  hide details  
Reply
HAF Dragon
(17 items)
 
Blue Dragon
(11 items)
 
W10M
(8 items)
 
CPUMotherboardGraphicsGraphics
AMD FX 9370 Asus Crosshair V Formula Z Asus R9-290 DCUII ~ ɌЭÐ M§D Asus R9-290 DCUII ~ ɌЭÐ M§D 
RAMHard DriveHard DriveHard Drive
AMD Radeon™ RP1866 Performance Series OCZ VERTEX 3 OCZ VERTEX 3 Seagate Hybrid drive 
CoolingOSMonitorKeyboard
CoolerMaster Seidon 240M WINDOWS 7 ULTIMATE 64-BIT BenQ XL2420T LOGITECH G19 
PowerCaseMouseAudio
Coolmax 1200W gold+ Coolermaster HAF 912 LOGITECH G300 Sound Blaster Tactic 3D Omega 
Other
ASUS PCE-AC68 WIRELESS ADAPTER 
CPUMotherboardGraphicsGraphics
AMD FX 4130 MSI 990FXA-GD80 MSI 7870 HAWK MSI 7870 HAWK 
Hard DriveOSMonitorKeyboard
OCZ VERTEX 4 WINDOWS 7 ULTIMATE 64-BIT BenQ XL2420T LOGITECH G19 
PowerCaseMouse
seasonic m12II 850w ANTEC NINE HUNDERED LOGITECH G300 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by Blue Dragon View Post

can you find the device in device manager? I've had problems with a realtek device, oem driver wouldn't load... had to get device properties and google device id to find the right driver. not sure if they ran out of parts when making my board or what, no one every said anything about their drivers not working. (BTW- it was an HP laptop that gave me these problems). remember you can force drivers, but doesn't always help.

After dealing with this issue on Windows 7 I decided to give Windows 8 a shot. The driver is now working and seems to be running smooth. If anyone runs into this issue try upgrading to Windows 8.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › SABERTOOTH Z77 Network Card Issue