Overclock.net › Forums › Video Games › PC Gaming › STEAM DX11 games won't launch anymore
New Posts  All Forums:Forum Nav:

STEAM DX11 games won't launch anymore

post #1 of 14
Thread Starter 
Hi guys,

I have a problem with my STEAM games. I cannot start any of my DX11 titles. I have alredy tried with Metro Last Light, Hitman Absolution, Sniper Elite V2, and Nazi Zombie Army 1 & 2. I go through a black screen, and game process seems to be handged. I need to kill the process using the task manager.

I have tried deleting local content and downloading games again, did'nt work. Also tried to reinstall the STEAM client, didn't work. Happens both in sourround and single configuration.

I'm currently going back to previous versions of Nvidia driver, I went as far as September WHQL and still nothing.

Any suggestions? Do anyone of you guys experience the same problem?

DX9 games I have tried work properly (Darksiders 2 and Dishonored).

Thank you

PS: Other non-STEAM DX11 games work fine (Crysis 3, BF4, Far Cry 3...)
Edited by iPEN - 11/24/13 at 10:06am
post #2 of 14
Thread Starter 
Hello again,

After spending all the afternoon testing different configurations of drivers, resolutions and so on, my conclusion is that the problem is caused by some kind of software incompatibility.

I have 3 candidates, Winpower (UPS manager for my Salicru SPS SOHO+), Logitech Gaming Software (for my G13 and G15 keyboards) or Rivatunner Server.

It is very strange. I reinstalled Sniper Elite Nazi Zombie Army 2, it didn't launch. Ok I switch-off these 3 programs, then game launched... and here come the good part... after one succesfull launch it continues working pretty well when I restart the 3 programs again! even if I restart the PC.

***?
post #3 of 14
Just to throw this out there but do you have a custom resolution? For me some games and especially heaven4.0 and valley won't launch if I reinstall a driver or update my nvidia driver without going back to native resolution. I have a custom res of 75hz since I have a 75hz monitor. It gets buggy when I install new drivers and its still on the custom res. I reset, delete the custom setting, recreate the custom resolution and then I'm done....
Philaphlous
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6700k Asus Z170i ITX Pro Gaming Asus STRIX GTX 970 Team Group DDR4 3600 16GB Xtreem 
Hard DriveCoolingOSMonitor
Sandisk X400 512GB m.2 SSD Silverstone NT06-Pro Windows 10 64bit 23" Acer 1920x1080 
KeyboardPowerCaseMouse Pad
Rapoo E9070 Silverstone ST45SF-G Silverstone ML07b Xtrack XXL 
  hide details  
Reply
Philaphlous
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6700k Asus Z170i ITX Pro Gaming Asus STRIX GTX 970 Team Group DDR4 3600 16GB Xtreem 
Hard DriveCoolingOSMonitor
Sandisk X400 512GB m.2 SSD Silverstone NT06-Pro Windows 10 64bit 23" Acer 1920x1080 
KeyboardPowerCaseMouse Pad
Rapoo E9070 Silverstone ST45SF-G Silverstone ML07b Xtrack XXL 
  hide details  
Reply
post #4 of 14
Thread Starter 
Thanks for your suggestion wink.gif

No, I don't have a custom resolution. I have tried this either with and without the Nvidia Surround and the result is the same.
post #5 of 14
My money is on Rivatuner being your problem.
My reason is that i use EVGA precision which uses Rivatuner for GPU stats and with it enabled i can not launch DX11 titles, with it disabled i can launch DX11 titles.

This can also sometimes happen with Fraps also, stuff that uses overlays can do this sometimes, im not clued up on why, just happens biggrin.gif

EDIT:

i recently went on a rage on Dota2 forum blaming an update for me not being able to play....turns out it was MSI AB causing my issue, but it worked fine on my sons rig with MSI AB rolleyes.gif
Edited by superj1977 - 11/24/13 at 4:03pm
Le Box of Black
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 Gigabyte X58A-UD7 r2.0 GTX 770 16GB Corsair Vengeance in Triple channel mode ;) 
Hard DriveHard DriveHard DriveHard Drive
Ocz Vertex 2  Samsung F1  Samsung F3 Samsung F1 
Optical DriveOSMonitorKeyboard
Sammie Dvd rw Windows 7 64Bit HZ281HPB 1200p / HP IPS 1080p / Samsung Syncmas... Qpad MK80 (Blue switch), SteelSeries 7G (Cherry... 
PowerCaseMouseMouse Pad
HX1000 CM-Stacker 832 Flipped Naos 3200,G5,G400,G400s, G300, Kone+ Razor Destructor and Steelseries Qck 
AudioAudioAudio
X-Fi Fatal1ty  ATH-T500 / AH-D510 Samson CO1U PAK Condenser Mic  
  hide details  
Reply
Le Box of Black
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 Gigabyte X58A-UD7 r2.0 GTX 770 16GB Corsair Vengeance in Triple channel mode ;) 
Hard DriveHard DriveHard DriveHard Drive
Ocz Vertex 2  Samsung F1  Samsung F3 Samsung F1 
Optical DriveOSMonitorKeyboard
Sammie Dvd rw Windows 7 64Bit HZ281HPB 1200p / HP IPS 1080p / Samsung Syncmas... Qpad MK80 (Blue switch), SteelSeries 7G (Cherry... 
PowerCaseMouseMouse Pad
HX1000 CM-Stacker 832 Flipped Naos 3200,G5,G400,G400s, G300, Kone+ Razor Destructor and Steelseries Qck 
AudioAudioAudio
X-Fi Fatal1ty  ATH-T500 / AH-D510 Samson CO1U PAK Condenser Mic  
  hide details  
Reply
post #6 of 14
I am running all but the UPS software and have no problems with running and launching any Steam DX11 game. I have a G19 Logitech keyboard with the latest drivers and am using the latest version of EVGA Precision X no problems.
 
Dragon Rider
(20 items)
 
 
CPUMotherboardGraphicsRAM
i5 3570k Asus Sabertooth Z77 Gigabyte GTX 670 G.SKILL Ripjaws 
Hard DriveOptical DriveCoolingOS
WD  LG Blu Ray Writer Corsair H100i Windows 8 Pro 
OSMonitorMonitorMonitor
Apple OS X 10.8.2 Asus VK278Q Asus VK278Q Asus VK278Q 
KeyboardPowerCaseMouse
Logitech G19 gaming Keyboard Roswill Lighting 800  In Win GRone White Tt esports Level 10m mouse 
Audio
Creative Sound Blaster Z 
  hide details  
Reply
 
Dragon Rider
(20 items)
 
 
CPUMotherboardGraphicsRAM
i5 3570k Asus Sabertooth Z77 Gigabyte GTX 670 G.SKILL Ripjaws 
Hard DriveOptical DriveCoolingOS
WD  LG Blu Ray Writer Corsair H100i Windows 8 Pro 
OSMonitorMonitorMonitor
Apple OS X 10.8.2 Asus VK278Q Asus VK278Q Asus VK278Q 
KeyboardPowerCaseMouse
Logitech G19 gaming Keyboard Roswill Lighting 800  In Win GRone White Tt esports Level 10m mouse 
Audio
Creative Sound Blaster Z 
  hide details  
Reply
post #7 of 14
Quote:
Originally Posted by bryonhowley View Post

am using the latest version of EVGA Precision X no problems.
Do you have any items enabled in "Monitoring" in EVGA Precision? that causes Rivatuner server to start, without any items ticked Rivatuner server would not be running. For me its when Rivatuner server runs my DX11 games do not start.

Le Box of Black
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 Gigabyte X58A-UD7 r2.0 GTX 770 16GB Corsair Vengeance in Triple channel mode ;) 
Hard DriveHard DriveHard DriveHard Drive
Ocz Vertex 2  Samsung F1  Samsung F3 Samsung F1 
Optical DriveOSMonitorKeyboard
Sammie Dvd rw Windows 7 64Bit HZ281HPB 1200p / HP IPS 1080p / Samsung Syncmas... Qpad MK80 (Blue switch), SteelSeries 7G (Cherry... 
PowerCaseMouseMouse Pad
HX1000 CM-Stacker 832 Flipped Naos 3200,G5,G400,G400s, G300, Kone+ Razor Destructor and Steelseries Qck 
AudioAudioAudio
X-Fi Fatal1ty  ATH-T500 / AH-D510 Samson CO1U PAK Condenser Mic  
  hide details  
Reply
Le Box of Black
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 Gigabyte X58A-UD7 r2.0 GTX 770 16GB Corsair Vengeance in Triple channel mode ;) 
Hard DriveHard DriveHard DriveHard Drive
Ocz Vertex 2  Samsung F1  Samsung F3 Samsung F1 
Optical DriveOSMonitorKeyboard
Sammie Dvd rw Windows 7 64Bit HZ281HPB 1200p / HP IPS 1080p / Samsung Syncmas... Qpad MK80 (Blue switch), SteelSeries 7G (Cherry... 
PowerCaseMouseMouse Pad
HX1000 CM-Stacker 832 Flipped Naos 3200,G5,G400,G400s, G300, Kone+ Razor Destructor and Steelseries Qck 
AudioAudioAudio
X-Fi Fatal1ty  ATH-T500 / AH-D510 Samson CO1U PAK Condenser Mic  
  hide details  
Reply
post #8 of 14
Thread Starter 
Quote:
Originally Posted by superj1977 View Post

My money is on Rivatuner being your problem.
My reason is that i use EVGA precision which uses Rivatuner for GPU stats and with it enabled i can not launch DX11 titles, with it disabled i can launch DX11 titles.

This can also sometimes happen with Fraps also, stuff that uses overlays can do this sometimes, im not clued up on why, just happens biggrin.gif

EDIT:

i recently went on a rage on Dota2 forum blaming an update for me not being able to play....turns out it was MSI AB causing my issue, but it worked fine on my sons rig with MSI AB rolleyes.gif

Yes, I am also thinking that. But I can not understand why it happens so randomly...

Quote:
Originally Posted by bryonhowley View Post

I am running all but the UPS software and have no problems with running and launching any Steam DX11 game. I have a G19 Logitech keyboard with the latest drivers and am using the latest version of EVGA Precision X no problems.

I have been running with this software for several months without any issue, but now it is causing me a lot of troubles. Don't really know what is happening. As I have said it is pretty random.
Edited by iPEN - 11/24/13 at 4:34pm
post #9 of 14
I have the same problem, Some of my steam games not launching.
     
CPUMotherboardGraphicsRAM
Intel Core i7-5820K Haswell-E 6-Core 3.3GHz LGA... ASUS X99-A LGA 2011-v3 Intel X99 SATA 6Gb/s USB... ASUS Radeon R9 390 STRIX-R9390-DC3OC-8GD5-GAMIN... CORSAIR Vengeance LPX 16GB (4 x 4GB) 288-Pin DD... 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force LS Series CSSD-F240GBLS 2.5" 240G... Corsair Neutron Series CSSD-N128GB3-BK 2.5" 128... Western Digital Blue WD10EZEX 1TB 7200 RPM 64MB... ASUS Black 12X BD-ROM 16X DVD-ROM 48X CD-ROM SA... 
CoolingOSMonitorKeyboard
Hydro Series™ H110i GT 280mm Extreme Performanc... Win 10 Pro ASUS ROG MG278Q Black 27" 144 Hz Corsair Gaming K70 RGB Mechanical Gaming Keyboa... 
PowerCaseMouseMouse Pad
CORSAIR HXi 1000W ATX12V / EPS12V 80 PLUS PLATI... Corsair Graphite Series 760T CC-9011074-WW Whit... Corsair Gaming M65 RGB Laser Gaming Mouse - White Corsair Gaming MM300 Anti-Fray Cloth Gaming Mou... 
AudioAudioOtherOther
Audioengine A2+ Premium Powered Desktop Speaker... Corsair Gaming VOID USB RGB Gaming Headset - White CableMod WideBeam Magnetic LED Strip RGB Kit - ... CableMod C-Series AXi, HXi & RM Cable Kit - Bla... 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i7-5820K Haswell-E 6-Core 3.3GHz LGA... ASUS X99-A LGA 2011-v3 Intel X99 SATA 6Gb/s USB... ASUS Radeon R9 390 STRIX-R9390-DC3OC-8GD5-GAMIN... CORSAIR Vengeance LPX 16GB (4 x 4GB) 288-Pin DD... 
Hard DriveHard DriveHard DriveOptical Drive
Corsair Force LS Series CSSD-F240GBLS 2.5" 240G... Corsair Neutron Series CSSD-N128GB3-BK 2.5" 128... Western Digital Blue WD10EZEX 1TB 7200 RPM 64MB... ASUS Black 12X BD-ROM 16X DVD-ROM 48X CD-ROM SA... 
CoolingOSMonitorKeyboard
Hydro Series™ H110i GT 280mm Extreme Performanc... Win 10 Pro ASUS ROG MG278Q Black 27" 144 Hz Corsair Gaming K70 RGB Mechanical Gaming Keyboa... 
PowerCaseMouseMouse Pad
CORSAIR HXi 1000W ATX12V / EPS12V 80 PLUS PLATI... Corsair Graphite Series 760T CC-9011074-WW Whit... Corsair Gaming M65 RGB Laser Gaming Mouse - White Corsair Gaming MM300 Anti-Fray Cloth Gaming Mou... 
AudioAudioOtherOther
Audioengine A2+ Premium Powered Desktop Speaker... Corsair Gaming VOID USB RGB Gaming Headset - White CableMod WideBeam Magnetic LED Strip RGB Kit - ... CableMod C-Series AXi, HXi & RM Cable Kit - Bla... 
  hide details  
Reply
post #10 of 14
Thread Starter 
Quote:
Originally Posted by Lshuman View Post

I have the same problem, Some of my steam games not launching.

Please, elaborate a bit more.

¿Are those DX11 games? ¿Do you use Rivatuner?

Thank you thumb.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › STEAM DX11 games won't launch anymore