Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › File transfers to external drives wont complete
New Posts  All Forums:Forum Nav:

File transfers to external drives wont complete

post #1 of 9
Thread Starter 
When trying to move large files (between 300mb to 2gb, I'm well aware of NTFS/FAT32) the file will transfer up to 99% and then will hang for upwards of 3-5mins before sometimes completing and just flat out wont transfer multiple large files at all, will hang after the first file gets to the same condition as before. I can still transfer from internal to internal and even from external to internal works fine, just no luck internal to external. I have tried every usb port on the front and back panels and have no variation.

I have tried a lot of different things, latest being a complete full reformatting of my OS drive and complete reinstallation (Windows 7 pro x64). Have run all latest updates and made sure that all drivers/BIOS/firmware etc. are all the latest and current but am still having the exact same issue as the last OS install. Have tried with multiple external drives and usb drives, full formats of all and still so change. I am running SpyBot 2 full professional edition. I have tried completely uninstalling it and restarting then trying the transfer and still no luck.

I am starting to worry that it is a motherboard issue which really would suck as the latest AMD boards are not on sale yet.

Have spent many hours now combing the forums for suggestions and cannot find anything that helps.

Thank you all in advance for your opinions and suggests.
post #2 of 9
How long did you let it stay there "copying but stuck"? Because especially when moving from internal storages to (slow) external storages, bothwindows and the external drive tends to use buffers massively, which causes it to appear "not working" for some time. Not long ago, I backed up some of my stuff to a external HDD (1TB capacity, copied some 800GB or so at once), and after the progress bar reached some 99%, it stopped there, for about 5 minutes, and after that, the progress bar went to 100% and it completed. However, even after this, the drive was still writing the data to the actual hdd for a good minute or two (this is why it's important to use the "safely remove device" feature in windows, or you will lose the last files!). So basically progress bars often lie, because they dont know about buffers and caches and such, especially on the drive side. rolleyes.gif
Minimachine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-5775C Asus Maximus VII Impact EVGA GTX1080 Founders edition 2x8GB Kingston HyperX 1600Mhz 
Hard DriveMonitorPowerCase
Samsung 950 PRO 512GB M.2 NVMe 3x Asus PB287Q 4k Silverstone 600W Strider SFX NCASE M1 Rev 2 
  hide details  
Reply
Minimachine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-5775C Asus Maximus VII Impact EVGA GTX1080 Founders edition 2x8GB Kingston HyperX 1600Mhz 
Hard DriveMonitorPowerCase
Samsung 950 PRO 512GB M.2 NVMe 3x Asus PB287Q 4k Silverstone 600W Strider SFX NCASE M1 Rev 2 
  hide details  
Reply
post #3 of 9
Thread Starter 
Thanks for such a quick reply, I get what your saying, I have tried leaving it for 30+ mins sometimes (if its a big file) and have come back and it has not progressed at all.

I am aware of the usual hang time towards the end when transferring but this issue is has become problematic eg before, I could select 1tb worth of files (400+ movies, 1.2gb to 8gb+ per file) and it would take a far few hours but it would write at a stable 180mb+ per second and have no issues, then one day, it decides that it wont even transfer a single file.

If I try to do a transfer like the one described above, it will hang at the end of transferring the first file and then just refuse to continue, even leaving it for 4+ hours and it did not progress past the first file.

I am officially stumped lol
post #4 of 9
Quote:
Originally Posted by Thaddeus8912 View Post

Thanks for such a quick reply, I get what your saying, I have tried leaving it for 30+ mins sometimes (if its a big file) and have come back and it has not progressed at all.

I am aware of the usual hang time towards the end when transferring but this issue is has become problematic eg before, I could select 1tb worth of files (400+ movies, 1.2gb to 8gb+ per file) and it would take a far few hours but it would write at a stable 180mb+ per second and have no issues, then one day, it decides that it wont even transfer a single file.

If I try to do a transfer like the one described above, it will hang at the end of transferring the first file and then just refuse to continue, even leaving it for 4+ hours and it did not progress past the first file.

I am officially stumped lol

Can you copy that specific file to another location (to make sure the problem is not with the file itself (corrupt filesystem or something))? If so, can you copy the file from this "other location" to your external drive?

Just out of interest, what file is this and how big is it?
Minimachine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-5775C Asus Maximus VII Impact EVGA GTX1080 Founders edition 2x8GB Kingston HyperX 1600Mhz 
Hard DriveMonitorPowerCase
Samsung 950 PRO 512GB M.2 NVMe 3x Asus PB287Q 4k Silverstone 600W Strider SFX NCASE M1 Rev 2 
  hide details  
Reply
Minimachine
(9 items)
 
  
CPUMotherboardGraphicsRAM
i7-5775C Asus Maximus VII Impact EVGA GTX1080 Founders edition 2x8GB Kingston HyperX 1600Mhz 
Hard DriveMonitorPowerCase
Samsung 950 PRO 512GB M.2 NVMe 3x Asus PB287Q 4k Silverstone 600W Strider SFX NCASE M1 Rev 2 
  hide details  
Reply
post #5 of 9
Thread Starter 
Yes and Yes.

Small files, photos/docx/pdf's transfer fine in all circumstances.

Any large files. I am trying to copy some movies and tv shows from my internal HDD's to some externals as network streaming is very problematic in this house and it is just easier to put onto a flash drive or external HDD and play it from the tv or etc.
post #6 of 9
Try doing the copy with TotalCopy, or XCOPY in a CMD prompt.
RYZEN
(14 items)
 
OFFICE PC
(12 items)
 
20TB_HOMENAS
(9 items)
 
CPUMotherboardGraphicsRAM
Ryzen 1700X ASRock Fatal1ty X370 Professional Gaming XFX 390x Corsair Vengeance LPX 64GB DDR4 
Hard DriveOptical DriveCoolingOS
A bunch of swappable SSDs LG BD-ROM Thermaltake CL-P039-AL12BL-A Contac Silent Windows 7 
MonitorKeyboardPowerCase
Generic Korean 32" 4K Generic mechanical rainbow LED lit SeaSonic G Series 550-Watt AZZA Helios 910 CSAZ-910 
MouseAudio
Logitech G500 T1 24BIT Tube USB DAC 
CPUMotherboardGraphicsRAM
AMD Athlon II X2 255 ASRock 970DE3/U3S3 Radeon X300 Kingston KHX1600C9D3/4GX 
Hard DriveHard DriveHard DriveHard Drive
8x Samsung HD204UI 7x Seagate ST2000DM001 Transcend TS16GSSD25-S 2x WD WD40EZRX 
Case
AZZA Helios 
  hide details  
Reply
RYZEN
(14 items)
 
OFFICE PC
(12 items)
 
20TB_HOMENAS
(9 items)
 
CPUMotherboardGraphicsRAM
Ryzen 1700X ASRock Fatal1ty X370 Professional Gaming XFX 390x Corsair Vengeance LPX 64GB DDR4 
Hard DriveOptical DriveCoolingOS
A bunch of swappable SSDs LG BD-ROM Thermaltake CL-P039-AL12BL-A Contac Silent Windows 7 
MonitorKeyboardPowerCase
Generic Korean 32" 4K Generic mechanical rainbow LED lit SeaSonic G Series 550-Watt AZZA Helios 910 CSAZ-910 
MouseAudio
Logitech G500 T1 24BIT Tube USB DAC 
CPUMotherboardGraphicsRAM
AMD Athlon II X2 255 ASRock 970DE3/U3S3 Radeon X300 Kingston KHX1600C9D3/4GX 
Hard DriveHard DriveHard DriveHard Drive
8x Samsung HD204UI 7x Seagate ST2000DM001 Transcend TS16GSSD25-S 2x WD WD40EZRX 
Case
AZZA Helios 
  hide details  
Reply
post #7 of 9
Thread Starter 
Thanks for the suggestion but I am looking for a long term solution as I am doing this on a very regular basis and am worried that this issue is due to hardware as I have tried every software option.
post #8 of 9
Is SpyBot 2 full professional edition the only antivirus installed?
post #9 of 9
Thread Starter 
UPDATE: So after much testing and frustration, I have done another complete format and reinstall in win7 and have figured out that the issue has been caused by the USB drivers (Etron USB3.0 - 1.1.0.115 from gigabyte website)

When it is installed, the issue arises, uninstall it and its very slow (usb 1.1 speeds) but it works.

After some searching, I found on the Etron website the latest drivers (1.1.0.118), installed and its back to working full speed and no hang issues.

Thanks for your suggestions, this was the only forum that gave me proper responses over monosyllabic throw aways.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › File transfers to external drives wont complete