Overclock.net › Forums › AMD › AMD Motherboards › Crosshair IV Formula Beta Bios Doesn't work with AM3 CPU?
New Posts  All Forums:Forum Nav:

Crosshair IV Formula Beta Bios Doesn't work with AM3 CPU?

post #1 of 2
Thread Starter 
Hey! I have a problem, I got rid of my FX8150 CPU and put that in another computer, however I put a amd athlon 620 x4 in there and it wont start up at all, it just turns on then turns off after half a second with a red cpu light. Is there anyway to flash the bios with another computer while it's turned off? Or is my board now bricked?
    
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 @3.742 ghz ASUS Prime Plus B350 AMD Radeon 7850 16 GB Corsair Vengeance LPX 
Hard DriveOptical DriveOSMonitor
Crucial MX300 525 GB Samsung Blu-ray rw Windows 7 Home Dell Ultrasharp 23 inch 
KeyboardPowerMouseMouse Pad
Logitech G910 Keyboard Corsair GS 700 Logitech G402 Mouse Saitek Cyborg silicon mouse pad 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 @3.742 ghz ASUS Prime Plus B350 AMD Radeon 7850 16 GB Corsair Vengeance LPX 
Hard DriveOptical DriveOSMonitor
Crucial MX300 525 GB Samsung Blu-ray rw Windows 7 Home Dell Ultrasharp 23 inch 
KeyboardPowerMouseMouse Pad
Logitech G910 Keyboard Corsair GS 700 Logitech G402 Mouse Saitek Cyborg silicon mouse pad 
  hide details  
Reply
post #2 of 2
It should work. The C4F BIOS has some bugs though, perhaps you triggered one of then when swapping CPUs? Try removing the battery from the motherboard for a while to completely reset the BIOS.
Test rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Sempron 145 @ 4.6GHz Asus M2N32-SLI Deluxe 8800GT Crucial Ballistix 4x1GB 
  hide details  
Reply
Test rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Sempron 145 @ 4.6GHz Asus M2N32-SLI Deluxe 8800GT Crucial Ballistix 4x1GB 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › Crosshair IV Formula Beta Bios Doesn't work with AM3 CPU?