Overclock.net › Forums › Components › Sound Cards and Computer Audio › Razer Megalodon and Windows 8
New Posts  All Forums:Forum Nav:

Razer Megalodon and Windows 8

post #1 of 4
Thread Starter 
I built a new PC recently running windows 8.1 and using for parts:
GPU: MSI gtx 780
PSU: seasonic 760watt
CPU: Intel I7 4770k
MB: MSI Z87-GD65
RAM: Patriot Viper 2x8GB DDR3 2133MHz
OS: Windows 8.1

Now my headset ran perfectly fine on my old pc and while looking around i have found many people are having problems with the megalodons on windows 8 what i have not found so far is any real fix to my problem the set runs fine for regular windows sounds but any application i run they get a crackling noise to them and the sound randomly dies off. This is my first time using widows 8 so I will admit I might not know the locations of somethings where I could have potentially fixed this problem on my own ..

Any help at all to fix this is really appreciated.
post #2 of 4
Quote:
Originally Posted by Fynx View Post

I built a new PC recently running windows 8.1 and using for parts:
GPU: MSI gtx 780
PSU: seasonic 760watt
CPU: Intel I7 4770k
MB: MSI Z87-GD65
RAM: Patriot Viper 2x8GB DDR3 2133MHz
OS: Windows 8.1

Now my headset ran perfectly fine on my old pc and while looking around i have found many people are having problems with the megalodons on windows 8 what i have not found so far is any real fix to my problem the set runs fine for regular windows sounds but any application i run they get a crackling noise to them and the sound randomly dies off. This is my first time using widows 8 so I will admit I might not know the locations of somethings where I could have potentially fixed this problem on my own ..

Any help at all to fix this is really appreciated.

Is it a continuous buzzing? Is the USB power cord plugged into the back of the motherboard or does it have an externally powered USB Hub?
Prometheus
(19 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7 3615QM Macbook Pro 2012 - Retina Chipset GeForce GT 650M 8GB DDR3L 1600 MHz 
Hard DriveOSMonitorCase
Apple/Samsung SSD Mountain Lion OSX 1.8.0.2 2880x1800 Macbook Pro 2012 15" 
MouseMouse Pad
Cyborg R.A.T. 7 Goliathus 
  hide details  
Reply
Prometheus
(19 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7 3615QM Macbook Pro 2012 - Retina Chipset GeForce GT 650M 8GB DDR3L 1600 MHz 
Hard DriveOSMonitorCase
Apple/Samsung SSD Mountain Lion OSX 1.8.0.2 2880x1800 Macbook Pro 2012 15" 
MouseMouse Pad
Cyborg R.A.T. 7 Goliathus 
  hide details  
Reply
post #3 of 4
Thread Starter 
Its continuous and its plugged into the back of the mother board
Iv tried driver and firmware updates
post #4 of 4
This is an easy fix, you are in luck.

I am sure you have AC to USB adapter for your phone? Just plug your headphone USB into that, and plug that into the extension cord/wall. Problem will be gone (99% sure.)

I learned that Razer doesn't ground the power coming into the headphones, its "raw". It's kind of lame but easily fixable, the power in the back of most motherboard USB ports isn't the cleanest.

Sorry for the late reply.

Source: My Tiamat 7.1's smile.gif
Prometheus
(19 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7 3615QM Macbook Pro 2012 - Retina Chipset GeForce GT 650M 8GB DDR3L 1600 MHz 
Hard DriveOSMonitorCase
Apple/Samsung SSD Mountain Lion OSX 1.8.0.2 2880x1800 Macbook Pro 2012 15" 
MouseMouse Pad
Cyborg R.A.T. 7 Goliathus 
  hide details  
Reply
Prometheus
(19 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7 3615QM Macbook Pro 2012 - Retina Chipset GeForce GT 650M 8GB DDR3L 1600 MHz 
Hard DriveOSMonitorCase
Apple/Samsung SSD Mountain Lion OSX 1.8.0.2 2880x1800 Macbook Pro 2012 15" 
MouseMouse Pad
Cyborg R.A.T. 7 Goliathus 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Razer Megalodon and Windows 8