Overclock.net › Forums › Components › Sound Cards and Computer Audio › Need help with a Sub-woofer setup
New Posts  All Forums:Forum Nav:

Need help with a Sub-woofer setup

post #1 of 2
Thread Starter 
Hey guys, I have a 15" Alpine Sub with a M500 Alpine powering it. I have 2 RCA's with audio signal, but the Voltage is way to high. The RCA's are made to go straight into speakers with more then 20 Volts. Max this Alpine Unit can take is 4!
Any type of Pre-Amp I could use? Rep will be given to all useful responses. Very desperate here. Thanks


I found these.
Edited by RussianC - 1/5/14 at 7:01pm
My Calculator
(13 items)
 
   
CPUMotherboardGraphicsRAM
i7 2670QM Asus G74SW Nvidia GTX 560M 2GB 16GB Samsung Stock 
Hard DriveCoolingOS
500GB + 1TB Samsung's Stock Windows 7 + Ubuntu 12.04 LTS  
  hide details  
Reply
My Calculator
(13 items)
 
   
CPUMotherboardGraphicsRAM
i7 2670QM Asus G74SW Nvidia GTX 560M 2GB 16GB Samsung Stock 
Hard DriveCoolingOS
500GB + 1TB Samsung's Stock Windows 7 + Ubuntu 12.04 LTS  
  hide details  
Reply
post #2 of 2
Thread Starter 
Anyone?
My Calculator
(13 items)
 
   
CPUMotherboardGraphicsRAM
i7 2670QM Asus G74SW Nvidia GTX 560M 2GB 16GB Samsung Stock 
Hard DriveCoolingOS
500GB + 1TB Samsung's Stock Windows 7 + Ubuntu 12.04 LTS  
  hide details  
Reply
My Calculator
(13 items)
 
   
CPUMotherboardGraphicsRAM
i7 2670QM Asus G74SW Nvidia GTX 560M 2GB 16GB Samsung Stock 
Hard DriveCoolingOS
500GB + 1TB Samsung's Stock Windows 7 + Ubuntu 12.04 LTS  
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Need help with a Sub-woofer setup