Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Issues with Conky. Help me please.
New Posts  All Forums:Forum Nav:

Issues with Conky. Help me please.

post #1 of 8
Thread Starter 
I installed it yesterday and tried to get it to display the temperature and usage of each of my four cores using a config file I've found on the internet. It displayed the core usage but didn't display the temperatures. Due to this issue, I decided to change a few things after some research. After a little while most of the numbers that are displayed have become overlapped. I have uninstalled and reinstalled Conky-all but it still occurs. Here is a screenshot of what it currently is showing me.

I hope someone can help me sort this out.
post #2 of 8
How did you configure conky? If you did it manually please post your conky config.

On another note, if you don't want to configure it manually I've heard good things about Conky Manager. It's basically a pretty nice GUI frontend for configuring conky.
post #3 of 8
Thread Starter 
I did it manually. It took a couple of tries but it finally outputs numbers correctly. I think I had the config. file like this for the temperatures and CPU usage.
Code:
alignment top_left
background no
border_width 1
cpu_avg_samples 2
default_color white
default_outline_color white
default_shade_color white
draw_borders no
draw_graph_borders yes
draw_outline no
draw_shades no
use_xft yes
xftfont DejaVu Sans Mono:size=12
gap_x 5
gap_y 60
minimum_size 5 5
net_avg_samples 2
no_buffers yes
out_to_console no
out_to_stderr no
extra_newline no
own_window yes
own_window_class Conky
own_window_type desktop
stippled_borders 0
update_interval 1.0
uppercase no
use_spacer none
show_graph_scale no
show_graph_range no

TEXT
${scroll 16 $nodename - $sysname $kernel on $machine | }
$hr
${color grey}Uptime:$color $uptime
${color grey}Frequency (in MHz):$color $freq
${color grey}Frequency (in GHz):$color $freq_g
${color grey}RAM Usage:$color $mem/$memmax - $memperc% ${membar 4}
${color grey}Swap Usage:$color $swap/$swapmax - $swapperc% ${swapbar 4}
${color grey}CPU Usage:$color $cpu% ${cpubar 4}
${color grey}Processes:$color $processes ${color grey}Running:$color $running_processes
$hr
${color grey}File systems:
/ $color${fs_used /}/${fs_size /} ${fs_bar 6 /}
${color grey}Networking:
Up:$color ${upspeed eth0} ${color grey} - Down:$color ${downspeed eth0}
$hr

${color #FFFFFF}Core 0:${goto 75}${color #FF0000} ${freq_g cpu1}GHz ${goto 170} ${color #FF0000}${hwmon 1 temp 1}°C ${color #FF0000}${goto 250}${cpu cpu1}% ${alignr}${color #FFFFFF}${cpubar cpu1 5,110}
${color #FFFFFF}Core 1:${goto 75}${color #FF0000} ${freq_g cpu2}GHz ${goto 170} ${color #FF0000}${hwmon 2 temp 1}°C ${color #FF0000}${goto 250}${cpu cpu2}% ${alignr}${color #FFFFFF}${cpubar cpu2 5,110}
${color #FFFFFF}Core 2:${goto 75}${color #FF0000} ${freq_g cpu3}GHz ${goto 170} ${color #FF0000}${hwmon 3 temp 1}°C${color #FF0000}${goto 250}${cpu cpu3}% ${alignr}${color #FFFFFF}${cpubar cpu3 5,110}
${color #FFFFFF}Core 3:${goto 75}${color #FF0000} ${freq_g cpu4}GHz ${goto 170} ${color #FF0000}${hwmon 4 temp 1}°C ${color #FF0000}${goto 250}${cpu cpu4}% ${alignr}${color #FFFFFF}${cpubar cpu4 5,110}

${color #FFFFFF}CPU Usage${goto 160}PID${goto 220}CPU%${goto 280}MEM%
${color #FF0000} ${top name 1}${goto 150}${top pid 1}${goto 220}${top cpu 1}${goto 280}${top mem 1}
${color #FFFFFF} ${top name 2}${goto 150}${top pid 2}${goto 220}${top cpu 2}${goto 280}${top mem 2}
${color #FFFFFF} ${top name 3}${goto 150}${top pid 3}${goto 220}${top cpu 3}${goto 280}${top mem 3}


I'm going to download Conky Manager. Thanks a lot for mentioning it as I've never heard of the program before.
post #4 of 8
No problem. Let me know how it goes. when I get home I'll try out your config to see if I can figure out why you're having the problems you are.

As an aside, in the future you'll probably want to post things like the conky config inside code tags, it's much easier to read that way.
post #5 of 8
Thread Starter 
Oh ok. I wasn't sure how to use the code tags since I've never used them before. Below "own_window yes" I had inserted "own_window_transparent yes". For some reason this seemed to be causing the problem but I'm not sure why. By the way, I had just got done trying out Conky Manager. It's a pretty cool program and it will suffice until I can get Conky configured the way I want it manually. biggrin.gif
post #6 of 8
Cool, glad it worked out for you.
post #7 of 8
Thread Starter 
Mind helping me with another Linux related question?
post #8 of 8
Not at all, shoot me a PM though if it isn't conky related so we don't get off topic in this thread.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Issues with Conky. Help me please.