Overclock.net › Forums › Components › Mice › problem with my new Zowie ec2 evo cl
New Posts  All Forums:Forum Nav:

problem with my new Zowie ec2 evo cl

post #1 of 7
Thread Starter 
well , i got the mouse today . And I got a problem. When I move the mouse real fast for a flick shot or to turn around , the cursor either sits still, or goes half way to where i wanted it, or goes up or down. I love everything else about this mouse, the shape , size , buttons, it moves smooth and accurate with very good response. But cannot use because it is not fast enough. I tried all dpi with 500 and 1000hz polling on 3 different mouse pads. Razer Goliathius, steelseries qck + plain black, and Roccat sense chrome blue. The razer deathadder that I was using did not fail at fast movements. On the enotus mouse test the highest value I got for the zowie was 2300dpi 1000hz 1.46m/s for the top speed. The deathadder got at the same dpi 2300 1000hz 4.53m/s. I do not need it to be as fast as the DA but I would atleast like to see around 3.00m/s.
post #2 of 7
I'd RMA it, sounds really faulty. 1.46m/s seems broken
Where did you order it from? I literally just placed an order for the exact same mouse on amazon us. Hope its not from the same batch lol.
post #3 of 7
Thread Starter 
superbiiz
post #4 of 7
it's definitely broken with only 1.46m/s on the mentioned mousepads.
PC
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon E3-1230v3  MSI Z87-G43 MSI GTX 970 Gaming 4G 16 GB Corsair Vengeance LP 
Hard DriveHard DriveHard DriveCooling
Samsung evo 830 120GB  Samsung evo 840 250GB 2x Samsung Spinpoint F1 Scythe Mugen 4 PCGH ed. 
OSMonitorKeyboardPower
Win 10 Pro x64  Acer Predator XB240HA(G-SYNC) Logitech G410  be quiet! Straight Power E7 580W 
CaseMouseMouse PadAudio
Corsair Carbide Series 300R Logitech G403(w/ paracord) Artisan Shiden Snow White L XSOFT  Soundblaster Z 
AudioAudio
Sennheiser HD-590 AKG K712 Pro 
  hide details  
Reply
PC
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon E3-1230v3  MSI Z87-G43 MSI GTX 970 Gaming 4G 16 GB Corsair Vengeance LP 
Hard DriveHard DriveHard DriveCooling
Samsung evo 830 120GB  Samsung evo 840 250GB 2x Samsung Spinpoint F1 Scythe Mugen 4 PCGH ed. 
OSMonitorKeyboardPower
Win 10 Pro x64  Acer Predator XB240HA(G-SYNC) Logitech G410  be quiet! Straight Power E7 580W 
CaseMouseMouse PadAudio
Corsair Carbide Series 300R Logitech G403(w/ paracord) Artisan Shiden Snow White L XSOFT  Soundblaster Z 
AudioAudio
Sennheiser HD-590 AKG K712 Pro 
  hide details  
Reply
post #5 of 7
Thread Starter 
this sucks, 2 to 4 week rma time ... they out of their whole freekin mind
post #6 of 7
Can you not get a direct replacement with the re-seller?
post #7 of 7
Thread Starter 
The rma process is with that seller
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › problem with my new Zowie ec2 evo cl