Overclock.net › Forums › Intel › Intel - General › Intel Graphics HDMI - no Audio? RESOLVED
New Posts  All Forums:Forum Nav:

Intel Graphics HDMI - no Audio? RESOLVED

post #1 of 7
Thread Starter 
I am unable to select audio via HDMI under Playback Devices.

My setup is:

- 1 monitor (gaming), 1 TV (movies)

I switch back and forth between the two depending on my activity, ie gaming or watching a movie. On my old AMD 7950 it would automatically select the correct audio depending on which monitor I had selected. In the rare event it didn't I would simply go into my Playback devices and select the appropriate output from there. Now, with the Intel Graphics there is no longer an option for audio via HDMI, only the soundcard shows up.

How do I resolve this? It's annoying to be watching a movie with no sound rolleyes.gif
post #2 of 7
do u have the onboard viaHD audio enabled in the bios?
are you also using ultra fastboot or have csm support set to never?
Edited by blaze0079 - 1/12/14 at 1:36pm
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2700k Extreme4 gen3 Evga Gtx 780 SC 16GB DDR3 1866 
Hard DriveHard DriveOptical DriveCooling
samsung Samsung Spinpoint F3 SAMSUNG HD103UJ DVD-RAM GH22NS30 NH-D14 
OSMonitorKeyboardPower
Windows 8 Qnix qx 2700 CM Trigger SilverStone Strider Plus 850w 
CaseMouseAudio
Haf X SteelSeries Sensei Creative Sound Blaster Z 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2700k Extreme4 gen3 Evga Gtx 780 SC 16GB DDR3 1866 
Hard DriveHard DriveOptical DriveCooling
samsung Samsung Spinpoint F3 SAMSUNG HD103UJ DVD-RAM GH22NS30 NH-D14 
OSMonitorKeyboardPower
Windows 8 Qnix qx 2700 CM Trigger SilverStone Strider Plus 850w 
CaseMouseAudio
Haf X SteelSeries Sensei Creative Sound Blaster Z 
  hide details  
Reply
post #3 of 7
do you have show disabled devices and show disconnected devices ticked?
post #4 of 7
You don't have computer Speakers? I would try to check Intel Control Panel.
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AMD Radeon R9 16GB DDR3-2400MHz  
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit Philips Brilliance BDM4065UC 4K Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AMD Radeon R9 16GB DDR3-2400MHz  
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit Philips Brilliance BDM4065UC 4K Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
post #5 of 7
Thread Starter 
Quote:
Originally Posted by blaze0079 View Post

do u have the onboard viaHD audio enabled in the bios?

I dont,

Quote:
Originally Posted by ClaggyPants View Post

do you have show disabled devices and show disconnected devices ticked?

Nothing unknown or disconnected.

Quote:
Originally Posted by ZealotKi11er View Post

You don't have computer Speakers? I would try to check Intel Control Panel.

I do have PC speakers. They are however hooked up to my PC's soundcard via analog out for when I use the monitor during gaming sessions. The TV is in another room - I run a 18ft HDMI cable from the room where I have my PC, to the TV in the living room. I use wireless KBM in the living room. This setup has always worked without any hitches when I was still using my AMD 7950. I would simply switch monitors from Display --> Screen Resolution and the audio output would switch along with it. Now it wont do that anymore and there is in fact not even an option to manually switch audio devices anymore.



Previously under "Sound" I would have an option to select either the Asus Soundcard OR AMD HDMI Audio. I expected to find a similarly named option for Intel Graphics Audio. There is nothing in the Intel HD Graphics Control Panel related to audio.

fwiw, I am using the latest Intel HD Graphics drivers (10.18.10.3368).
post #6 of 7
are you also using ultra fastboot or have csm support set to never in the bios? also enable the viaHD audio in the bios
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2700k Extreme4 gen3 Evga Gtx 780 SC 16GB DDR3 1866 
Hard DriveHard DriveOptical DriveCooling
samsung Samsung Spinpoint F3 SAMSUNG HD103UJ DVD-RAM GH22NS30 NH-D14 
OSMonitorKeyboardPower
Windows 8 Qnix qx 2700 CM Trigger SilverStone Strider Plus 850w 
CaseMouseAudio
Haf X SteelSeries Sensei Creative Sound Blaster Z 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2700k Extreme4 gen3 Evga Gtx 780 SC 16GB DDR3 1866 
Hard DriveHard DriveOptical DriveCooling
samsung Samsung Spinpoint F3 SAMSUNG HD103UJ DVD-RAM GH22NS30 NH-D14 
OSMonitorKeyboardPower
Windows 8 Qnix qx 2700 CM Trigger SilverStone Strider Plus 850w 
CaseMouseAudio
Haf X SteelSeries Sensei Creative Sound Blaster Z 
  hide details  
Reply
post #7 of 7
Thread Starter 
Quote:
Originally Posted by blaze0079 View Post

do u have the onboard viaHD audio enabled in the bios?
are you also using ultra fastboot or have csm support set to never?

That's what it was! I always had it disabled with the AMD card so I didn't think that would have any impact rolleyes.gif Thanks for pointing it out thumb.gif

/Resolved.
Edited by 8bitG33k - 1/12/14 at 1:54pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel - General
Overclock.net › Forums › Intel › Intel - General › Intel Graphics HDMI - no Audio? RESOLVED