Overclock.net › Forums › Intel › Intel CPUs › Xeon L5430 VT-x speedstep and ssse 4.1
New Posts  All Forums:Forum Nav:

Xeon L5430 VT-x speedstep and ssse 4.1 - Page 7

post #61 of 75
Thread Starter 
@rewease:
Gigabyte has two similar mainboards: GA-P35-DS4 and GA-EP35-DS4 with an "E".

(See here)
http://www.gigabyte.de/search/search.aspx?kw=p35-ds4#pr-1


Could you check that you have the GA-P35-DS4 not (GA-EP35-DS4)?

And what Board revision do you have?

After this is verified, could I mod the BIOS for you?

I recommend installing your Q6600, if not already, because that runs stable and is not so risky remodding your original BIOS.
After that you can still reinstall your Xeon
post #62 of 75
Thread Starter 
Quote:
Originally Posted by rewease View Post

@Vincent12

{...}
I followed the tutorials to the letter. The thing is that extraction of the original cpucodes with cbrom for those bioses yields an empty NCPUCODE.BIN file. Maybe the original codes are stored in a different way in those Gigabyte bioses.
The added cpucodes and the NCPUCODE.BIN are displayed properly in cbrom /D and the intel microcode tool after writing it back to the bios.bin.


I have also a Gogabyte Board EP45T-UD3LR with Award BIOS, and modding this BIOS went without problem, i'm optimistic your will work as well,
(if your adapter is not broken of course)

VT-x Speedstep and sse4.1 work on my Gigabyte Board.

Can I mod for you?
I would upload you the file here as zip file
post #63 of 75
I have the P35-DS4 without the E, revision 1.1. I went back to the Q6600 already as I need the machine for every day use, runs rock stable as always.

Sure, I would appreciate if you could mod the bios. Maybe I got something wrong after all. I included 2 files, F14 which is the latest currently provided by Gigabyte and F15b which is the most recent beta release. Saved the 15B from my machine since it was nowhere to be found on the net.

GA-P35-DS4original.zip 1283k .zip file
post #64 of 75
Thread Starter 
OK. I have already downloaded BIOS directly from Gigabyte Website for your P35-DS4

Ive downloaded BIOS F14 from all Board revision of that board and have run a file compare chexk. All Board revision of your board have same BIOS

Files are identical. Im modding now. I'll tell you if there shoulds be any problems and post the file when I'm finished smile.gif

[Edit]

Hey your zip file contains also a P45-DS4. N´But you said you have a P35-DS4. Do you also have a P45-DS4?

[Edit]

Your P35DS4.F14 BIOS file is not identical to my P35DS4.F14 from Gigabyte website. Maybe thats already modded somehow.

[Edit] Sry Im wrong . My mistake they are identcial I have started already to mod smile.gif
Edited by Vincent12 - 3/25/14 at 1:13pm
post #65 of 75
Thread Starter 
Ok I see now. You're right. After step 1 and 2 NCPUCODE.BIN has a size 0 Bytes frown.gif

It works with my EP45T-UD3LR BIOS, but with yours somehow it doesn't work.


Maybe I should try a different cbrom version
Edited by Vincent12 - 3/25/14 at 3:18pm
post #66 of 75
UPDATE: I managed to get it to work on a friends laptop running vista.

Cheers
Spart.

@Vincent12

Hope all is well with your stuff. I have been having some serious issues. I had a Asus Striker II NSE which was a gret board but very flaky one patched and Xeon installed.

I have now replaced it with a Gigabyte GA-EP45C-DS3R (rev. 1.0) so I am right back to the beginning. I cannot get the codes into the bios files. I am running the latest bios EP4CDS3R.F6a which flashed perfectly using QFlash. The good news is the board sees the Xeon but obviously VT-x etc. don't work as it only has the (0a) revisions not the (0b) revisions that the mod creates for the 1067a processors.

Can you help me out and mod the attached bios files?

I can then get the system back up and running my vm's.

Cheers
Spart GA-EP45C-DS3R.zip 1128k .zip file
Edited by sparticle - 4/6/14 at 5:53am
post #67 of 75
Thread Starter 
Hi Sparticle.

I've modded modded the BIOS for your GA-EP45C-DS3R.
Here's the zip file with modded F5 and F6a BIOS version for your GA-EP45C-DS3R

EP45C-DS3R-mod.zip 1148k .zip file

I was not necessary to make NCPUCODE.BIN one Byte smaller after step 1) and 2).
Number was already even, (not uneven).

When I looked at the end of NCPUCODE.BIN with hexedit, cbrom195 did not add a last zero Byte to it.

Good luck with flashing.

Seems to have added CPU microcodes successfully at least. smile.gif

You can check both modded files
intelmicrocodelist.exe ep4cds3r-mod.f5
intelmicrocodelist.exe EP4CDS3R-mod.F6a

You should see this new microcodes in modded BIOS

CPUID=10676 Rev=60F 2010/09/29 CRC=8FE1A243 Off=E0FE0 Size=1000 Plat=2
CPUID=10676 Rev=60F 2010/09/29 CRC=8FE1A207 Off=E1FE0 Size=1000 Plat=6
CPUID=1067A Rev=A0B 2010/09/28 CRC=B007E7B0 Off=E2FE0 Size=2000 Plat=2,6

We've seen now three different cases of CBROM195 working (Award BIOS)

1 It has a small bug to add a last zero Byte with some BIOS
2. It works without bug with other BIOS
3. It does not work at all with Gigabyte P35-DS4 by member rewease frown.gif. Tried with four different cbrom versions
Edited by Vincent12 - 4/7/14 at 4:22pm
post #68 of 75
@Vincent12

Many thanks for this. You probably missed the update at the top of my post that I got it to work on a friends laptop. But once again the original file from Gigabyte would not work. I had to flash the bios using the file from Gigabyte, then save it back to disk, then mod the saved version, then re-flash with the new modded saved file.

All worked perfectly then.


Cheers
Spart
post #69 of 75
Thread Starter 
I think I dit it same way with Gigabyte mainboard.
And there was no last zero byte to remove with the saved BIOS file when modding it?
post #70 of 75
Wow. This is giving me hope. I have a GA-P35-DS3L, and am hoping to install a Xeon E5450 into it. I have read that with the minor motherboard mod and LGA 775 adapter on the processor, that the P35 chipset should be compatible. However, I didn't realize that a BIOS mod would be needed to get it to work properly.

So, it sounds like without the BIOS mod, Speedstep, SSE 4.1, and VT-X will be non-functional. I'm not sure if I should care or not. Advice would be appreciated:
  1. I am transitioning from a 105-watt Core 2 processor to an 80-watt Xeon. So have a significant reduction in heat and electrical even without speedstep. Is it worth a BIOS mod to go even further?
  2. I have no current plans to use virtualization.
  3. Here's the rub... I don't know what SSE 4.1 does, but suspect it might impact my game and/or graphic uses for the computer.
I understand from reading other posts on this, that the new microcodes will probably not fit in the BIOS without removing something else to make room. What do you think? Worth it?

Thanks much.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › Xeon L5430 VT-x speedstep and ssse 4.1