Overclock.net › Forums › Distributed Computing › Distributed Computing - General › [Tutorial] Ultimate Guide to tweaking AMD CGMiner 3.7.2 Kalroth edition. SGMiner instructions included aswell. Get the most hash out of your GPU!
New Posts  All Forums:Forum Nav:

[Tutorial] Ultimate Guide to tweaking AMD CGMiner 3.7.2 Kalroth edition. SGMiner instructions included aswell. Get the most hash out of your GPU! - Page 12

post #111 of 226
Quote:
Originally Posted by kskwerl View Post

So I have 6 290X's in Windows 8.1 64 bit using these settings

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer.exe --auto-fan --temp-target 80 --temp-overheat 85 -I 13 --thread-concurrency 32765 --gpu-powertune 20

If I go above 13 it crashes LOL!!!!

Look at my joke hashes




Does anyone have any idea what would be causing this? I want to rip my hair out. My monitor is connected one of the DVI connections on one of the 290x's. I don't have a dummy plug vga (don't know if that matters)

i have 1 x 1500 watt psu and 850watt psu , the 1500w is connected to 4 x 290x's and the 850 is connected to 2 x 290x's

Friends don't let friends use Windows 8.1 for mining with that many GPU's. I had a huge struggle getting everything to work right on my rig and Windows 8.1 with the same settings I had used under Linux. Spent about 8 hours one day on the issue to no avail, just constant driver crashes, trying to clean up drivers, reinstalling, lockups, etc. Decided to try Windows 7 the next day and lo and behold, in about an hour I had everything working and reached my highest hash rates to date. This is with the same exact drivers and process I underwent in 8.1.
post #112 of 226
r9 290x Sapphier Tri-x





So Now Finally i Found Some Good settings for my 2 sapphire cards. I have been playing around with them for 2 days now

I'm getting about 960 Kh/s Out of them.. I can go To about 1000 kh/s but then the valid shares go Way down, To about 97%. At 960 i'm at 99,8 % valid That can be the internet connection to the pool bad

strangely the best settings for my for my 2 cards was exactly the same so others may get the same numbers as me

I use sgminer 4.1 and Catalyst version 13.12

This is the config raw paste



{

"pools" : [

{

"url" : "stratum+tcp://euro1.coinhuntr.com:3333",

"user" : "Ctheg.1",

"pass" : "x"

}

]

,

"intensity" : "21,21",

"xintensity" : "0,0",

"rawintensity" : "0,0",

"worksize" : "256,256",

"kernel" : "scrypt,scrypt",

"lookup-gap" : "2,2",

"thread-concurrency" : "32765,32765",

"shaders" : "0,0",

"gpu-threads" : "1,1",

"gpu-engine" : "1020-1020,1020-1020",

"gpu-fan" : "auto,auto",

"gpu-memclock" : "1500,1500",

"gpu-memdiff" : "0,0",

"gpu-powertune" : "10,10",

"gpu-vddc" : "0.000,0.000",

"temp-cutoff" : "95,95",

"temp-overheat" : "89,89",

"temp-target" : "85,85",

"api-mcast-port" : "4028",

"api-port" : "4028",

"expiry" : "1",

"failover-switch-delay" : "60",

"gpu-dyninterval" : "7",

"gpu-platform" : "0",

"log" : "5",

"no-pool-disable" : true,

"queue" : "1",

"scan-time" : "1",

"tcp-keepalive" : "30",

"temp-hysteresis" : "3",

"shares" : "0",

"kernel-path" : "/usr/local/bin"

}







If u want to try for 1000Kh/s U can increase the intensety to 23. And the gpu-powertune to aboute 20 That’s wher I got it to be stable but the invalid shairs was To hige so im sticking whit 960 kh/s



Iff u feel like it u can donaite som Litecoins Or Anoncoin To me

LTC : LLKrfmWMkJ7ZsetNjpb4pEJFquJ5iwNH3v

ANC: AYdBTNZdXv7jNqfG5R5rnVT2e1FKDwAf5S
post #113 of 226
XFX reference 290x epilda and default voltage


intensity" : "20",
"worksize" : "256",
"lookup-gap" : "2",
"thread-concurrency" : "32760",
"shaders" : "2816",
"gpu-engine" : "1055",
"gpu-memclock" : "1425",
"gpu-powertune" : "20",
"temp-cutoff" : "90",
"expiry" : "1",
"failover-only" : true,
"log" : "5",
"queue" : "0",
"scan-time" : "1",
"device" : "0",
"gpu-threads" : "1"
}
post #114 of 226

I'm a small miner that started out in January with a pair of mSI R7850 Twin Frozr 2GD5 OC I bought from a gamer moving up.
Looked at me funny when I said I was setting up a miner.

Stumbled around with settings on CGMiner 3.7.2 and cooling issues ( one card I got to 305~310 before getting above 80c, other 375kHz @74c) theyre in a game case with 2-200mm fans and 2-140mm fans with a controller set 100%. Got my best with 925/1100 and 1100/1250 - tc10000 - gthreads 2 - I13. Was getting some random win7 crashes, especially after hitting 'Q" to stop mining.

Studied your guide and made some plans. Downloaded the 3.7.3 Kalroth.
Next, I pulled the power supply out of the case ran my power cables from outside. Left the side cover off.
Started out with config file (used to just do bat) set as gthread 2,TC 8193, x-3 (that's ne to me too), 900/1200, others as you laid out..

Got it running and pumped it to 1100/1250 on both along with x to 4.
Wow this is nice and cool with 375 hash id never seen before out of both temp
63c and 71c.. let it run over night. Got brave today.

I put a little turbo fan on the case and started playing with memory and engine. Found it liked memory at 1250, Started pumping the engine. Went thru engine increases to 380,385,then 390...got to 395....398.....figured "What the hell" finished up at 1170/1250 - 65c and 78c.
Pulling JUST OVER 400kHz on both cards...no hw errors . Cool and stable.

Love the controls in the 3.7.3 Kalroth too. Oh and NO crashes anymore.

Thank you! Thank you!
Edited by Miner4wDC - 3/10/14 at 1:52pm
post #115 of 226
So I added a 2nd 290x to my rig, and did a fresh re-do of SGMiner to avoid issues, but now all I get is an empty black screen. I tried letting the miner spit out the config file to edit and see if it would work but I get nothing but a black screen. Is there something different you need to do when you have two cards instead of one? I thought you could just set the miner with the basic commands and it would automatically detect the hardware.
 
NAS4Free Server
(10 items)
 
 
CPUMotherboardGraphicsRAM
i7-950 3.8GHz EVGA X58 SLI LE EVGA GTX 970  16GB G.Skill Trident X 2400MHz 
Hard DriveHard DriveCoolingOS
Sandisk II Ultra Plus 960GB SSD Seagate Barracuda 2TB Some Supermicro HSF that is an NH-D12 knockoff Windows 7 Pro 
MonitorKeyboardPowerCase
Crossover 44K 40" 3840x2160 Das Mechanical  Silverstone 500 Watt 80+ Gold Phanteks Enthoo Pro 
MouseAudio
Razer Deathadder 2013 Creative Sound Blaster Z 
CPUMotherboardGraphicsRAM
AMD A4-5000 Kabini ASRock QC5000-ITX  Integrated 4GB Corsair Vengeance DDR3-1600 
Hard DriveHard DriveHard DriveOS
2TB Seagate Constellation Nas x2 RAID 1 Samsung 840 Pro 256GB 2TB Toshiba  NAS4Free 
PowerCase
Silverstone Strider 500 Watt 80+ Gold Fractal Design Node 804 
  hide details  
Reply
 
NAS4Free Server
(10 items)
 
 
CPUMotherboardGraphicsRAM
i7-950 3.8GHz EVGA X58 SLI LE EVGA GTX 970  16GB G.Skill Trident X 2400MHz 
Hard DriveHard DriveCoolingOS
Sandisk II Ultra Plus 960GB SSD Seagate Barracuda 2TB Some Supermicro HSF that is an NH-D12 knockoff Windows 7 Pro 
MonitorKeyboardPowerCase
Crossover 44K 40" 3840x2160 Das Mechanical  Silverstone 500 Watt 80+ Gold Phanteks Enthoo Pro 
MouseAudio
Razer Deathadder 2013 Creative Sound Blaster Z 
CPUMotherboardGraphicsRAM
AMD A4-5000 Kabini ASRock QC5000-ITX  Integrated 4GB Corsair Vengeance DDR3-1600 
Hard DriveHard DriveHard DriveOS
2TB Seagate Constellation Nas x2 RAID 1 Samsung 840 Pro 256GB 2TB Toshiba  NAS4Free 
PowerCase
Silverstone Strider 500 Watt 80+ Gold Fractal Design Node 804 
  hide details  
Reply
post #116 of 226
Guys , I am a bit confused here, I am using TeamViewer to control my miningPc,now when i try to start Kalroth CGminer 3.7.3 it starts and immediately closes , but when i try cgminer 3.7.2.
My hardware is:
GPU: Sapphire Tri-X OC
PSU : Corsair 1000 W (planning to add 2 more Tri-x)
RAM: 4 GB DDR 3 1333
My .bat file for Kalroth miner is :
Code:
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer --scrypt -o stratum+tcp://global.wemineltc.com:3335 
  
-g 1 
-w 512 
--lookup-gap 2
--xintensity 1100 
--thread-concurrency 20481 
-I 21 
--gpu-fan 76,75 
--temp-target 80 
--temp-overheat 90 
--temp-cutoff 95 
--gpu-engine 1030 
--gpu-memclock 1250 
--gpu-powertune 20
and for the standard cgminer 3.7.2
Code:
setx GPU_MAX_ALLOC_PERCENT 90
setx GPU_USE_SYNC_OBJECTS 1
cgminer --scrypt -o stratum+tcp://global.wemineltc.com:3335  -g 1 -w 512 --lookup-gap 2 --thread-concurrency 20481 -I 19 --gpu-fan 76,75 --temp-target 80 --temp-overheat 90 --temp-cutoff 95 --gpu-engine 1030 --gpu-memclock 1200 --gpu-powertune 20
I wonder if the problem is anywhere in the .bat file or that I am trying to start Kalroth cgminer 3.7.3 by TeamViewer? I am getting around 800-850 Kh/s.
post #117 of 226
Read the guide carefully, on the Kalroth. You can't use Intensity and Xintensity, its one or the other..


also the Kalroth strong suit is two thread the xIntensity matched to the Thread currency.
Try starting with this.

- g 2
-w 256
--lookup-gap 2
--xintensity 4
--thread-concurrency 8193
--gpu-fan 75
--temp-target 80
--temp-overheat 90
--temp-cutoff 95
--gpu-engine 1030
--gpu-memclock 1250
--gpu-powertune 0

If that doesn't get you started delete the engine and memory clock settings and let it start stock.
Also be sure and delete previous .Bin files in the folder. You can also do the fan settings and temp settings once you get going .
That's one of the great things about 3.7.3-Kalroth.
Good Luck
Edited by Miner4wDC - 3/13/14 at 3:11am
post #118 of 226
Oh, sorry I read somewhere that xIntensity overwrites Intensity , will give it a try.
Thanks.
post #119 of 226
I personally like using raw intensity on my miner, especially with mixed cards (290s, 270s). Allows me to use the best of both worlds on one instance of the miner,
post #120 of 226
Giving sgminer a go. Running a different instance for each GPU so they can each have a different worker name. I am noticing that the displayed kh/s is hihger than was 3.7.2 release was showing but the pool rate is about the same.

Hynix Powercolor TurboDuo 280x 3.7.2 700-730kH/s sgminer 715-740kH/s

Vmax 1100
Core 1020
Mem 1500
PT +0

Samsung Powercolor TurboDuo 280x 3.7.2 730-760kH/s sgminer 750-780kH/s

Vmax 1100
Core 1088
Mem 1600
PT +0

All using
TC 8193
I 13
G 2

Haven't done anymore experimenting yet.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Distributed Computing - General
Overclock.net › Forums › Distributed Computing › Distributed Computing - General › [Tutorial] Ultimate Guide to tweaking AMD CGMiner 3.7.2 Kalroth edition. SGMiner instructions included aswell. Get the most hash out of your GPU!