Overclock.net › Forums › Graphics Cards › AMD/ATI › PowerColor PCS+ R9 290?
New Posts  All Forums:Forum Nav:

PowerColor PCS+ R9 290? - Page 47

post #461 of 1176
Quote:
Originally Posted by taem View Post

What cpu? My 290 + 4670k @ 4.6 scores just barely higher at stock clocks, around 61 fps.
Taem, are you gonna give the new bios a shot?
Gaming Rig
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5-4670K Asrock Z87 Extreme6 Powercolor RX 480 G-skill Ripjaws x-series  
Hard DriveOptical DriveCoolingOS
Adata SPG 900X adata 120GB Antec H2O 620 Windows 10 
MonitorKeyboardPowerCase
MG279Q 27inch free sync CM Storm quickfire Seasonic 650W Fractal Design R5 
MouseMouse PadAudio
Logitech G502 ZERO Sennheiser PC-363D 
  hide details  
Reply
Gaming Rig
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5-4670K Asrock Z87 Extreme6 Powercolor RX 480 G-skill Ripjaws x-series  
Hard DriveOptical DriveCoolingOS
Adata SPG 900X adata 120GB Antec H2O 620 Windows 10 
MonitorKeyboardPowerCase
MG279Q 27inch free sync CM Storm quickfire Seasonic 650W Fractal Design R5 
MouseMouse PadAudio
Logitech G502 ZERO Sennheiser PC-363D 
  hide details  
Reply
post #462 of 1176
Quote:
Originally Posted by Tobiman View Post

Taem, are you gonna give the new bios a shot?

No, since my card is working fine. Like Charles Oakley said, if it ain't broke, don't break it.
my pc
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670k Asus Maximus VII Gene Powercolor PCS+ AXR9 290 Crucial Ballistix Sport Very Low Profile 
Hard DriveOptical DriveCoolingCooling
Crucial m500 SSD LG GGC H20L Bluray/HDDVD combo drive Watercool Heatkiller IV Pro all copper Alphacool NexXxoS XT45 420 radiator 
CoolingCoolingOSMonitor
Alphacool NexXxoS XT45 280 radiator Watercool Heatkiller GPU-X3 290X Windows 8.1 Qnix QX2710LED 27" 2560x1440 monitor 
KeyboardPowerCaseMouse
Logitech K360 wireless keyboard EVGA 1000w P2 Phanteks Enthoo Primo white Logitech Performance MX wireless mouse 
AudioOther
Cyber Acoustics 3602a Western Digital Red 6tb HDD 
  hide details  
Reply
my pc
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670k Asus Maximus VII Gene Powercolor PCS+ AXR9 290 Crucial Ballistix Sport Very Low Profile 
Hard DriveOptical DriveCoolingCooling
Crucial m500 SSD LG GGC H20L Bluray/HDDVD combo drive Watercool Heatkiller IV Pro all copper Alphacool NexXxoS XT45 420 radiator 
CoolingCoolingOSMonitor
Alphacool NexXxoS XT45 280 radiator Watercool Heatkiller GPU-X3 290X Windows 8.1 Qnix QX2710LED 27" 2560x1440 monitor 
KeyboardPowerCaseMouse
Logitech K360 wireless keyboard EVGA 1000w P2 Phanteks Enthoo Primo white Logitech Performance MX wireless mouse 
AudioOther
Cyber Acoustics 3602a Western Digital Red 6tb HDD 
  hide details  
Reply
post #463 of 1176
Quote:
Originally Posted by taem View Post

What cpu? My 290 + 4670k @ 4.6 scores just barely higher at stock clocks, around 61 fps.

I have a Core i5 3570k @ 4.2Ghz
post #464 of 1176
I also contact directly to powercolor and raymond:) 10 days ago about the problem. My card is @ powercolor office atm , they ve informed me about the new bios and they flashed the card. Don'T know if it fixed the card, gonna grab it today or tomorrow.Will inform you guys
post #465 of 1176
Quote:
Originally Posted by taem View Post

No, since my card is working fine. Like Charles Oakley said, if it ain't broke, don't break it.
same here my cards doing alright so im not touching the bios for anything,

im curious though what stock 12v you guys get on load, i get 11.65 for the most part, seen it flicker at 11.50 sometimes headscratch.gif
post #466 of 1176
Quote:
Originally Posted by DrClaw View Post

same here my cards doing alright so im not touching the bios for anything,

im curious though what stock 12v you guys get on load, i get 11.65 for the most part, seen it flicker at 11.50 sometimes headscratch.gif



Here is mine after couple if mins in valley
AMD Gamer
(16 items)
 
  
CPUMotherboardGraphicsRAM
core i5 6600k 4.4Ghz Gigabyte Z170-GAMING K3 Sapphire R9 290 Tri-x Kingston HyperX Savage DDR4 2x8gb 2800Mhz 
Hard DriveHard DriveHard DriveOptical Drive
SanDisk X400 512gb Samsung 840pro 128gb SSD WD Blue 1 TB WD10EZEX ASUS DRW-24F1ST  
CoolingCoolingOSMonitor
Cooler Master Hyper 212 EVO + Arctic F12 pwm pu... 120mm exhaust, 3x140mm Windows 10 pro 64bit Benq G2222HDL 
KeyboardPowerCaseMouse
CM Storm Devastator Thermaltake SPS-630M Fractal Design Define R4 window V7 Bloody 
  hide details  
Reply
AMD Gamer
(16 items)
 
  
CPUMotherboardGraphicsRAM
core i5 6600k 4.4Ghz Gigabyte Z170-GAMING K3 Sapphire R9 290 Tri-x Kingston HyperX Savage DDR4 2x8gb 2800Mhz 
Hard DriveHard DriveHard DriveOptical Drive
SanDisk X400 512gb Samsung 840pro 128gb SSD WD Blue 1 TB WD10EZEX ASUS DRW-24F1ST  
CoolingCoolingOSMonitor
Cooler Master Hyper 212 EVO + Arctic F12 pwm pu... 120mm exhaust, 3x140mm Windows 10 pro 64bit Benq G2222HDL 
KeyboardPowerCaseMouse
CM Storm Devastator Thermaltake SPS-630M Fractal Design Define R4 window V7 Bloody 
  hide details  
Reply
post #467 of 1176
got the card with special bios mad.gif

%50 fixed

before it was %7-10 slower now %3.5-5

still slower than it should

here are the new scores



post #468 of 1176
Quote:
Originally Posted by daymond View Post

got the card with special bios mad.gif

%50 fixed

before it was %7-10 slower now %3.5-5

still slower than it should

here are the new scores




Do you have a 290 PCS+ or a 290X PCS+? If the latest then just like me those are not good results sadsmiley.gif
post #469 of 1176
Quote:
Originally Posted by Schussnik View Post

Do you have a 290 PCS+ or a 290X PCS+? If the latest then just like me those are not good results sadsmiley.gif

290 pcs+

ran a few tests overclocked

12v drops 11.5v with load

1200-1650
valley 65.6 mad.gif

3d11 gpu 16200

overclocking doesnt effect performance as it should. Scores same as old bios when oc'ed

i'm bored with these cards, super cooling yet doesnt perform as 290
Edited by daymond - 4/3/14 at 10:28am
post #470 of 1176
Quote:
Originally Posted by daymond View Post

290 pcs+

ran a few tests overclocked

1200-1650
valley 65.6 mad.gif

3d11 gpu 16200

overclocking doesnt effect performance as it should. Scores same as old bios when oc'ed

i'm bored with these cards, super cooling yet doesnt perform as 290

you mind linking your 3DMark11 score?

nvm. i checked mine and i got 17300. 13.11 driver.
Edited by rdr09 - 4/3/14 at 10:35am
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › PowerColor PCS+ R9 290?