Overclock.net › Forums › Graphics Cards › AMD/ATI › PowerColor PCS+ R9 290?
New Posts  All Forums:Forum Nav:

PowerColor PCS+ R9 290? - Page 59

post #581 of 1176
Quote:
Originally Posted by DA77 View Post

Less then 2 months and fans are already making weird noises at low speed ( bellow 47%). At first i thought it was the PSU fan, but today i finally figured it was GPU frown.gif

Have you tried lubricating the fan motors? Should be a small problem compared to the underperforming issue. Nevertheless, it doesn't feel good to get burned.
post #582 of 1176
My card has been good to me for over a month..i thought i was the only one without problems until now.
my unigine benchmarks are starting to show lower scores .. looks like just about everybody is starting to or already has issues with their cards.
Im going to try run some benches in the next couple weeks and see if the scores get worse. I was getting around 2700 points on unigine valley 1.0, now its much less, im not even gonna say how bad it is but i feel like theres no point trying to rma assuming it is a bad batch. And whoever has their rma up let us know how that goes, hopefully they can figure out how to fix these cards or replace them with a new one.
post #583 of 1176
My PCS+ 290Xs are coming in from RMA either on Tuesday or Wednesday. Hopefully, the cards work as they should.
Edited by airisom2 - 4/13/14 at 3:28pm
post #584 of 1176
Hello Guys,

Just to let you know my 290 PCS+ seems now to be playing up as well, not from a performances perspective though.

I now get red dots artifacts after playing for while, leading ultimately to a game crash. My setup is the same as before, haven't changed anything and still not overclocking the card one bit. Any ideas?

Thanks
post #585 of 1176
Well, this doesn't sound good. Hoping mine doesn't degrade like a bunch of cases here. My firestrike score is low but I was willing to look past that because of the deal I got on it.
Primary
(13 items)
 
Secondary
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770k ASRock Z77 Extreme4 PowerColor Radeon R9 290X PCS+ Samsung (2x4GB) 
Hard DriveHard DriveCoolingOS
Intel 520 series 240GB WD Caviar Green 2TB Phanteks PH-TC14PE Win 7 64-bit 
PowerCaseMouseAudio
SeaSonic X650 Fractal Design Define R4 Razer DeathAdder Dayton APA 150 
Audio
Acoustic Research AR-90 
CPUMotherboardGraphicsRAM
i5 3350p Gigabyte GA-H77N-WIFI Asus GTX 970 HyperX Black (2x4GB) 
Hard DriveOSPowerCase
Samsung 840 Windows 7 64 bit Rosewill CAPSTONE-450 Cooler Master Elite 120 
  hide details  
Reply
Primary
(13 items)
 
Secondary
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770k ASRock Z77 Extreme4 PowerColor Radeon R9 290X PCS+ Samsung (2x4GB) 
Hard DriveHard DriveCoolingOS
Intel 520 series 240GB WD Caviar Green 2TB Phanteks PH-TC14PE Win 7 64-bit 
PowerCaseMouseAudio
SeaSonic X650 Fractal Design Define R4 Razer DeathAdder Dayton APA 150 
Audio
Acoustic Research AR-90 
CPUMotherboardGraphicsRAM
i5 3350p Gigabyte GA-H77N-WIFI Asus GTX 970 HyperX Black (2x4GB) 
Hard DriveOSPowerCase
Samsung 840 Windows 7 64 bit Rosewill CAPSTONE-450 Cooler Master Elite 120 
  hide details  
Reply
post #586 of 1176
https://docs.google.com/spreadsheets/d/1LxMwL1Ku6gWiU8bYvZnfx-yY3ODeiSXsdHVxuCWKESw/edit#gid=0

I have made a google doc, please log your issues and benchmark scores here
post #587 of 1176
Quote:
Originally Posted by Schussnik View Post

Hello Guys,

Just to let you know my 290 PCS+ seems now to be playing up as well, not from a performances perspective though.

I now get red dots artifacts after playing for while, leading ultimately to a game crash. My setup is the same as before, haven't changed anything and still not overclocking the card one bit. Any ideas?

Thanks

Maybe worth trying the new 290 bios or fiddling with the voltage. I would try lowering the clock first and then the voltage
post #588 of 1176
I hope this is not a case of Powercolor cheaping out too much on the Components.

But sadly, it looks like it is the case.
post #589 of 1176
Quote:
Originally Posted by Derion View Post

https://docs.google.com/spreadsheets/d/1LxMwL1Ku6gWiU8bYvZnfx-yY3ODeiSXsdHVxuCWKESw/edit#gid=0

I have made a google doc, please log your issues and benchmark scores here

Never really used google docs, but doesn't look like I have permission to edit it.
post #590 of 1176
Quote:
Originally Posted by Toth21 View Post

Never really used google docs, but doesn't look like I have permission to edit it.

Edit permission is now granted
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › PowerColor PCS+ R9 290?