Overclock.net › Forums › Graphics Cards › AMD/ATI › PowerColor PCS+ R9 290?
New Posts  All Forums:Forum Nav:

PowerColor PCS+ R9 290? - Page 61

post #601 of 1176
Received the bios update from Raymond, card seems to be functioning normally now. Time to sell devil.gif
Steins Gate
(17 items)
 
  
CPUMotherboardGraphicsRAM
R7 1700 ASUS X370 CH6 Gigabyte R9 290 2x8GB Trident Z @ 3200 C14 
Hard DriveHard DriveHard DriveCooling
960 Evo 850 Evo WD Blue 1TB Thermalright True Spirit 140 Direct 
MonitorKeyboardPowerCase
BenQ XL2730Z G413 EVGA 750w G2 CM MC5 
MouseMouse PadAudioAudio
G703 SS Qck Onboard Logitech Z906 
Audio
HD518 
  hide details  
Reply
Steins Gate
(17 items)
 
  
CPUMotherboardGraphicsRAM
R7 1700 ASUS X370 CH6 Gigabyte R9 290 2x8GB Trident Z @ 3200 C14 
Hard DriveHard DriveHard DriveCooling
960 Evo 850 Evo WD Blue 1TB Thermalright True Spirit 140 Direct 
MonitorKeyboardPowerCase
BenQ XL2730Z G413 EVGA 750w G2 CM MC5 
MouseMouse PadAudioAudio
G703 SS Qck Onboard Logitech Z906 
Audio
HD518 
  hide details  
Reply
post #602 of 1176
Quote:
Originally Posted by rv8000 View Post

Received the bios update from Raymond, card seems to be functioning normally now. Time to sell devil.gif

Could you also post your before and after results on the google doc?
post #603 of 1176
Quote:
Originally Posted by Derion View Post

Could you also post your before and after results on the google doc?

Added both results for you, didn't include uniengine. I'll update when I get a chance to run it tomorrow.
Steins Gate
(17 items)
 
  
CPUMotherboardGraphicsRAM
R7 1700 ASUS X370 CH6 Gigabyte R9 290 2x8GB Trident Z @ 3200 C14 
Hard DriveHard DriveHard DriveCooling
960 Evo 850 Evo WD Blue 1TB Thermalright True Spirit 140 Direct 
MonitorKeyboardPowerCase
BenQ XL2730Z G413 EVGA 750w G2 CM MC5 
MouseMouse PadAudioAudio
G703 SS Qck Onboard Logitech Z906 
Audio
HD518 
  hide details  
Reply
Steins Gate
(17 items)
 
  
CPUMotherboardGraphicsRAM
R7 1700 ASUS X370 CH6 Gigabyte R9 290 2x8GB Trident Z @ 3200 C14 
Hard DriveHard DriveHard DriveCooling
960 Evo 850 Evo WD Blue 1TB Thermalright True Spirit 140 Direct 
MonitorKeyboardPowerCase
BenQ XL2730Z G413 EVGA 750w G2 CM MC5 
MouseMouse PadAudioAudio
G703 SS Qck Onboard Logitech Z906 
Audio
HD518 
  hide details  
Reply
post #604 of 1176
Quote:
Originally Posted by rv8000 View Post

Received the bios update from Raymond, card seems to be functioning normally now. Time to sell devil.gif

can you give me a copy of yours? smile.gif tested tweb21's bios and there was a little improvement, want to see if yours will be any different. Thanks man
post #605 of 1176
I have had no response from Raymond.
Odd Ball
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-9590 Asus Sabertooth 990FX Gigabyte WF3 OC GTX 970 Hyper-X Savage 2400Mhz 
Hard DriveOptical DriveCoolingOS
Samsung 830 SSD Samsung NZXT KRAKEN X31 Win 10 x64 
MonitorKeyboardPowerCase
LG IPS226 Logitech G110 XFX 750w Pro CM HAF 912+ 
MouseMouse Pad
Schakron Fireglider CMStorm 
  hide details  
Reply
Odd Ball
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-9590 Asus Sabertooth 990FX Gigabyte WF3 OC GTX 970 Hyper-X Savage 2400Mhz 
Hard DriveOptical DriveCoolingOS
Samsung 830 SSD Samsung NZXT KRAKEN X31 Win 10 x64 
MonitorKeyboardPowerCase
LG IPS226 Logitech G110 XFX 750w Pro CM HAF 912+ 
MouseMouse Pad
Schakron Fireglider CMStorm 
  hide details  
Reply
post #606 of 1176
After comparing custom bioses that came from powercolor, it seems we all received the same BIOS fix[even the bios that was sent to me is the same, i was wrong saying it was different]. I'm glad that it worked for some people here.

Unfortunately the bios does not seem to fix some cards still. My card is sadly one of them. Not sure if Powercolor would still proceed to troubleshoot, but i believe for now RMA is inevitable.


Again many thanks to the guys that shared me their custom bios.
post #607 of 1176
Quote:
Originally Posted by wako7654 View Post

After comparing custom bioses that came from powercolor, it seems we all received the same BIOS fix[even the bios that was sent to me is the same, i was wrong saying it was different]. I'm glad that it worked for some people here.

Unfortunately the bios does not seem to fix some cards still. My card is sadly one of them. Not sure if Powercolor would still proceed to troubleshoot, but i believe for now RMA is inevitable.


Again many thanks to the guys that shared me their custom bios.

You sure you want to go through the RMA process? They will just look for artifacts and return the same card to you, or send you another with the same issue.
post #608 of 1176
Quote:
Originally Posted by Derion View Post

You sure you want to go through the RMA process? They will just look for artifacts and return the same card to you, or send you another with the same issue.

I really don't want to go through it, but it seems like our only choice for now. Ill be away from work in 1 or 2 months and going somewhere else for vacation, i think by then if there is no resolution i will send it for RMA in that time frame. If it still does not work, then just my luck i guess
post #609 of 1176
Quote:
Originally Posted by Abundant Cores View Post

I have had no response from Raymond.

Just a heads up but for some reason gmail accounts are blocking emails with the bios. I had to give raymond a yahoo email to receive it.
post #610 of 1176
I have updated the google spreadsheet with 290 PCS+ results, which is the card who always performed fine. It is clear looking at people results on the spreadsheet that a lot of you are experiencing the "slow performances" issue.

I find it more and more difficult to believe that the root cause of the problem is just a batch of cards with a "bad bios" issue.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › PowerColor PCS+ R9 290?