Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Is it possible to adjust Windows 7 low memory warning levels?
New Posts  All Forums:Forum Nav:

Is it possible to adjust Windows 7 low memory warning levels? - Page 3

post #21 of 37
Thread Starter 
Quote:
Originally Posted by latelesley View Post

smile.gif yeah it may be long. I've not watched it yet, but I know of Mark Russinovich's work, he did the sysinternals site before microsoft took him on, and he knows how windows works inside out. Also responsible for tools like process explorer etc. He knows his stuff.

Yeh I was reading an article this guy wrote about the pagefile on technet the other day actually. It made me feel that it's not best to disable it all together. But I didn't fully understand it all. So that's why I thought I'd start doing some testing tongue.gif Watching the video now btw..

Quote:
Originally Posted by Bearybear View Post

I understand what your saying, it's just that it's been covered so many times with the same conclusion yet people are still frustratingly dedicated to it.

Either way: what edition of Windows 7 are you using? Because I'm sure there's are group policy setting that will disable the warnings, if not the reg key looks like your best bet, since I'm pretty sure there's no way of making the warning any smaller. This could be entirely wrong but AFAIK you can't change the low memory warning, because I'd assume you get the warning when RAM/paging is genuinely full, at which stage it'll purge some stuff and use that space whilst giving you the nice little error, what that means is basically some applications and processes will be killed and your game might crash.

Yeh I know man. I've read a lot of forums and seen lots of people ask about it over the past few years since SSD's became more of a normal thing to have. I've seen so much conflicting info. And wasn't convinced that it was a good idea to disable it all together simply based on the fact that you have lots of physical ram. But I just wanted to test out what would happen in different scenarios. Hence why I wanted to control the low memory warning. I wanted to see what would happen, but didn't want it to keep minimising games when I'm playing them.

I'm using W7 Pro x64. From seaching around on the net it looks like you might not be able to adjust the setting. I mean, I at least can't find anything on it other than how to disable it all together. But I just thought that maybe there was a registry hack or something tongue.gif It's just a bit irritating that some of these modern games rely on having pagefile to this extent. They're using it when there is still plenty of physical ram available.. I would prefer them to just stay in the physical ram. So far from running a few tests it seems that I get better performance in some games with the pagefile disabled. Obviously because the ram is faster (It's usually games with big streaming worlds). So this is one thing that's really made me want to minimise pagefile usage. It's also a nice bonus that it saves a bit of thrashing of the SSD smile.gif
Edited by ET900 - 2/14/14 at 4:53pm
post #22 of 37
that's why my page file is on a standard hdd and not my ssd.my wife has been with intel corp for 18 years, we have a very good friend at Microsoft in Renton up the freeway from us as we live in Olympia, anyway I called David at Microsoft and you cannot disable the warning unless you know your way around the registry and he suggested you don't. anyway he said the best thing to do is let windows manage your page file and if your worried about your ssd lasting have the page file on a hdd like I do even though he said to write and delete enough info on a ssd to cause it to fail you would have to do 190GB a day.
Old X58
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 970 6 core ASUS Sabertooth X58 MSI GTX 1070 Gaming X GSkill 24 gigs 
Hard DriveHard DriveHard DriveCooling
Crucial MX100 256 gig Crucial M500 120gig WD VelociRaptor 1TB Noctua 
OSMonitorMonitorKeyboard
Windows 7 Pro 64bit LG 29inch widescreen DP LG 29inch widescreen DP Corsair K65 
PowerCaseMouseAudio
EVGA SuperNova G2 1000w Corsair C70 Corsair M65 Sound Blaster Z 
Other
Custom sleeved psu cables 
  hide details  
Reply
Old X58
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 970 6 core ASUS Sabertooth X58 MSI GTX 1070 Gaming X GSkill 24 gigs 
Hard DriveHard DriveHard DriveCooling
Crucial MX100 256 gig Crucial M500 120gig WD VelociRaptor 1TB Noctua 
OSMonitorMonitorKeyboard
Windows 7 Pro 64bit LG 29inch widescreen DP LG 29inch widescreen DP Corsair K65 
PowerCaseMouseAudio
EVGA SuperNova G2 1000w Corsair C70 Corsair M65 Sound Blaster Z 
Other
Custom sleeved psu cables 
  hide details  
Reply
post #23 of 37
Why do you still have it on the HDD then?
post #24 of 37
Quote:
Originally Posted by Bearybear View Post

Why do you still have it on the HDD then?


just never thought about the page file thing since I was giving the info until today. smile.gif
so I guess I could say I just haven't gotten around to it.
Old X58
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 970 6 core ASUS Sabertooth X58 MSI GTX 1070 Gaming X GSkill 24 gigs 
Hard DriveHard DriveHard DriveCooling
Crucial MX100 256 gig Crucial M500 120gig WD VelociRaptor 1TB Noctua 
OSMonitorMonitorKeyboard
Windows 7 Pro 64bit LG 29inch widescreen DP LG 29inch widescreen DP Corsair K65 
PowerCaseMouseAudio
EVGA SuperNova G2 1000w Corsair C70 Corsair M65 Sound Blaster Z 
Other
Custom sleeved psu cables 
  hide details  
Reply
Old X58
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 970 6 core ASUS Sabertooth X58 MSI GTX 1070 Gaming X GSkill 24 gigs 
Hard DriveHard DriveHard DriveCooling
Crucial MX100 256 gig Crucial M500 120gig WD VelociRaptor 1TB Noctua 
OSMonitorMonitorKeyboard
Windows 7 Pro 64bit LG 29inch widescreen DP LG 29inch widescreen DP Corsair K65 
PowerCaseMouseAudio
EVGA SuperNova G2 1000w Corsair C70 Corsair M65 Sound Blaster Z 
Other
Custom sleeved psu cables 
  hide details  
Reply
post #25 of 37
Quote:
Originally Posted by ET900 View Post

Jesus Christ... I know people are trying to help. I appreciate that.

It's hard to be believe you appreciate it. If anything you are the one being offensive.

Some of the members here (who have been here longer than me) are just trying to help you and here you are throwing out accusations like "trolling". You obviously have a warped definition of that word. To me a troll goes out his/her way to cause trouble and makes comments to foment a fight.
Quote:
Originally Posted by ET900 View Post

...some people always think they know better and try to give you advice you're really not interested in. It's borderline trolling in my opinion!
post #26 of 37
Thread Starter 
Quote:
Originally Posted by jlhawn View Post

that's why my page file is on a standard hdd and not my ssd.my wife has been with intel corp for 18 years, we have a very good friend at Microsoft in Renton up the freeway from us as we live in Olympia, anyway I called David at Microsoft and you cannot disable the warning unless you know your way around the registry and he suggested you don't. anyway he said the best thing to do is let windows manage your page file and if your worried about your ssd lasting have the page file on a hdd like I do even though he said to write and delete enough info on a ssd to cause it to fail you would have to do 190GB a day.


Thanks for checking that out! The thrashing of ssd was the smaller part of the concern for me tbh. I was more bugged about the performance. My ssd has limited space as well. So it's nice to free some it up with a smaller pagefile smile.gif So there is a way of changing this in the registry then it seems. I might have to dig a bit deeper and see what I find. I like looking into things like this, even if I don't end up doing them tongue.gif
Quote:
Originally Posted by DaChosenOne View Post

It's hard to be believe you appreciate it. If anything you are the one being offensive.

Some of the members here (who have been here longer than me) are just trying to help you and here you are throwing out accusations like "trolling". You obviously have a warped definition of that word. To me a troll goes out his/her way to cause trouble and makes comments to foment a fight.

God this seems inevitable. Every single thread on the internet ever.... Always descends into this. I said I considered it borderline trolling when people keep trying to give you information you're not interested in. It's like harassment. Which is what trolls do. Purposely trying to steer the conversation away from where it was intended to go. But I'm not saying anyone here is actually a troll. It's just frustrating when you want to know the answer to one thing, then people start trying to tell you other things. Sometimes there is a good reason for that. I understand the intent with help like that. We all do it. But when you specifically state that you don't want that advice, yet people keep giving you it, it's just a waste of time for you and them. I'm not trying to talk badly about anyone here. I just wanted to be clear that I'm not interested in discussing the pagefile. I just wanted to know if there was a way to control the out of memory message. I don't care if anyone thinks that's a bad idea or not. Overclocking your cpu is not a good idea. Go ask the cpu manufacturers or the store you bought your components from. They're experts right? They'll tell you it's not a good idea and that they don't recommend it. Yet here we are on a site which is primarily about what? Yes exactly. We all take risks with our setups by doing these things. It's ok wink.gif

Again, I appreciate all the help everyone's offered. My intentions are not to offend anyone!
post #27 of 37
Okay, I just found what I believe is the correct group policy object, go to:

Local Computer Policy
>Computer Configuration
>Administrative Templates
>System
>Troubleshooting and Diagnostics
>Resource Exhaustion Detection and Resolution

Then set "Configure Scenario Execution Level" to "Disabled".

That should stop you getting the low memory messages, however it might cause you more issues than is solves if memory is a genuine problem.
Edited by Bearybear - 2/14/14 at 6:52pm
post #28 of 37
Thread Starter 
Quote:
Originally Posted by Bearybear View Post

Okay, I just found what I believe is the correct group policy object, go to:

Local Computer Policy
>Computer Configuration
>Administrative Templates
>System
>Troubleshooting and Diagnostics
>Resource Exhaustion Detection and Resolution

Then set "Configure Scenario Execution Level" to "Disabled".

That should stop you getting the low memory messages, however it might cause you more issues than is solves if memory is a genuine problem.

Hey thanks man smile.gif The state of mine just says "Not configured" at the moment. But is this just a way to disable the messages all together I take it? If so, it's better than the registry method I reckon. I'm a bit tired now, but I will have a look into what you can do with those settings there tomorrow. I appreciate the help mate. Thanks smile.gif
post #29 of 37
Quote:
Originally Posted by ET900 View Post

Hey thanks man smile.gif The state of mine just says "Not configured" at the moment. But is this just a way to disable the messages all together I take it? If so, it's better than the registry method I reckon. I'm a bit tired now, but I will have a look into what you can do with those settings there tomorrow. I appreciate the help mate. Thanks smile.gif
I don't know why anyone as complaining about disabling the 'Out of Memory' warnings as I routinely ignore them myself clicking the 'Cancel' button every time one shows up since I always seam to get them every 5 minutes and still have 1.5GB of RAM still 'Available' I ignore them till Chrome crashes or Windows Explorer starts malfunctioning. Disabling the Warning can result in program and/or system crashed or loss of data but I personally have been sick and tired of seeing them pop up every 5 GD minutes when I have plenty of RAM and Page file available and there is no way to adjust it. And I am not a gamer to I just do typical computing.

I have found out a few things though that may be interesting:
First the revelations of what I found in various forums of hundreds of users getting the same warnings:
1. It doesn't matter how much RAM you have. You may still get them. I increased my RAM from 4GB to 6GB and still got them
2. Google Chrome seams to be one big app that doesn't play well (memory leakage)with memory. I had someone tell me that it was because I had 200 browser tabs open. That is BS since I closed half of them and still received the warnings. Then only 50 tabs and still got them all after upgrading to 6GB or RAM and with a ratio of 1x for the page file a total of 12GB virtual memory. I know I don't even come close to using 12GB of VM
3. Seams to effect other applications other than Chrome as , like I said, Windows Explorer starts at times to mess up if Chrome does''eventually crash. Also I had the issue with Waterfox and IE. Seams like all browsers have memory management issues these days.
4. Tends to happen for most users when they reach about 3/4 of their RAM or VM being used and having about 1/4 listed in TM as 'Available'

Possible FIX other than disabling the warnings:
There seams to be some discussion that I have found that effect systems from Vista onward ..... namely more so XP, Widow 7, and Window 8 as the NT familly tends to suffer more in some way. It is called the 'Desktop Heap' setting
To be clear, we are not talking about the desktop you see on your display monitor with all of the icons and task bar. Every service, handle, app, window ect. is assigned an individual desktop out of the Desktop Heap. Even services that run behind the scenes that do not have UI windows.

This got me thinking that even though there are many places on the web where you can read others saying that disabling the 'Superfetch' and its original predecessor, Prefetch in Windows does not do anything to improve or contribution to memory management issues or problems but when these things (applications that you MAY use because you used them every day at the same time) are loaded by the OS's Superfetch to take full advantage of RAM and make using RAM more efficient, it contributes to Desktop Heap depletion because all of thes things loaded will use its own portion of the Desktop Heap. There is only so much and is not Dynamic (something like 10MB or 20MB). So when it is used up, the system says there is no more addressing for virtual address space regardless of you having available memory.

This may be why some report that 'Disableing' Superfetch has improved or fixed this issue as it free up more of this 'Desktop Heap' and leaves more headroom. I personally think that this is like someone (Microsoft) putting baby oil in your cars window washer fluid reservoir (setting this Desktop Heap' at a predetermined number and designing Windows Memory Management to only use 75-80% and then redesign Prefetch to use more memory and Desktop Heap space loading more things in memory calling this improvement 'Superfetch) and then since every time you turn on the windshield washers it just smears (you get 'Out of Memory' warning with typical , average computing), you decide to rip off your wiper blades or disable you windshield wiper/washer switch (Disable Superfetch) to gain a smear and streak free windshield (no more 'Out of Memory' warnings). But then you can't clean your windshield very easily (the joys and benefits of Superfetch don't work anymore) since you didn't eliminate, fix or in any way address the cause of the issue ... like dumping and flushing the baby oil out of your windshield washer fluid reservoir.

What I figured out and decided to do:
After going to many sites to figure out what it was, what it was used for and how best to adjust it I came to the conclusion (just today) that I would try today to adjust it via the MSDN instructions found at, http://support.microsoft.com/kb/947246

MSDN Steps
To resolve this problem, modify the desktop heap size. To do this, follow these steps:
Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list.

Note If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\SubSystems
Right-click the Windows entry, and then click Modify.
In the Value data section of the Edit String dialog box, locate the SharedSection entry, and then increase the second value and the third value for this entry.

I figured that I would adjust the 3rd value to 1024 as mine was orig. set to 768

Other supporting sites talking about this issue which I used are:
http://support.microsoft.com/kb/126962
http://blogs.msdn.com/b/ntdebugging/archive/2007/01/04/desktop-heap-overview.aspx
In this blogs.msdn URL there is a link to a video .... which actually takes you to another page where the real link is that I highly recomend that explains what Desktop Heap is in a consice, easy to understand way which I will post the link for your convenience below.
http://channel9.msdn.com/Blogs/jeff_dailey/ntdebugging-blog-talk-about-on-desktop-heap
Edited by Richman - 3/5/14 at 11:33pm
post #30 of 37
Thread Starter 
Quote:
Originally Posted by Richman View Post

I don't know why anyone as complaining about disabling the 'Out of Memory' warnings as I routinely ignore them myself clicking the 'Cancel' button every time one shows up since I always seam to get them and still have 1.5GB of RAM still 'Available' I ignore them till Chrome crashes to Windows Explorer starts malfunctioning. Disabling the Warning can result in program and/or system crashed or loss of data but I personally have been sick and tired of seeing them pop up every 5 GD minutes when I have plenty of RAM and Page file available and there is no way to adjust it. And I am not a gamer to I just do typical computing.

I have found out a few things though that may be interesting:
First the revelations of what I found in various forums of hundreds of users getting the same warnings:
1. It doesn't matter how much RAM you have. You may still get them. I increased my RAM from 4GB to 6GB and still got them
2. Google Chrome seams to be one big app that doesn't play well with memory. I had someone tell me that it was because I had 200 browser tabs open. That is BS since I closed half of them and still received the warnings. Then only 50 tabs and still got them all after upgrading to 6GB or RAM and with a ratio of 1x for the page file a total of 12GB virtual memory. I know I don't even come close to using 12GB of VM
3. Seams to effect other applications other than Chrome as , like I said, Windows Explorer starts at times to mess up if Chrome does''eventually crash.
4. Tens to happen for most users when they reach about 3/4 of their RAM orVM beiingused and having about 1/4 listed in TM as 'Available'

Possible FIX other than disabling the warnings:
There seams to be some discussion that I have found that effect systems from Vista onward ..... namely Widow 7 called the 'Desktop Heap' setting
To be clear, we are not talking about the desktop you see on your display monitor with all of the icons and task bar. Every service, handle, app, ect. is assigned an individual desktop out of the desktop heap. This got me thinking that even though there are many places on the web where you can read that disabling the original Prefetch and 'Superfetch' in Windows 7 does not do anything to improve or contribution to memory management issues or problems but when these things are loaded by the OS to take full advantage of RAM and make using RAM more efficient and it is using up more or the Desktop Heap and is just contributing to the problem since depleting the Desktop Heap is what will throw out the warnings.

What I figured out and decided to do:
After going to many sites to figure out what it was, what it was used for and how best to adjust it I came to the conclusion (just today) that I would try today to adjust it via the MSDN instructions found at, http://support.microsoft.com/kb/947246
To resolve this problem, modify the desktop heap size. To do this, follow these steps:
Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list.

Note If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\SubSystems
Right-click the Windows entry, and then click Modify.
In the Value data section of the Edit String dialog box, locate the SharedSection entry, and then increase the second value and the third value for this entry.

I figured that I would adjust the 3rd value to 1024 as min was set to 768

Other supporting sites talking about this issue which I used are:
http://support.microsoft.com/kb/126962
http://blogs.msdn.com/b/ntdebugging/archive/2007/01/04/desktop-heap-overview.aspx

Good find! Thanks for the info! I will give this a go shortly before I reinstall windows later in the month smile.gif I ended up disabling the pagefile today to test that way for a bit. Sick of having my games minimized all the time to get the low memory warning when I have 3GB+ of ram free!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Is it possible to adjust Windows 7 low memory warning levels?