Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › How do I shut Windows up?
New Posts  All Forums:Forum Nav:

How do I shut Windows up? - Page 2

post #11 of 13
Quote:
Originally Posted by Darkwizzie View Post

Nope, didn't work.

If my suggestion did not work, did you try the registry edit given by Vagrant Storm?
post #12 of 13
Quote:
Originally Posted by DaChosenOne View Post

If my suggestion did not work, did you try the registry edit given by Vagrant Storm?

    You mean the "HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM\UseMachineCheck" tweak?  That shouldn't affect anything since Windows 7 SP1 doesn't even look at that value.  I believe that setting was for Vista.

    Anyway, I ran a trace and found these valid registry settings for DWM in Windows 7 SP1: List of all registry settings for DWM in Windows 7 (Click to show)
XP style (non-blurry) DPI scaling setting (in access order)
HKU\.DEFAULT\Software\Microsoft\Windows\DWM\UseDpiScaling
HKLM\Software\Microsoft\Windows\DWM\UseDpiScaling
HKCU\Software\Microsoft\Windows\DWM\UseDpiScaling

Shared system and user settings (in access order)
HKCU\Software\Microsoft\Windows\DWM\AnimationsShiftKey
HKLM\Software\Microsoft\Windows\DWM\AnimationsShiftKey
HKCU\Software\Microsoft\Windows\DWM\DisableDynamicShutdownUI
HKLM\Software\Microsoft\Windows\DWM\DisableDynamicShutdownUI
HKCU\Software\Microsoft\Windows\DWM\DisableLockingMemory
HKLM\Software\Microsoft\Windows\DWM\DisableLockingMemory

Shared system and user policies (in access order)
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowAnimations
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowAnimations
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowColorizationColorChanges
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowColorizationColorChanges
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowComposition
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowComposition
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowFlip3D
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowFlip3D
HKLM\Software\Policies\Microsoft\Windows\DWM\DefaultColorizationColorState
HKCU\Software\Policies\Microsoft\Windows\DWM\DefaultColorizationColorState

User settings (in access order)
HKCU\Software\Microsoft\Windows\DWM\Composition
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy
HKCU\Software\Microsoft\Windows\DWM\ColorizationColor
HKCU\Software\Microsoft\Windows\DWM\ColorizationColorBalance
HKCU\Software\Microsoft\Windows\DWM\ColorizationAfterglow
HKCU\Software\Microsoft\Windows\DWM\ColorizationAfterglowBalance
HKCU\Software\Microsoft\Windows\DWM\ColorizationBlurBalance
HKCU\Software\Microsoft\Windows\DWM\ColorizationGlassReflectionIntensity
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend

System settings (in access order)
HKLM\System\CurrentControlSet\services\nvlddmkm\DisableDWMContexts
HKLM\Software\Microsoft\Windows\DWM\DisableDeviceBitmaps
HKLM\Software\Microsoft\Windows\DWM\Schedule\FrameRateMin
HKLM\Software\Microsoft\Windows\DWM\Schedule\MoveSize\FrameRateMin

Any settings not in this list will be ignored since Windows doesn't even check their values.


    @Darkwizzie: I have never had this problem myself so I am unable to attack it on my own, but I do have some suggestions for you to try (one at a time, please):
  • Create a dWord value named DisableDynamicShutdownUI in HKCU\Software\Microsoft\Windows\DWM\, and set its value to 1.
  • Create a dWord value named DisableLockingMemory in HKCU\Software\Microsoft\Windows\DWM\, and set its value to 1.
  • Create a dWord value named DisableDeviceBitmaps in HKLM\Software\Microsoft\Windows\DWM\, and set its value to 1.  You will probably have to create the "DWM" key as well.

    By default, none of these values exist, so if they don't help anything, just delete them once you're done.  After adding a setting, reboot the computer so that it will take effect, and then test your system and see if the dialog comes up or not.
 
Edited by Techie007 - 3/14/14 at 12:13pm
My desktop PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Gigabyte P67A-D3-B3 NVIDIA GeForce 8400 GS  1x Corsair 8 GB 
Hard DriveHard DriveHard DriveOS
Kingston SV300S3 WesternDigital WD10EZEX Samsung HD154UI Windows 7 Ultimate SP1 x64 
MonitorMonitorKeyboardPower
Daewoo L947BK Gateway FPD1530 HTK-2001 Dynex DX-400WPS 
MouseAudio
Kensington K72400 Realtek ALC889 
  hide details  
Reply
My desktop PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-3770K Gigabyte P67A-D3-B3 NVIDIA GeForce 8400 GS  1x Corsair 8 GB 
Hard DriveHard DriveHard DriveOS
Kingston SV300S3 WesternDigital WD10EZEX Samsung HD154UI Windows 7 Ultimate SP1 x64 
MonitorMonitorKeyboardPower
Daewoo L947BK Gateway FPD1530 HTK-2001 Dynex DX-400WPS 
MouseAudio
Kensington K72400 Realtek ALC889 
  hide details  
Reply
post #13 of 13
Quote:
Originally Posted by Techie007 View Post

Quote:
Originally Posted by DaChosenOne View Post

If my suggestion did not work, did you try the registry edit given by Vagrant Storm?

    You mean the "HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM\UseMachineCheck" tweak?  That shouldn't affect anything since Windows 7 SP1 doesn't even look at that value.  I believe that setting was for Vista.

    Anyway, I ran a trace and found these valid registry settings for DWM in Windows 7 SP1: List of all registry settings for DWM in Windows 7 (Click to show)
XP style (non-blurry) DPI scaling setting (in access order)
HKU\.DEFAULT\Software\Microsoft\Windows\DWM\UseDpiScaling
HKLM\Software\Microsoft\Windows\DWM\UseDpiScaling
HKCU\Software\Microsoft\Windows\DWM\UseDpiScaling

Shared system and user settings (in access order)
HKCU\Software\Microsoft\Windows\DWM\AnimationsShiftKey
HKLM\Software\Microsoft\Windows\DWM\AnimationsShiftKey
HKCU\Software\Microsoft\Windows\DWM\DisableDynamicShutdownUI
HKLM\Software\Microsoft\Windows\DWM\DisableDynamicShutdownUI
HKCU\Software\Microsoft\Windows\DWM\DisableLockingMemory
HKLM\Software\Microsoft\Windows\DWM\DisableLockingMemory

Shared system and user policies (in access order)
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowAnimations
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowAnimations
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowColorizationColorChanges
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowColorizationColorChanges
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowComposition
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowComposition
HKLM\Software\Policies\Microsoft\Windows\DWM\DisallowFlip3D
HKCU\Software\Policies\Microsoft\Windows\DWM\DisallowFlip3D
HKLM\Software\Policies\Microsoft\Windows\DWM\DefaultColorizationColorState
HKCU\Software\Policies\Microsoft\Windows\DWM\DefaultColorizationColorState

User settings (in access order)
HKCU\Software\Microsoft\Windows\DWM\Composition
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy
HKCU\Software\Microsoft\Windows\DWM\ColorizationColor
HKCU\Software\Microsoft\Windows\DWM\ColorizationColorBalance
HKCU\Software\Microsoft\Windows\DWM\ColorizationAfterglow
HKCU\Software\Microsoft\Windows\DWM\ColorizationAfterglowBalance
HKCU\Software\Microsoft\Windows\DWM\ColorizationBlurBalance
HKCU\Software\Microsoft\Windows\DWM\ColorizationGlassReflectionIntensity
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend

System settings (in access order)
HKLM\System\CurrentControlSet\services\nvlddmkm\DisableDWMContexts
HKLM\Software\Microsoft\Windows\DWM\DisableDeviceBitmaps
HKLM\Software\Microsoft\Windows\DWM\Schedule\FrameRateMin
HKLM\Software\Microsoft\Windows\DWM\Schedule\MoveSize\FrameRateMin

Any settings not in this list will be ignored since Windows doesn't even check their values.


    @Darkwizzie: I have never had this problem myself so I am unable to attack it on my own, but I do have some suggestions for you to try (one at a time, please):
  • Create a dWord value named DisableDynamicShutdownUI in HKCU\Software\Microsoft\Windows\DWM\, and set its value to 1.
  • Create a dWord value named DisableLockingMemory in HKCU\Software\Microsoft\Windows\DWM\, and set its value to 1.
  • Create a dWord value named DisableDeviceBitmaps in HKLM\Software\Microsoft\Windows\DWM\, and set its value to 1.  You will probably have to create the "DWM" key as well.

    By default, none of these values exist, so if they don't help anything, just delete them once you're done.  After adding a setting, reboot the computer so that it will take effect, and then test your system and see if the dialog comes up or not.
 

Whoops...I just googled registry and DWM and had a result for 2013 so I assumed that was for Win7. I assume the above would be for Win7 then. So try that.

You could try disabling the service that starts and runs dwm.exe I am not sure if that will help though. I haven't been able to have hands on this problem...or at least not when disabling troubleshooting doesn't make it go away.


Looks like it is the UxSms service that runs DWM.exe...I've never messed with that one before, but I just stopped it on my laptop and it doesn't look like it was really needed and everything seems to work yet save for DWM.exe and if that process isn't running there shouldn't be anyway for that popup to complain about a full screen app and Aero.
Edited by Vagrant Storm - 3/14/14 at 2:43pm
My System
(16 items)
 
  
CPUMotherboardGraphicsGraphics
2600K @ 4.7GHz Asus P8P67 B3 GTX 580 EVGA Hydro Copper 2 GTX 580 EVGA  
RAMHard DriveOptical DriveOS
4x4GB G.Skill Ripjaws bunch of 'em Blu-Ray For movies Windows 8.1 
MonitorMonitorKeyboardPower
24.4" Hans G HH251 X2 Yamakasi DS270  Blah 1000watt Super Flower 
CaseMouseMouse PadAudio
Built into Desk Microsoft SideWinder X8 Comfy one... Creative Extreme Gamer 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsGraphics
2600K @ 4.7GHz Asus P8P67 B3 GTX 580 EVGA Hydro Copper 2 GTX 580 EVGA  
RAMHard DriveOptical DriveOS
4x4GB G.Skill Ripjaws bunch of 'em Blu-Ray For movies Windows 8.1 
MonitorMonitorKeyboardPower
24.4" Hans G HH251 X2 Yamakasi DS270  Blah 1000watt Super Flower 
CaseMouseMouse PadAudio
Built into Desk Microsoft SideWinder X8 Comfy one... Creative Extreme Gamer 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › How do I shut Windows up?