Overclock.net › Forums › Components › Mice › Roccat Kone+ buttons not working
New Posts  All Forums:Forum Nav:

Roccat Kone+ buttons not working

post #1 of 9
Thread Starter 
Soooo, the problem is pretty simple. I was using Roccat Kone for like 2 months, everything was working fine till today. I turned my PC on from hibernation and all buttons stopped working. Lights are working, i can freelly move cursor, but non of the buttons are working. Right click,left click, scroll, DPI changers etc. Nothing. Im using Windows 7, but the same problem occures on my laptop with XP, so its something bad with the mouse itself. But how could all butotns break just by themselves?
post #2 of 9
I'd guess your buttons are fine and its a circuit board or connection inside the mouse that failed. RMA it if you can. Or pop it open and look as long as it doesn't affect the rma.
post #3 of 9
Thread Starter 
Well, there might be a problem with RMA...
post #4 of 9
Try using your keyboard as a mouse and open up the software of the mouse and prompt for a factory reset.. This should work I guess...
post #5 of 9
Thread Starter 
Unfortunately didn't work : / The problem occures on every computer, so it's about mouse itself. Any ideas guys?
post #6 of 9
Super unlikely. Is Steelseries Engine or another brands software running?
post #7 of 9
Thread Starter 
Nah
post #8 of 9
How about on another PC/notebook?
post #9 of 9
Thread Starter 
Wasn't working on any other PC nor notebook, but problem is solved. All i had to do was pretty big wipe and clean done with another mouse while Kone was connected too. THanks for feedback guys, topic can be closed wink.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Roccat Kone+ buttons not working