Overclock.net › Forums › Cooling › Water Cooling › EK issues, need help please! n00b alert!!
New Posts  All Forums:Forum Nav:

EK issues, need help please! n00b alert!! - Page 2

post #11 of 15
Yikes. Well check the card and block and see if there are any incriminating stickers that would prove you took off the block. Not that I'm encouraging breaking your warranty but might save you some time.
Verktøy Cu
(20 items)
 
XForma MBX MKII
(18 items)
 
 
CPUCPUMotherboardGraphics
Intel Xeon E5-2670 V4 Intel Xeon E5-2670 V4 Asus Z10PE-D8 WS Nvidia Titan X 
GraphicsGraphicsGraphicsRAM
Nvidia Titan X Nvidia Titan X Nvidia Titan X 128GB of Kingston DDR4 ECC 2133Mhz 
Hard DriveHard DriveHard DriveHard Drive
Intel 750 NVME 1.2TB U.2 Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC 
CoolingOSMonitorKeyboard
EK Water Blocks Windows 10 Pro Dell UP2715K Cherry MX 6.0 
PowerCaseMouseAudio
Corsair AX1500i Case Labs S8 Logitech MX Master Pioneer SE-L40 
CPUMotherboardGraphicsGraphics
Intel 5960X Asus Rampage V Extreme Nvidia Titan X Nvidia Titan X 
GraphicsRAMHard DriveHard Drive
Nvidia Titan X Corsair Dominator Platinum 4x8GB 2400Mhz (2) Intel 530 180GB (2) HGST 4TB 
Optical DriveCoolingOSMonitor
Blu-Ray Slot Load EK Water Blocks Liquid Cooling Windows 8.1 Dell UP2715K 
KeyboardPowerCaseMouse
Ducky OCN Blues Seasonic 1200W Platinum XForma MBX MKII TBD 
AudioAudio
Asus Xonar Essence One (2) Mackie MR5MK2 
  hide details  
Reply
Verktøy Cu
(20 items)
 
XForma MBX MKII
(18 items)
 
 
CPUCPUMotherboardGraphics
Intel Xeon E5-2670 V4 Intel Xeon E5-2670 V4 Asus Z10PE-D8 WS Nvidia Titan X 
GraphicsGraphicsGraphicsRAM
Nvidia Titan X Nvidia Titan X Nvidia Titan X 128GB of Kingston DDR4 ECC 2133Mhz 
Hard DriveHard DriveHard DriveHard Drive
Intel 750 NVME 1.2TB U.2 Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC 
CoolingOSMonitorKeyboard
EK Water Blocks Windows 10 Pro Dell UP2715K Cherry MX 6.0 
PowerCaseMouseAudio
Corsair AX1500i Case Labs S8 Logitech MX Master Pioneer SE-L40 
CPUMotherboardGraphicsGraphics
Intel 5960X Asus Rampage V Extreme Nvidia Titan X Nvidia Titan X 
GraphicsRAMHard DriveHard Drive
Nvidia Titan X Corsair Dominator Platinum 4x8GB 2400Mhz (2) Intel 530 180GB (2) HGST 4TB 
Optical DriveCoolingOSMonitor
Blu-Ray Slot Load EK Water Blocks Liquid Cooling Windows 8.1 Dell UP2715K 
KeyboardPowerCaseMouse
Ducky OCN Blues Seasonic 1200W Platinum XForma MBX MKII TBD 
AudioAudio
Asus Xonar Essence One (2) Mackie MR5MK2 
  hide details  
Reply
post #12 of 15
So the leaks are still happening regardless of if the triple parallel bridge or the original terminal (with four G1/4 ports) are used?

Have you checked if the mating area around the slotted ports on the GPU block is completely flush?
post #13 of 15
Thread Starter 
Quote:
Originally Posted by shimeng View Post

So the leaks are still happening regardless of if the triple parallel bridge or the original terminal (with four G1/4 ports) are used?

Have you checked if the mating area around the slotted ports on the GPU block is completely flush?

Yes, leaks occur with either terminal and usually on the same card.

I've checked, rechecked, and triple rechecked every mating surface every time I make an adjustment.

I don't usually feel out of my depth but I have to admit I am baffled.
post #14 of 15
ive got an idea.
leave the cards out of your case. assemble a loop out of the case. see if it still leaks.
it doesnt need to be a full loop. just your pump, res and crossfire set-up.
w00t
(18 items)
 
   
CPUMotherboardGraphicsRAM
ph2 x20be asus m4a785-m sapphire vapor-x 4850  geil black dragon 1066 5-5-5-15-20 
Hard DriveOptical DriveCoolingOS
wd  asus dvd multi-write arctic cooling freezer 64 pro win 7 ultimate x64 
MonitorKeyboardPowerCase
samsung 42" lcd logitech wireless antec basic 500watt old dell crap 
MouseAudio
logitech wireless pioneer 7.1 
  hide details  
Reply
w00t
(18 items)
 
   
CPUMotherboardGraphicsRAM
ph2 x20be asus m4a785-m sapphire vapor-x 4850  geil black dragon 1066 5-5-5-15-20 
Hard DriveOptical DriveCoolingOS
wd  asus dvd multi-write arctic cooling freezer 64 pro win 7 ultimate x64 
MonitorKeyboardPowerCase
samsung 42" lcd logitech wireless antec basic 500watt old dell crap 
MouseAudio
logitech wireless pioneer 7.1 
  hide details  
Reply
post #15 of 15
If it's not the mating surfaces, O-rings, screw length or over tightening then the leak may not be originating from the terminal contact.

As Derick mentioned earlier, if there aren't any tamper proof seals then you could just try opening it to see if there's anything wrong on the inside.

Otherwise, just return the card/block for another one - having it leak right out of the box is unacceptable.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › EK issues, need help please! n00b alert!!