Overclock.net › Forums › Intel › Intel Motherboards › Display Driver Issues with AMD and NVIDIA cards! HELP!
New Posts  All Forums:Forum Nav:

Display Driver Issues with AMD and NVIDIA cards! HELP!

post #1 of 11
Thread Starter 
I recently finished building my new computer (details below) and am having some serious issues regarding display drivers.

Firstly I had a nvidia GTX 760 card which froze on the 'Starting Windows' screen then blue screened with an error about 'nvlddmkm.sys' which relates to nvidia. I tried an older nvidia driver and a different monitor but still had problems.

So I formatted my hard drive, re-install windows and download the latest BIOS and chipset (thanks again to Cgipson and TwoCables for making sure I did this correctly). I had to return the GTX 760 as it wasnt suitable for my case and bought an a AMD Radeon R9 270X 4GB card instead which I have just installed with the latest drivers. However I am STILL getting display driver issues!?

It boots into Windows fine, but as soon as I launch any application, say Firefox the screen goes blank for a few seconds then shows a warning icon next to the clock "Display driver has stopped responding and has recovered" then Firefox crashes. Sometimes with another error "Load MMdriver stopped working" which relates to ATI.

It has also BlueScreened with message "The device driver got stuck in an infinite loop. This usually indicates problem with device itself or with device driver programming the hardware incorrectly"

What the hell?! Is my motherboard broken? Bad drivers? Strangely my old GTX 690 worked fine though. Ugh this is driving me crazy! wheee.gif



SYSTEM INFO:
OS: Windows 7 Home Premium 64bit
GFX: EVGA Nvidia GeForce GTX 760 Superclocked ACX 2GB (initially)
GFX: AMD Radeon R9 270X 4GB (currently)
CPU: Intel Core i5 4570
RAM: Corsair 8GB (2 x 4GB) Vengeance DDR3 1600MHz
PSU: Corsair RM650 650w Modular Power Supply
HDD: Sandisk Extreme 240GB SSD
MOBO: Asus H87M-PLUS s1150 uATX H87
post #2 of 11
Found this.. hope it helps.. http://www.tomshardware.com/faq/id-1713187/fix-amd-catalyst-software-driver-issues.html

Looks like you will need a Login on the AMD support site though....
Edited by cgipson1 - 3/19/14 at 10:52am
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
post #3 of 11
Thread Starter 
Thanks I can certainly try that, but dont you think its a bit weird that both AMD and NVIDIA cards didnt work though?

Makes me think its not actually directly related to the card drivers and is perhaps the ASUS motherboard drivers? Should I maybe try an older BIOS version?
post #4 of 11
Sounds like bad memory. Run memtest86+ to test if the memory is going bad. Also make sure your SSD is on latest firmware.
FreeNAS
(9 items)
 
Beast
(14 items)
 
Alura :)
(11 items)
 
CPUMotherboardGraphicsRAM
Intel Xeon E3-1245 v5 SuperMicro X11SSM-F-O C236 Integrated 2 x 16GB Kingston ValueRAM ECC KVR21E15D8/16 
Hard DriveCoolingOSPower
5 x 8TB Seagate IronWolf Pro in ZF2 Array CoolerMaster Hyper 212 Evo FreeNAS 11 EVGA SuperNOVA G2 550W Gold 
Case
Fractal Design Node 804 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97 Pro WIFI-AC Sapphire Nitro Radeon R9 Fury Tri-X OC+  G.Skill 4 x 8GB F3-2133C9D-16GXH 
Hard DriveOptical DriveCoolingOS
2 x Intel 730 480GB SSD in RAID 0 Asus DRW-24B1ST/BLK/B/AS Noctua NH-D15 Winblows 10 Pro x64 
MonitorKeyboardPowerCase
Pixio PX277 Logitech G510 Seasonic SS-660XP2 Fractal Design R4 Blackout 
MouseMouse Pad
Logitech G500 Xtrac Ripper 
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Pro MSI R7970 Lightning BE 2 x 4GB G.Skill Ripjaws 2133mhz 
Hard DriveOptical DriveCoolingOS
Mushkin Enhanced Chronos 240GB and WD Black 1TB Asus DRW-24B1ST Cooler Master Hyper 212 EVO Windows 7 Ultimate x64 
MonitorPowerCase
Hannspree 24 inch Thermaltake Tough Power TP-750P 750W Gold Cooler Master HAF 932 
  hide details  
Reply
FreeNAS
(9 items)
 
Beast
(14 items)
 
Alura :)
(11 items)
 
CPUMotherboardGraphicsRAM
Intel Xeon E3-1245 v5 SuperMicro X11SSM-F-O C236 Integrated 2 x 16GB Kingston ValueRAM ECC KVR21E15D8/16 
Hard DriveCoolingOSPower
5 x 8TB Seagate IronWolf Pro in ZF2 Array CoolerMaster Hyper 212 Evo FreeNAS 11 EVGA SuperNOVA G2 550W Gold 
Case
Fractal Design Node 804 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97 Pro WIFI-AC Sapphire Nitro Radeon R9 Fury Tri-X OC+  G.Skill 4 x 8GB F3-2133C9D-16GXH 
Hard DriveOptical DriveCoolingOS
2 x Intel 730 480GB SSD in RAID 0 Asus DRW-24B1ST/BLK/B/AS Noctua NH-D15 Winblows 10 Pro x64 
MonitorKeyboardPowerCase
Pixio PX277 Logitech G510 Seasonic SS-660XP2 Fractal Design R4 Blackout 
MouseMouse Pad
Logitech G500 Xtrac Ripper 
CPUMotherboardGraphicsRAM
i5 2500k Asus P8Z68-V Pro MSI R7970 Lightning BE 2 x 4GB G.Skill Ripjaws 2133mhz 
Hard DriveOptical DriveCoolingOS
Mushkin Enhanced Chronos 240GB and WD Black 1TB Asus DRW-24B1ST Cooler Master Hyper 212 EVO Windows 7 Ultimate x64 
MonitorPowerCase
Hannspree 24 inch Thermaltake Tough Power TP-750P 750W Gold Cooler Master HAF 932 
  hide details  
Reply
post #5 of 11
Quote:
Originally Posted by BENBOBBY View Post

Thanks I can certainly try that, but dont you think its a bit weird that both AMD and NVIDIA cards didnt work though?

Makes me think its not actually directly related to the card drivers and is perhaps the ASUS motherboard drivers? Should I maybe try an older BIOS version?

Could be, I don't know! Does the card work ok with the standard VGA windows drivers? If so, probably not Mobo.

Easy enough to switch around BIOS versions, can't hurt to try.
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
post #6 of 11
Thread Starter 
Quote:
Originally Posted by cgipson1 View Post

Could be, I don't know! Does the card work ok with the standard VGA windows drivers? If so, probably not Mobo.
Easy enough to switch around BIOS versions, can't hurt to try.

Yeh it works fine with the standard windows drivers and in safe mode. The problems only start when installing the drivers. Could the integrated graphics on the motherboard be interfering maybe? I remember Windows Update downloaded something to do with Intel graphics.

Quote:
Originally Posted by Dopamin3 View Post

Sounds like bad memory. Run memtest86+ to test if the memory is going bad. Also make sure your SSD is on latest firmware.

Cant really see the connection myself, but will give it a try and let you know... thanks smile.gif
post #7 of 11
Quote:
Originally Posted by BENBOBBY View Post

Yeh it works fine with the standard windows drivers and in safe mode. The problems only start when installing the drivers. Could the integrated graphics on the motherboard be interfering maybe? I remember Windows Update downloaded something to do with Intel graphics.
Cant really see the connection myself, but will give it a try and let you know... thanks smile.gif

In your BIOS, you can select which to use as primary graphics... PCIE or IGP. I would do that. If you have drivers installed for the IGP, I would uninstall them.

Memory is a possibility... worth checking.

have you tried resetting the BIOS settings to default? Just in case any other changes are getting in the way?
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
post #8 of 11
Thread Starter 
OK heres what Ive tried lately:

- Selecting PCIE as the primary graphics in BIOS
- Uninstalling Intel on-board graphics drivers
- Swapping memory sticks over
- Installing older versions of BIOS and chipset drivers
- Downloaded latest display drivers for my monitor
- Installing AMD beta driver
- Updating firmware on SSD (was already up to date)
- Resetting BIOS back to default

With the old BIOS (0704) I get a different blue screen error relating to "atikmpag.sys". With the beta AMD drivers I thought I had found the solution as it was stable all last night while using it, but then turned the computer off and on and this morning the problem is still there. I dunno what else to do? Is the motherboard broken? Or power supply? Maybe it not getting enough power?
post #9 of 11
Researching some of the errors you have had...

http://www.geek.com/chips/the-infinite-loop-problem-549322/

It appears that it can be either a timing issue with some motherboards... or sometimes a power issue (motherboard power).

Have you got an extra cable going into the EATX12V connector at the top of your mobo?



Do you have both the 6-pin adn 8-pin power connectors on the card populate? (if you are using one cable for both... trying two separate PSU cables as a test.

Have you tried just the drivers... and not load the Catalyst software? Removed any and all OC's on the video card...and any software that might be involved there? ( I don't use AMD.. so not familiar with popular software / tweaks)
Edited by cgipson1 - 3/20/14 at 5:46am
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
Workstation
(16 items)
 
   
CPUMotherboardGraphicsGraphics
INtel 4770k ASUS maximus extreme VI  EVGA GTX 780Ti SC  EVGA GTX 780Ti SC 
GraphicsRAMHard DriveHard Drive
EVGA GTX 780Ti SC Kingston HyperX Beast 32 GB Kit (4x8 GB) 2400MH... Western Digital 2tb Enterprise Samsung 840 Pro SSD 256GB 
Optical DriveCoolingCoolingCooling
Pawtec External USB 3.0 Aluminum 8X DVD-RW Writ... Primochill ghost fitings Monsoon reservoir Swifttech MCP50x/2  
CoolingCoolingCoolingCooling
Primochill rigid acrylic tubing EK supremacy CPU block - Nickel EK 780Ti waterblocks x3 - Nickel Lamptron FC9 fan Controller 
CoolingCoolingCoolingCooling
9x Primochill Acrylic Radiator Grills Alphacool ST30 280 radiator Alphacool ST30 280 radiator Alphacool 420 80mm 
OSMonitorKeyboardPower
Windows 7 Ultimate Dell UW3014 Merc stealth steel series keyboard EVGA NEX1500 PSU 
CaseMouseMouse PadAudio
Lian Li PC-D600 Razer Death Adder Mouse Razer Scarab mousepad Logitech X-540 5.1 speakers with sub 
  hide details  
Reply
post #10 of 11
Thread Starter 
Really appreciate you looking into this cgipson. A few quick updates - did the MemTest for 3 passes and had 0 errors and also swapped around the sticks as mentioned before so I think we can rule out memory issues. And yup the CPU power cable is connected and have also tried two separate PSU cables to the graphics card.

Theres an interesting part from that article you mentioned "The one commonality is graphics drivers pushing the graphics cards to the limit and presumably using more power than some motherboards can handle. Who is blamed? The petition targets motherboard makers, but this is one sticky issue." It was written in 2002, but I guess it still applies today. Both the GTX 760 and R9 270X are heavily factory overclocked versions "EVGA Superclocked" and "SAPPHIRE Overclocked and Boost Edition" respectively. Where as my old GTX 690, which is at stock speeds, seemed to work fine. Think we might be on to something!... Is there an easy way to temporarily reverse factory overclocked settings to test?

Another strange thing is that the fan on my new Corsair RM650 650w Power Supply never spins! It has a special feature called 'Zero RPM' mode, but thats only supposed to be effective up to 40% load. However even when benchmarking running Unigine and Cinebench simultaneously on extreme mode it doesnt spin. Of course it doesnt run for long before it crashes but surely it uses more than 260W! Maybe its not getting enough power?

Thanks thumb.gif
Edited by BENBOBBY - 3/20/14 at 1:11pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Display Driver Issues with AMD and NVIDIA cards! HELP!