Overclock.net › Forums › Graphics Cards › NVIDIA › PCI-E connector ... is that a manufacturer defect?
New Posts  All Forums:Forum Nav:

PCI-E connector ... is that a manufacturer defect?

post #1 of 3
Thread Starter 
Hello, I got a Gigabyte GTX 760 WF3 and the PCI-E connectors are weird, the PCI-E cable won't clip in the connector and I can get the cable out without the need to press on the plastic, it just go in and out easily. I took some pictures and I wonder if that a defect and need to RMA ?













Taichi
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 5960x ASRock X99 Taichi EVGA GTX 1070 FTW Kingston 32GB Fury X 2666MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 960 Pro 512Gb Samsung SSD 850 EVO 500Gb Seagate Enterprise Capacity v5 8Tb  Nzxt Kraken X62 
OSMonitorPowerCase
Windows 7 / Windows 10 Pro LG 29UM67 Seasonic Prime Titanium 850w Corsair Obsidian 750D 
MouseAudio
Logitech G502 Proteus Spectrum Creative Sound Blaster ZxR 
  hide details  
Reply
Taichi
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 5960x ASRock X99 Taichi EVGA GTX 1070 FTW Kingston 32GB Fury X 2666MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 960 Pro 512Gb Samsung SSD 850 EVO 500Gb Seagate Enterprise Capacity v5 8Tb  Nzxt Kraken X62 
OSMonitorPowerCase
Windows 7 / Windows 10 Pro LG 29UM67 Seasonic Prime Titanium 850w Corsair Obsidian 750D 
MouseAudio
Logitech G502 Proteus Spectrum Creative Sound Blaster ZxR 
  hide details  
Reply
post #2 of 3
If your willing to wait a few weeks to rma for something that has no functionality loss then you could I suppose
Silent Dominator
(28 items)
 
Classy Lady
(26 items)
 
TUF Inside
(18 items)
 
  hide details  
Reply
Silent Dominator
(28 items)
 
Classy Lady
(26 items)
 
TUF Inside
(18 items)
 
  hide details  
Reply
post #3 of 3
looks like the plastic "ramp" that holds the 8-pin clip is not as tall as the "ramp" on the 6-pin side...but who cares,it wont fall out unless you take your rig to rollercoasters rides biggrin.gif
yunojelly
(17 items)
 
  
CPUMotherboardGraphicsGraphics
2600K P8P67 EVO GTX Titan 560 Ti GE 
RAMHard DriveHard DriveHard Drive
16GB 1600/CL8 64GB C300 RAID0 128GB M4 256GB M4 
CoolingOSMonitorPower
NH-D14 Windows 8 Pro VP2770-LED 850AX 
Case
PCV1020B 
  hide details  
Reply
yunojelly
(17 items)
 
  
CPUMotherboardGraphicsGraphics
2600K P8P67 EVO GTX Titan 560 Ti GE 
RAMHard DriveHard DriveHard Drive
16GB 1600/CL8 64GB C300 RAID0 128GB M4 256GB M4 
CoolingOSMonitorPower
NH-D14 Windows 8 Pro VP2770-LED 850AX 
Case
PCV1020B 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › PCI-E connector ... is that a manufacturer defect?