Overclock.net › Forums › Specialty Builds › HTPC › Issues with XBMCbuntu after non standard install
New Posts  All Forums:Forum Nav:

Issues with XBMCbuntu after non standard install

post #1 of 5
Thread Starter 
Good Morning everyone,

Ok I have a bit of an issue with XBMC not loading after an XBMCbuntu install.

What I did was set up a VM in virtualbox and install XBMCbuntu, after install I install VBOX guest additions (which is needed to be able to run XBMC in a VM since it requires OPENGL) and mounted my shares from my NAS so I could add media. I opened XBMC and got it set up exactly like I like it. Ok that was easy and everything is working fine.....inside the VM.

Next, I booted up the VM to clonezilla and made an image of the XBMCbuntu VM. Worked OK .......check
Then I deployed this image over my LAN to my HTPC sitting in my living room. Worked OK .......check
Living Room HTPC booted up fine after deployment. Here is where the issue arises.

XBMC will start up to the FRODO splash screen but then it crashes to the desktop. I have read the crash logs and the only thing that looks out of place is the driver that Xorg loads is the VMWare one and my HTPC has an NVIDIA card in it.

Now my understanding is that the linux kernal chose the drivers to load at boot time.

I have installed the closed source drivers provided by nvidia and
Code:
jockey-text --list

is showing it as installed and enabled but not in use.

So short of loading up a fresh install and re-configuring on a non VM box and then retaking the image, I cant think of a way to fix this.

I know x-server is loading the wrong driver I just cant figure out why.

Does anyone have any tips or command-fu I could do to avoid having to re-install so I can just take a new image of the box with a modified config?
post #2 of 5
Try entering this into a terminal and restart the computer
Code:
sudo nvidia-xconfig
post #3 of 5
Why load a VM and then clone it to an actual box. Just set it up in the VM if you must, install it to the HTPC without cloning. Then copy XBMC's home folder to the HTPC, that should do what you want. If you need help just ask.

Edit: recommend using fstab to mount the network shares for XBMC, instead of using the built in part of XBMC to do that.
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 500GB 
Hard DriveHard DriveHard DriveOS
Samsung 2TB Western Digital Red 3TB HGST Deskter 4TB Unraid 6.x 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 500GB 
Hard DriveHard DriveHard DriveOS
Samsung 2TB Western Digital Red 3TB HGST Deskter 4TB Unraid 6.x 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
post #4 of 5
Thread Starter 
Quote:
Originally Posted by thestraw0039 View Post

Try entering this into a terminal and restart the computer
Code:
sudo nvidia-xconfig

I will try this when I get to the house.
Quote:
Originally Posted by cones View Post

Why load a VM and then clone it to an actual box. Just set it up in the VM if you must, install it to the HTPC without cloning. Then copy XBMC's home folder to the HTPC, that should do what you want. If you need help just ask.

Edit: recommend using fstab to mount the network shares for XBMC, instead of using the built in part of XBMC to do that.

The shares are mounted in the fstab file

I loaded it in a VM because the HTPC is next to my television and the only keyboard and mouse I have to work on it are attached to my main machine. Which has a mass amount of wire management behind my desk. So my mouse and keyboard cord were weaved in between a bunch of velcro straps and I didn't want to take them out of it because it is a headache to do so. Though ultimately I had to do this anyway because I didnt think ahead far enough to realize I had to hit F12 to boot from network but that is just me being dumb.

The coping of the setting folder I can manage and I like this idea and then I can image it.

I just want a reconfigured image so that I can re install in less than 5 mins and start fresh if I need too.
Edited by Macnemarion - 3/21/14 at 8:33am
post #5 of 5
You are just complicating it in my opinion then if you want to image the VM with drivers onto something else. You could always make a script, install the OS then run the script to set it up how you want.
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 500GB 
Hard DriveHard DriveHard DriveOS
Samsung 2TB Western Digital Red 3TB HGST Deskter 4TB Unraid 6.x 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 500GB 
Hard DriveHard DriveHard DriveOS
Samsung 2TB Western Digital Red 3TB HGST Deskter 4TB Unraid 6.x 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC
Overclock.net › Forums › Specialty Builds › HTPC › Issues with XBMCbuntu after non standard install