Overclock.net › Forums › Components › Mice › My mouse feels... WEIRD
New Posts  All Forums:Forum Nav:

My mouse feels... WEIRD

post #1 of 35
Thread Starter 
Dear forum

My mouse just feels... weird. I cannot really explain why. The only thing I can really say is that it feels like I am on ice with it.

I think it all started after I restarted Windows 7 on my computer two weeks ago. I believe I could tell that there was a difference, but I thought maybe I was rusty, since I had not spend a lot of time on the computer those days after reinstalling. Then I got a new mouse a week ago, and so I thought I just had to get used to it. Now a week later, it STILL feels weird. I do not believe it is because I need to get used to it, since 1) it happened to me on the old mouse and 2) it only takes a day or two for me to get used to a new mouse.

I have tried everything. I am changing the sensitivity of the mouse every single day, because it feels odd. I have tried changing the mouse settings in windows. This is driving me nuts!

Can anyone please help me? This is really causing me trouble, as I like to play video games, and it really takes all the joy and fun out of the games, since all I can ever think about is my god damn mouse!

Oh, and by the way, I tried it on my brother's PC about two hours ago (which is really why I am convinced that something is wrong with my computer), and I did not pay attention to my mouse one single time.
Edited by Cytraz - 3/21/14 at 3:40pm
post #2 of 35
The feels like on ice thing sounds like mouse acceleration, did you check to see if that's enabled in windows?
Noodles
(17 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i5 3570k (@ 4.4GHz) MSI Z77MA-G45 Zotac GTX 760 Zotac GTX 760 
RAMRAMHard DriveHard Drive
8GB Crucial Ballistix DDR3 1866 8GB Crucial Ballistix DDR3 1866 240GB Seagate 600 Series SSD 240GB Seagate 600 Series SSD 
Hard DriveCoolingOSMonitor
1TB Seagate SSHD Cooler Master Hyper 212 EVO Windows 8.1 Acer 27" 
KeyboardPowerCaseMouse
SteelSeries 6GV/2 (Reds) Thermaltake Tough Power 750W BitFenix Prodigy M SteelSeries Sensei [RAW] 
Audio
SteelSeries Sibera V2 
  hide details  
Reply
Noodles
(17 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i5 3570k (@ 4.4GHz) MSI Z77MA-G45 Zotac GTX 760 Zotac GTX 760 
RAMRAMHard DriveHard Drive
8GB Crucial Ballistix DDR3 1866 8GB Crucial Ballistix DDR3 1866 240GB Seagate 600 Series SSD 240GB Seagate 600 Series SSD 
Hard DriveCoolingOSMonitor
1TB Seagate SSHD Cooler Master Hyper 212 EVO Windows 8.1 Acer 27" 
KeyboardPowerCaseMouse
SteelSeries 6GV/2 (Reds) Thermaltake Tough Power 750W BitFenix Prodigy M SteelSeries Sensei [RAW] 
Audio
SteelSeries Sibera V2 
  hide details  
Reply
post #3 of 35
Thread Starter 
Yes, I did, and it is not.
post #4 of 35
Mouse pad? i have an issue with the cheap wireless mouse in my house on a colored surface.
Budget Rig V2
(12 items)
 
   
CPUMotherboardGraphicsRAM
Intel Xeon X5650 P6T DELUXE NVIDIA GeForce GTX 670 G.skill Sniper 
RAMHard DriveCoolingOS
G.skill Sniper Hitachi Raijintek Themis Windows 7 
PowerCaseMouseAudio
Rosewill Capstone 750M Corsair C70 Dell Mouse Samson SR950 
CPUMotherboardGraphicsGraphics
AMD FX-8120 M5A99FX PRO R2.0 AMD Radeon HD 7800 Series AMD Radeon HD 7800 Series 
RAMRAMHard DriveCooling
G.Skill sniper G. Western Digital WD Green Asetek 510lc w/rosewill hypoborea push/pull 
OSMonitorCaseAudio
Windows 7 Ultimate Dell 144ox900 @75hz Corsair C70 Arctic White topping tp 12 amp 
  hide details  
Reply
Budget Rig V2
(12 items)
 
   
CPUMotherboardGraphicsRAM
Intel Xeon X5650 P6T DELUXE NVIDIA GeForce GTX 670 G.skill Sniper 
RAMHard DriveCoolingOS
G.skill Sniper Hitachi Raijintek Themis Windows 7 
PowerCaseMouseAudio
Rosewill Capstone 750M Corsair C70 Dell Mouse Samson SR950 
CPUMotherboardGraphicsGraphics
AMD FX-8120 M5A99FX PRO R2.0 AMD Radeon HD 7800 Series AMD Radeon HD 7800 Series 
RAMRAMHard DriveCooling
G.Skill sniper G. Western Digital WD Green Asetek 510lc w/rosewill hypoborea push/pull 
OSMonitorCaseAudio
Windows 7 Ultimate Dell 144ox900 @75hz Corsair C70 Arctic White topping tp 12 amp 
  hide details  
Reply
post #5 of 35
1; Windows mouse options. Should be 6/11 (middle) with enhanced pointer precision UNCHECKED

2; Mouse drivers, sampling rate. 125hz, 500hz etc.

3; Screen refresh rate

4; Windows aero. Toggle to windows basic theme, check it.
Insert Name Here
(14 items)
 
  
CPUMotherboardGraphicsRAM
6700k Asus Maximus VIII Hero Gigabyte Aorus Xtreme 1080ti Corsair LPX 2x8GB 3200c16 
Hard DriveHard DriveCoolingOS
Old Seagate HDD Samsung 850 EVO Thermalright Silver Arrow SB-E SE Windows 7 Home Premium 64 bit 
MonitorKeyboardPowerCase
Asus PG258Q (240hz + Gsync) WASDKeyboards.com v1 semi custom w/ mx browns, ... Superflower Golden Green HX550 Air540 
MouseMouse Pad
Logitech G Pro Qck+ 
  hide details  
Reply
Insert Name Here
(14 items)
 
  
CPUMotherboardGraphicsRAM
6700k Asus Maximus VIII Hero Gigabyte Aorus Xtreme 1080ti Corsair LPX 2x8GB 3200c16 
Hard DriveHard DriveCoolingOS
Old Seagate HDD Samsung 850 EVO Thermalright Silver Arrow SB-E SE Windows 7 Home Premium 64 bit 
MonitorKeyboardPowerCase
Asus PG258Q (240hz + Gsync) WASDKeyboards.com v1 semi custom w/ mx browns, ... Superflower Golden Green HX550 Air540 
MouseMouse Pad
Logitech G Pro Qck+ 
  hide details  
Reply
post #6 of 35
Thread Starter 
I have used the same mouse pad for years. I bought the same mouse pad I had used for years around 2 weeks ago (after format) to see if that was the issue, and it is not. I have literally tried everything! I think something happened after I reinstalled Windows. I just do not know what. I really am confused right now. I feel like this is all in my head, but I really, really doubt it! I have bought several mice over the years, and this problem has never happened to me.
post #7 of 35
Thread Starter 
Quote:
Originally Posted by Cyro999 View Post

1; Windows mouse options. Should be 6/11 (middle) with enhanced pointer precision UNCHECKED

2; Mouse drivers, sampling rate. 125hz, 500hz etc.

3; Screen refresh rate

4; Windows aero. Toggle to windows basic theme, check it.

Now that I think of it, for the first time ever I tried changing the windows theme to something else after reinstalling Windows 2 weeks ago. Can this be the cause of it?
post #8 of 35
Thread Starter 
Ok, so I think this fixed my problem. It seems to be the Windows Aero theme that I was using which somehow messed up my mouse. I would never have guessed that, but hey, I guess that is what these forums are for! Thanks for the help everyone smile.gif
post #9 of 35
Np, the aero themes can be very laggy especially on 60hz. I believe they are Vsynced, while the basic theme is not?
Insert Name Here
(14 items)
 
  
CPUMotherboardGraphicsRAM
6700k Asus Maximus VIII Hero Gigabyte Aorus Xtreme 1080ti Corsair LPX 2x8GB 3200c16 
Hard DriveHard DriveCoolingOS
Old Seagate HDD Samsung 850 EVO Thermalright Silver Arrow SB-E SE Windows 7 Home Premium 64 bit 
MonitorKeyboardPowerCase
Asus PG258Q (240hz + Gsync) WASDKeyboards.com v1 semi custom w/ mx browns, ... Superflower Golden Green HX550 Air540 
MouseMouse Pad
Logitech G Pro Qck+ 
  hide details  
Reply
Insert Name Here
(14 items)
 
  
CPUMotherboardGraphicsRAM
6700k Asus Maximus VIII Hero Gigabyte Aorus Xtreme 1080ti Corsair LPX 2x8GB 3200c16 
Hard DriveHard DriveCoolingOS
Old Seagate HDD Samsung 850 EVO Thermalright Silver Arrow SB-E SE Windows 7 Home Premium 64 bit 
MonitorKeyboardPowerCase
Asus PG258Q (240hz + Gsync) WASDKeyboards.com v1 semi custom w/ mx browns, ... Superflower Golden Green HX550 Air540 
MouseMouse Pad
Logitech G Pro Qck+ 
  hide details  
Reply
post #10 of 35
Thread Starter 
Okay, so I had some mouse problems a few weeks ago, which I thought I fixed by changing the Windows Theme back to normal. However, it seems like I still have some problems with the mouse. I think I got used to it after changing the theme, but now it feels like something is wrong with my mouse again. Either it is in my head, or something is actually wrong. I do not know if I never actually felt alright using the mouse, or if new problems started to arise.

It is hard to put a feeling on it. I just have this feeling while I am using the mouse, something is not right. It is hard to put a word on it, it just feels like I am not used to it, even though I have had the mouse for months, and I use it tons every day. I might say it feels as if I am on ice with it. It is hard to come any closer to a description of what it feels like.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › My mouse feels... WEIRD