Overclock.net › Forums › Case Mods & Cases › Builds & Case Mods › Case Mods › Case Mod Work Logs › "RIGHTEOUS GAMER!" Donation Build! AMD FX-8320 8 Core & R9 270x OC! ALL WC!!!
New Posts  All Forums:Forum Nav:

"RIGHTEOUS GAMER!" Donation Build! AMD FX-8320 8 Core & R9 270x OC! ALL WC!!! - Page 26

post #251 of 843
Thread Starter 
Updating thread now! OCN User BirdmanDK Donated a game: DAYLIGHT
post #252 of 843
Thread Starter 
I figure I should post some good pics of the new keyboard! And my thoughts about it. Overall I give it a 8.5/10, it has very nice construction although it is not completely metal like some other models it is still very sturdy! The software and features are really easy to use! They kept that classic volume knob that we all love! The Keys are easy to type on, even though they are actually membrane they still have that mechanical feel, I would describe it as a mix in between a super mechanical old keyboard and a newer membrane keyboard, like a hybrid! One thing I dont like though is that they use a coating on the keys to get the characters and that coating will scratch and wear off over time! Also like may other backlit keyboards the lighting looks uneven under each key due to the clear membrane underneath..... Also the macro/shortcut keys on the left are cool but I am one of those people that use there peripheral vision to place my hands in the correct spot on the keyboard quickly oppose to feeling my way around, and when there are extra keys on the left it messes me up, I place my hands in the wrong place at first..... rolleyes.gif









Also I did get the CPU waterblock, im not 100% sure that this is the one im using but I have three of these on there way and the only difference is the color of the block.....






And although I did plan to order some pink or purple fittings I may just use these barbs depending on how my budget goes... rolleyes.gif



post #253 of 843
That's the Raptor then? I've got the Vengeance K95 full mechanical and I adore it. Anyway I wanted to note that I bricked a K95 during my build by accidently plugging it into a USB 3.0 port so watch out for that. You can also accidently brick them if you cancel your "save to keyboard" thing or if you mess up the keyboard bios flash. They're finicky, but well worth it imo.
post #254 of 843
Thread Starter 
Quote:
Originally Posted by Mystriss View Post

That's the Raptor then? I've got the Vengeance K95 full mechanical and I adore it. Anyway I wanted to note that I bricked a K95 during my build by accidently plugging it into a USB 3.0 port so watch out for that. You can also accidently brick them if you cancel your "save to keyboard" thing or if you mess up the keyboard bios flash. They're finicky, but well worth it imo.

Thanks for the Info! REP+ thumb.gif USB 3.0 Bricked? Thats crazy was it a isolated incident or are there other reports of that happening? thinking.gif
post #255 of 843
Quote:
Originally Posted by MCCSolutions View Post

Thanks for the Info! REP+ thumb.gif USB 3.0 Bricked? Thats crazy was it a isolated incident or are there other reports of that happening? thinking.gif

I have a K70 and a K95 and both have had no issues plugged into USB 3.0. It may be an isolated or rare occurrence.
Shadow Box
(116 photos)
  
Reply
Shadow Box
(116 photos)
  
Reply
post #256 of 843
Thread Starter 
Quote:
Originally Posted by RexTempus View Post

I have a K70 and a K95 and both have had no issues plugged into USB 3.0. It may be an isolated or rare occurrence.

good to know! Sounds like he had bad luck lol. Worries me because here soon there will be no more USB 2.0! biggrin.gif
post #257 of 843
Quote:
Originally Posted by MCCSolutions View Post

Thanks for the Info! REP+ thumb.gif USB 3.0 Bricked? Thats crazy was it a isolated incident or are there other reports of that happening? thinking.gif

I had the K90 originally and that worked flawlessly, went to a friend who is using it right now. As for the K95 usb3.0 bricking, it was relatively isolated... I think... At least there was only like one other post on it (though I can't seem find it now.) It was another person with a Sabertooth 990FX/Gen3 Rev2 though, so maybe it was the charger or the 3.0 boost that put too much power into her. Now being finicky about it's firmware updates and USB port issues 'are' pretty well documented.

The K95 likes to become one with the computer and she's not at all fond of being moved around. I've had to soft reinstall windows 7 64-bit at least twice because of her. She's well worth the trouble, and is much more behaved now that I'm keeping track of what USB port she gets plugged into. I wouldn't buy anything else honestly, if she bricked right now for no reason at all, I'd immediately buy another and have it express mailed to Alaska, no questions asked. RMA's take way too long and it's well worth the money to have her under my fingers.

Also; I'm one of them rare females that games, mods, builds, and codes wink.gif
Edited by Mystriss - 4/8/14 at 10:37pm
post #258 of 843
Thread Starter 
Quote:
Originally Posted by Mystriss View Post

I had the K90 originally and that worked flawlessly, went to a friend who is using it right now. As for the K95 usb3.0 bricking, it was relatively isolated... I think... At least there was only like one other post on it (though I can't seem find it now.) It was another person with a Sabertooth 990FX/Gen3 Rev2 though, so maybe it was the charger or the 3.0 boost that put too much power into her. Now being finicky about it's firmware updates and USB port issues 'are' pretty well documented.

The K95 likes to become one with the computer and she's not at all fond of being moved around. I've had to soft reinstall windows 7 64-bit at least twice because of her. She's well worth the trouble, and is much more behaved now that I'm keeping track of what USB port she gets plugged into. I wouldn't buy anything else honestly, if she bricked right now for no reason at all, I'd immediately buy another and have it express mailed to Alaska, no questions asked. RMA's take way too long and it's well worth the money to have her under my fingers.

Also; I'm one of them rare females that games, mods, builds, and codes wink.gif
Quote:
she's not at all fond of being moved around. I've had to soft reinstall windows 7 64-bit at least twice because of her.

What hardware are you running, usually bad contacts cause this, or even IRQ assignments, CMOS battery etc(Changing SATA from ACHI to IDE mode). If it turns out to be the ram terminals a good cleaning and then thin application of electrical grease should do the trick. But with AM3 motherboards its sometimes the CPU socket as well......
post #259 of 843
I also have a K95, running through my USB 3.0 ports, no problem at all.
And i have had my pc with me for lans a few times, no problems either - no need to reinstall windows or anything like that
Only thing when going to lans is my pc is in a Corsair Obsidian 900D ... That bastard is heavy when you are going up to your friends who live in a appartment on the 5th floor tongue.gif
White Lightning
(14 items)
 
 
Old / sold rig
(12 items)
 
CPUMotherboardGraphicsRAM
5820k x99s sli krait gtx 980ti G1 hyperx fury ddr4 
Hard DriveHard DriveOSMonitor
ocz agility 240 samsung evo 850 500 Windows 7, 64 asus rog swift 
MonitorKeyboardPowerCase
xl2420t Corsair k95 Corsair Hx850 coolermaster Mastercase 5 pro 
MouseMouse Pad
Steelseries rival steelseries dex 
CPUMotherboardGraphicsGraphics
Intel core i7 3770K MSI Z77A-GD65 EVGA GTX 780 Classified EVGA GTX 780 Classified 
RAMHard DriveHard DriveCooling
Crucial DDR3 BallistiX  OCZ Agility 3 Samsung Spinpoint F3 Corsair H100i 
OSMonitorKeyboardPower
Windows 7, 64 bit BenQ XL2420T 120Hz Corsair K95 Corsair HX850 
CaseMouseMouse PadAudio
Corsair Obsidian 900D Corsair M65 Corsair MM600 Logitech G930 wireless headset 
CPUMotherboardGraphicsRAM
Intel i7 920 Gigabyte ex58ud4p sapphire 5970 kingston ram 
Hard DriveCoolingOSMonitor
Samsung spinpoint F1 Prolimatech Megahalems  Windows 7, 64 bit Phillips brilliance 230c 
KeyboardPowerCaseMouse
Logitech G15 Corsair Tx750w Antec 1200 Logitech G5 
  hide details  
Reply
White Lightning
(14 items)
 
 
Old / sold rig
(12 items)
 
CPUMotherboardGraphicsRAM
5820k x99s sli krait gtx 980ti G1 hyperx fury ddr4 
Hard DriveHard DriveOSMonitor
ocz agility 240 samsung evo 850 500 Windows 7, 64 asus rog swift 
MonitorKeyboardPowerCase
xl2420t Corsair k95 Corsair Hx850 coolermaster Mastercase 5 pro 
MouseMouse Pad
Steelseries rival steelseries dex 
CPUMotherboardGraphicsGraphics
Intel core i7 3770K MSI Z77A-GD65 EVGA GTX 780 Classified EVGA GTX 780 Classified 
RAMHard DriveHard DriveCooling
Crucial DDR3 BallistiX  OCZ Agility 3 Samsung Spinpoint F3 Corsair H100i 
OSMonitorKeyboardPower
Windows 7, 64 bit BenQ XL2420T 120Hz Corsair K95 Corsair HX850 
CaseMouseMouse PadAudio
Corsair Obsidian 900D Corsair M65 Corsair MM600 Logitech G930 wireless headset 
CPUMotherboardGraphicsRAM
Intel i7 920 Gigabyte ex58ud4p sapphire 5970 kingston ram 
Hard DriveCoolingOSMonitor
Samsung spinpoint F1 Prolimatech Megahalems  Windows 7, 64 bit Phillips brilliance 230c 
KeyboardPowerCaseMouse
Logitech G15 Corsair Tx750w Antec 1200 Logitech G5 
  hide details  
Reply
post #260 of 843
Quote:
Originally Posted by MCCSolutions View Post


What hardware are you running, usually bad contacts cause this, or even IRQ assignments, CMOS battery etc(Changing SATA from ACHI to IDE mode). If it turns out to be the ram terminals a good cleaning and then thin application of electrical grease should do the trick. But with AM3 motherboards its sometimes the CPU socket as well......

I suppose its possible its just the two of us' systems in the world. But honestly I'd assume if it were a problem specific to my system then I'd have other troubles, and the new K95 wouldn't work either. I had a K90 running for a good while, and my old K95 was up and working fine until I plugged her into the 3.0 port, then I got the new K95 and plugged her in no problem - other than having to soft reinstall Win 7 64-bit before I memorized what USB port I'm plugging her into; not had any trouble since then even though I've disassembled my system at least twice. I have reset my CMOS since getting the new K95, that was to reset my BIOS for my new GPU install though. *shrug* It's working now and I'm not having any troubles so I'm happy.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Case Mod Work Logs
Overclock.net › Forums › Case Mods & Cases › Builds & Case Mods › Case Mods › Case Mod Work Logs › "RIGHTEOUS GAMER!" Donation Build! AMD FX-8320 8 Core & R9 270x OC! ALL WC!!!