Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › R9 270x won't start up properly
New Posts  All Forums:Forum Nav:

R9 270x won't start up properly

post #1 of 3
Thread Starter 
I recently bought a Sapphire R9 270x Vapor X and got to install it today in my comp. Everything was working okay, but even after installing my drivers for the card Device Manager said that the graphics card wasn't starting up properly and said "Code 10".

I tried some games, and the instant it starts up it goes to a black screen and ultimately back to my desktop screen and says "Direct3D start up failed" or something along those lines. I had a GeForce card in before, and I uninstalled all that I could find from that software. I even uninstalled and reinstalled the drivers which hasn't fixed the issue.



I apologize if this is confusing, but it is late. Am I missing a step? I don't remember my GeForce being this annoying.
post #2 of 3
Thread Starter 
To elaborate now that I am more awake

CPU: Phenom II X2 550
Mobo: Biostar A780L3B AMD 760G AM3 mATX Motherboard
RAM: Crucial Ballistix 2x4
PSU: Thermaltake TR2 700w
GPU: Sapphire Radeon R9 270X Vapor X
OS: Vista 32

Current GPU driver: 13.12
This morning I uninstalled the driver software again and then reinstalled it using the AMD Driver Detect.

I can use the card to display on my monitor, and I can get some higher resolutions, but if I try to play a game still it goes black and back to the desktop saying the Direct3D failed and device manager still says the card isn't starting right with "Code 10"

I did look around and I saw that other people had similar issues with Vista, but most of them solved it by downloading the 13.11 beta drivers so that solution is not applicable.

Also, as for any questions about the odd mishmash of hardware it is because I am in the middle of upgrading my hardware piece by piece. My first series of upgrades was the case, PSU and GPU.

Any idea what might be happening? Or at least some things I could try to solve the problem?
post #3 of 3
Thread Starter 
So, I uninstalled drivers and the R9 270x from video adapters and such, and then when the comp was off I took out the card. Booted it without the card and blahblahblah

After I booted the computer back up with the card and everything it registered as "Standard VGA Graphics Adaptor" which is normal, but this time after the software downloads and everything the card didn't get recognized. So I went in Device Manager and

Right clicked the Standard VGA adapter clicked update driver software browsed my computer selected "Let me pick"
then clicked "Have disk" and then browse again searched for c:\AMD opened up folder selected support, 13-12, packages, drivers, display, LH_INF, CL165822 located AMD Radeon R9 200 Series since Radeon R9 270x was not listed

after that it simply went to Input Signal Out of Range and the monitor went to sleep.

Oh, and it the error message from earlier was actually "Failed to initialize Direct3D9"
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › R9 270x won't start up properly