Overclock.net › Forums › Overclock Marketplace › Online Deals › Expired Deals › [NEWEGG] - ASRock Fatal1ty Z87 Killer LGA 1150 - $99.99 (after $20 MIR)
New Posts  All Forums:Forum Nav:

[NEWEGG] - ASRock Fatal1ty Z87 Killer LGA 1150 - $99.99 (after $20 MIR)

post #1 of 4
Thread Starter 
Feature wise I don't see a better motherboard for $100. I paid $115 for the last one.

I have one of these and I really like the BIOS.

The motherboard seems kind of thin, but it probably won't be an issue if you have a decent case and keep the temps down.

I would highly recommend this board except the one little (well not so little) issue. With W8.1 with computer crashes (BSOD) does a core-dump on a daily bases with the current drivers from ASRock. I used WinDbg to trace the problem to The driver software for the "Killer" NIC. I have tried updating the driver (from Qualcomm), but still have the issue quite frequently. Other people report the same issue, so I'm not alone.

I did read that someone was able to load the driver without loading the corresponding desktop app/service and the issue went away. I did not try that yet. I have the computer configured to reboot and resume whats its doing, so its not an issue for me right now.

I do know, downloading bit-torrents to a network drive will kill it fast frown.gif

I do hope the issue gets resolved as now I'll have two of these now:

http://www.newegg.com/Product/Product.aspx?Item=N82E16813157460
Edited by bbond007 - 4/9/14 at 7:47am
post #2 of 4
Quote:
Originally Posted by bbond007 View Post

Feature wise I don't see a better motherboard for $100. I paid $115 for the last one.

I have one of these and I really like the BIOS.

The motherboard seems kind of thin, but it probably won't be an issue if you have a decent case and keep the temps down.

I would highly recommend this board except the one little (well not so little) issue. With W8.1 with computer crashes (BSOD) does a core-dump on a daily bases with the current drivers from ASRock. I used WinDbg to trace the problem to The driver software for the "Killer" NIC. I have tried updating the driver (from Qualcomm), but still have the issue quite frequently. Other people report the same issue, so I'm not alone.

I did read that someone was able to load the driver without loading the corresponding desktop app/service and the issue went away. I did not try that yet. I have the computer configured to reboot and resume whats its doing, so its not an issue for me right now.

I do know, downloading bit-torrents to a network drive will kill it fast frown.gif

I do hope the issue gets resolved as now I'll have two of these now:

http://www.newegg.com/Product/Product.aspx?Item=N82E16813157460



I own this board, i've had it about 5 months, i've never had a crash or any of the issues you are talking about, and you said torrents will kill it fast? what? I do not have the stupid killerNIC program, I installed the drivers manually.
post #3 of 4
i have this board as well, killer nic works fine with latest win 7 64 ultimate
2nd itx
(15 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k p8z77-i deluxe sapphire 7970 dual-x ballistix tactical 2 x 8gb 1600 1.35v cas 8 
Hard DriveCoolingOSMonitor
samsung 840 240gb, 1tb spinpoint f3, 2tb spinpo... corsair H90 win 7 ultimate 64 asus pb278q 
KeyboardPowerCaseMouse
cm quickfire pro (mx brown) silverstone 600w (from sg07) node 304 logitech g700 
Mouse PadAudioAudio
gigapbyte ghost kingston hyperx cloud logitech z623 
  hide details  
Reply
2nd itx
(15 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k p8z77-i deluxe sapphire 7970 dual-x ballistix tactical 2 x 8gb 1600 1.35v cas 8 
Hard DriveCoolingOSMonitor
samsung 840 240gb, 1tb spinpoint f3, 2tb spinpo... corsair H90 win 7 ultimate 64 asus pb278q 
KeyboardPowerCaseMouse
cm quickfire pro (mx brown) silverstone 600w (from sg07) node 304 logitech g700 
Mouse PadAudioAudio
gigapbyte ghost kingston hyperx cloud logitech z623 
  hide details  
Reply
post #4 of 4
Thread Starter 
Quote:
Originally Posted by Nightfallx View Post

I own this board, i've had it about 5 months, i've never had a crash or any of the issues you are talking about, and you said torrents will kill it fast? what? I do not have the stupid killerNIC program, I installed the drivers manually.

just it seems to BSOD quite frequently when torrents downloading to a NAS (network attached storage) ...
Quote:
Originally Posted by ninong View Post

i have this board as well, killer nic works fine with latest win 7 64 ultimate

always this error:

BugCheck 1E, {ffffffffc0000094, fffff80001ea87f0, ffffd000224c6c58, ffffd000224c6460}

*** ERROR: Module load completed but symbols could not be loaded for bwcW8x64.sys
Probably caused by : bwcW8x64.sys ( bwcW8x64+37f0 )


anyway, I still think its a great board for the $115, and now $100. I'll eventually get the BSOD sorted out. I just want people to be aware of one potential issue...

http://www.google.com/search?hl=en&source=hp&q=BugCheck+1E+bwcW8x64.sys
Edited by bbond007 - 4/9/14 at 11:31am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Expired Deals
Overclock.net › Forums › Overclock Marketplace › Online Deals › Expired Deals › [NEWEGG] - ASRock Fatal1ty Z87 Killer LGA 1150 - $99.99 (after $20 MIR)