post #1 of 1
Thread Starter 
This might be the wrong forum to post this in but as I suspect my GPU could be the problem, I thought I'd try here.

So my PC has started locking up in particular games. When it does screen typically goes black, sound still plays/ loops in the background but the PC goes completely unresponsive and I have to shut down to recover. I first noticed it in Elder Scrolls Online. If I set graphics quality to anything above Low, it crashes as soon as the character selection screen loads. Then I noticed it in BF4. It does the same thing during the opening cinematic. Other games run just fine... I played the Wildstar beta for hours without a hiccup for example.

My system:
Asus P8P67 Pro
Intel 2600k
2x 4GB G.SKILL Ripjaws X DDR3 1600
Ultra X3 1000W PSU
Asus 7970 DCii

All drivers are up to date. I've done a fresh install of Windows 7. Nothing is overclocked. I've had no issues with Prime95 or Windows mem checker. I've run FurMark with no issues. Heaven produces the lock a couple of minutes in in both DX11 and DX9 modes, though DX9 runs longer than DX11.

Anybody have any suggestions on what to try next? At this point, I can't see any explanation other than a failing piece of hardware. I'm just not sure how to isolate further. Any advice is appreciated! Thanks in advance!
Old reliable
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600k ASUS P8P67 PRO ASUS 7970 DCUIII G.SKILL Ripjaws X DDR3 1600 
MonitorKeyboardPowerCase
Dell 2407WFP Logitech G15 Ultra X3 1000W Corsair Carbide Air 540 
Mouse
Shogun Brothers Ballista MK-I 
  hide details  
Reply
Old reliable
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600k ASUS P8P67 PRO ASUS 7970 DCUIII G.SKILL Ripjaws X DDR3 1600 
MonitorKeyboardPowerCase
Dell 2407WFP Logitech G15 Ultra X3 1000W Corsair Carbide Air 540 
Mouse
Shogun Brothers Ballista MK-I 
  hide details  
Reply