Overclock.net › Forums › Graphics Cards › NVIDIA › GPU Clock Not Boosting On Certain DX9 Games
New Posts  All Forums:Forum Nav:

GPU Clock Not Boosting On Certain DX9 Games

post #1 of 5
Thread Starter 
So, I've got an FX 8320 overclocked to 4.2 GHz paired with my GTX 770. CPU temp never exceeds 55 C, GPU temp never exceeds 65 C. This is simply not an issue with heat as it boosts up just fine in far more intensive games. When I play Borderlands 2, my GPU clock does exceed 1137 MHz (the base clock), when it should be boosting to 1280 MHz. This causes poor framerate. This only happens in Borderlands 2 and Skyrim (no mods). All my other games are okay. I can Battlefield 4 for hours without the memory or core clocks dipping at any point. Why would my GPU not be boosting to its full clock on these two games (especially Borderlands 2)..?
post #2 of 5
Quote:
Originally Posted by Propheciah View Post

So, I've got an FX 8320 overclocked to 4.2 GHz paired with my GTX 770. CPU temp never exceeds 55 C, GPU temp never exceeds 65 C. This is simply not an issue with heat as it boosts up just fine in far more intensive games. When I play Borderlands 2, my GPU clock does exceed 1137 MHz (the base clock), when it should be boosting to 1280 MHz. This causes poor framerate. This only happens in Borderlands 2 and Skyrim (no mods). All my other games are okay. I can Battlefield 4 for hours without the memory or core clocks dipping at any point. Why would my GPU not be boosting to its full clock on these two games (especially Borderlands 2)..?

seems like there is some conflict with nvidia boost/physx and this game. have you tried with the physx set to off or low?
X7900D
(8 items)
 
  
Reply
X7900D
(8 items)
 
  
Reply
post #3 of 5
Thread Starter 
Quote:
Originally Posted by abirli View Post

seems like there is some conflict with nvidia boost/physx and this game. have you tried with the physx set to off or low?

I think I am going to try uninstalling PhysX and see what kind of results I get. Thanks.

Edit: Just remembered that uninstalling the software will simply make my CPU run it, oops (I think). I'll try it on low then.
Edited by Propheciah - 4/18/14 at 10:39am
post #4 of 5
Try enabling the "K-boost" feature in Evga Precision(It's under the voltage section). This should lock your card at full boost clocks. Run the games you're having issues in and see if that helps.
Edited by bvsbutthd101 - 4/18/14 at 12:46pm
post #5 of 5
Thread Starter 
Quote:
Originally Posted by bvsbutthd101 View Post

Try enabling the "K-boost" feature in Evga Precision(It's under the voltage section). This should lock your card at full boost clocks. Run the games you're having issues in and see if that helps.

You just earned yourself a rep man. I can't believe I overlooked something so simple! My game runs like it should now, no more drops to 25 FPS like I was getting. Stays above 50 at all times with V Sync on. I guess I'll just have to enable K-Boost any time I want to play Borderlands, but at least it is playable now.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › GPU Clock Not Boosting On Certain DX9 Games