Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Sapphire r9 280x Toxic Vsync framedrops
New Posts  All Forums:Forum Nav:

Sapphire r9 280x Toxic Vsync framedrops

post #1 of 6
Thread Starter 
First of all, excuse me if I posted in the wrong section. Feel free to move my thread.

Hello dear fellow OCers,

I come to you with the following problem, something that has been driving me crazy for a few days and I can not seem to figure out what is causing it.

First of all I will list my specs:

Asus p6x58d Premium
i7 960 @ 3.8ghz (temps under stress do not exceed 60º celsius)
12gb G-Skill @1600mhz
Samsung 840, 250gb
Sapphire R9 280x Toxic @ stock
Soundblaster Z audio card
Windows 7

While playing all sorts of games (from Counter Strike Source to Battlefield 4 to League of Legends) I am noticing very subtle (but noticeable and "flow-breaking") frame drops when vsync is activated.

As an example I will give you Counter Strike Source: With maxed settings and without vsync activated, i achieve a steady 299 FPS in the video stress test.
This sounds good right? Well wait for it...
As soon as I activate Vsync it shows a neat 60fps, but it will randomly drop to 55/58 and you will notice a small hickup, but just for a second.
As far as I understand, my system should be able to run this game at 60fps steady without any kind of slow downs or frame drops.
I understand the purpose of vsync and all I want is to run my game at 60 fps to avoid screen tearing and deliver a smoother game experience, that is all.


What I have tried:

Reinstall video drivers. (Tried various ones, from the newest Beta to 13.12.)
Reinstall audio drivers.
Remove audio card.
Removing the OC from my processor.
Memtest.
Removing all USB apparels that are not necessary except for my keyboard and mouse.
Reinstalling windows 7.
Unpark my CPU cores.

The temps of my graphic card do never exceed 65/70º celsius at any time, same with my processor, which stays under 60º celsius when Overclocked and around 50º when running stock. Airflow in my case is excellent so temps should not be causing a throttle imo.

Again I would like to state that these frame drops only seem to occur with vsync activated. Perhaps I also lose a few frames without vsync, but when you are having 150+fps in most games that is not noticeable, unfortunately the screen tearing is...

I am to my wits end and do not know what I can try anymore or where I should be looking for the cause if these annoying frame drops.

In a game like battlefield 4 I can understand this happens when its a 64 player map since its a heavy game,
but in League of Legends or Counter Strike Source this should not be happening, or am I wrong and overlooking something?


Please OCers, enlighten me.
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
post #2 of 6
Are you positive you never see dips to that range with vsync disabled? Most in-game fps counters don't update fast enough to catch all dips/spikes. If you have vsync enabled and your system ever needs to wait over 16.66ms (@60Hz) for a frame, for any reason, you will see two identical frames back to back, resulting in a split second stutter.

Another potential issue is that some games apparently do no know how to order pre-rendered frames correctly, and can pull a frame other than the most recently rendered one out of the queue and display this outdated image, again resulting in a stutter. Setting flipqueuesize (either via the registry or with a tool such as RadeonPro) to 1 can solve this, if it's the issue
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #3 of 6
Thread Starter 
Well when running games with vsync disabled i experience some frame drops which is normal depending on what is being rendered, but as an example that would be from 150fps to 135fps, not from 150fps to the -60 range.

I will try what you advice me concerning the flipqueuesize and will report back to you with an update if it helped or if not.

+rep for your well thought out reply, thank you I appreciate it.

EDIT: Tried forcing Flipqueuesize to 1 with Radeonpro and unfortunately i am still experiencing frame drops. In League of Legends its the most noticeable.

I can reproduce it by standing in fountain with 60 solid FPS, open shop tab, buy an item, and can see in the top right corner my FPS dropping to 50 for 2 seconds. Could someone else test this perhaps to see if they experience the same?

EDIT 2: I would also like to state that in my resource manager/monitor (sorry, my OS is in Spanish) I can see a lot (+500) of page fault errors (regarding to memory) when opening certain programs. Is this a normal thing? Could this be causing the "frame drops/spikes"?
Edited by N0ID - 4/19/14 at 4:48am
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
post #4 of 6
Page faults are normal, it simply means that the requested data wasn't in memory and has to be retrieved from somewhere else (the disk). Such an access delay could cause dips in frame rate.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #5 of 6
Thread Starter 
What could be the cause of such errors? Is this RAM related? I ran a memtest for a few hours and it showed up no errors.
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
post #6 of 6
Thread Starter 
Just giving this a bump to see if someone else has an idea of what might be going on, as the problem still persists. redface.gif

If anyone is interested I could record a video of the issue to make it more clear.
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
Gaming Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 960 3.5Ghz Asus P6X58D Premium GTX 970 G1 Gaming OCZ 3x4 GB @ 1600 
Hard DriveCoolingOSMonitor
Samsung 840 250gb Noctua NH-U12P SE2 Windows 7 x64 BenQ E2400HD 
PowerCase
Corsair HX750 Cooler Master HAF 922 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Sapphire r9 280x Toxic Vsync framedrops