Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › [ARCH] Fresh install hangs at different points every reboot?
New Posts  All Forums:Forum Nav:

[ARCH] Fresh install hangs at different points every reboot?

post #1 of 12
Thread Starter 
I just finished installing Arch on my laptop and everything went fine, no issues what so ever, but when I actually go to reboot from the install media to the actual system it starts the boot process, but it hangs at random points.

The first time it hung at Bluetooth target reached.

The second time it hung at Kernel Mode Driver or Debug, forget which one now.

This time it's hanging at Starting Load/Save Screen Backlight Brightness of leds:asus:kbd_backlight...

I'm at a lost for where to start debugging now since it's different points that it hangs at. Any ideas?

I have a very bad gut feeling that the hard drive it was installed on is/was dead. I hear faint scratching/clicking sounds every so often when it hits a certain area of the disk. Running tests now.
Edited by bryce - 4/24/14 at 7:28am
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
post #2 of 12
I'm sorry I have to agree that scratching and clicking are almost always signs of imminent hdd failure. It seems you have some skills so you probably already know this but let me reinforce it. Backup anything you need NOW!
NewMain
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 - 3550 Asrock Z77 Extreme4 Evga GTX 1070Ti  4x2GB Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate SATA 2TB x 2  Plextor PX-891SAW CM-Hyper N520 Slackware 14.2 MultiLib, Slackware 14.0 32 bit,... 
MonitorKeyboardPowerCase
32" Vizio HDTV + DLP Logitech Wireless Corsair HX-850 Antec Sonata I 
MouseMouse PadAudioOther
Razer DeathAdder 2013 dual ESI Juli@ CoolGear ExtSata Enclosure w/ Optical and 3TB S... 
  hide details  
Reply
NewMain
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 - 3550 Asrock Z77 Extreme4 Evga GTX 1070Ti  4x2GB Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate SATA 2TB x 2  Plextor PX-891SAW CM-Hyper N520 Slackware 14.2 MultiLib, Slackware 14.0 32 bit,... 
MonitorKeyboardPowerCase
32" Vizio HDTV + DLP Logitech Wireless Corsair HX-850 Antec Sonata I 
MouseMouse PadAudioOther
Razer DeathAdder 2013 dual ESI Juli@ CoolGear ExtSata Enclosure w/ Optical and 3TB S... 
  hide details  
Reply
post #3 of 12
I'm guessing you aren't overclocked, but my Arch install will hang on random boot spots when I am overclocked. Even a very modest overclock can lock it up. Weirdly if I am able to boot it runs fine.
post #4 of 12
Thread Starter 
Hard drive test is about done, but so far nothing has failed on it. Not like I had anything on it anyways since I just formatted the entire drive for Arch lol.

But it won't boot period, it just hangs at random spots after the install. I've had it sitting for an hour when testing it before checking the hard drive and it didn't move from the spot it froze at.

Maybe I'll try another distro just to see if it does the same thing.

EDIT: Harddrive passed everything. Guess it is failing just to early for any tests to tell maybe? I only heard a scratching for a couple seconds then it stopped. Haven't heard it again now.
Edited by bryce - 4/24/14 at 11:33am
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
post #5 of 12
Quote:
Originally Posted by bryce View Post

I just finished installing Arch on my laptop and everything went fine, no issues what so ever, but when I actually go to reboot from the install media to the actual system it starts the boot process, but it hangs at random points.

The first time it hung at Bluetooth target reached.

The second time it hung at Kernel Mode Driver or Debug, forget which one now.

This time it's hanging at Starting Load/Save Screen Backlight Brightness of leds:asus:kbd_backlight...

I'm at a lost for where to start debugging now since it's different points that it hangs at. Any ideas?

I have a very bad gut feeling that the hard drive it was installed on is/was dead. I hear faint scratching/clicking sounds every so often when it hits a certain area of the disk. Running tests now.

Disable legacy USB in your UEFI. I.e. there should be some legacy device detection for USB ports. Disable that. Had this problem on my Z87 board.
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
post #6 of 12
Thread Starter 
I haven't thought of that, will try it after this is finished installing for the 5th time today and see if it works.
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
post #7 of 12
Quote:
Originally Posted by bryce View Post

I haven't thought of that, will try it after this is finished installing for the 5th time today and see if it works.

Yeah, mine was actually hanging because of a USB device that didn't behave well with the legacy mode for some reason. I could boot fine every time with that device removed, but incidentally with that device plugged in, I could boot successfully maybe one of every three attempts.
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
post #8 of 12
Thread Starter 
Well thing is I had nothing plugged in to the laptop though. Maybe it's something internally hanging it up. Won't hurt to try, just finishing up the install currently.

Nope, disabling Legacy USB didn't do anything. Still freezes on boot. This first time it froze on "Starting Load/Save Screen Backlight Brightness of leds:asus:kbd_backlight...
Edited by bryce - 4/24/14 at 1:54pm
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
post #9 of 12
What laptop do you have?

I need to do some research, it's either a BIOS setting or a Kernel module causing your lockup on boot. I know the current Asus module set tries to load itself on any hardware where a certain bus address exists - even if it's not a laptop or even an Asus product. You end up having to blacklist all of that garbage to get them to stop loading (which shaves like 3-4 seconds off your boot time) I haven't had them locking me up though, but who knows since they try to access random devices depending on the status.
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 920 D0 4.2ghz HT (1.3625v) Asus R3E 2xGTX 460 (non SLi, no overclock) 6x2gb G.skill @ 6-8-6-24-1T 
Hard DriveOptical DriveOSMonitor
WD-VR 300GBx1, 2xWD 1tb,2x60gb Agility Some crappy combo burner... Arch x64 3xDell U2410f rev A02 
KeyboardPowerCaseMouse
X-Armor U9BL TT Toughpower 1200w (NTB more efficient) Mountain Mods Pinnacle 24 CYO Roccat Kone (R.I.P. A4Tech x7) 
Mouse Pad
Steelpad Experience I-1 
  hide details  
Reply
post #10 of 12
Thread Starter 
Asus G75VW is what I have.

Installed it on another drive I have just to rule out the drive and it does the same thing. Freezes at random points during boot.
Edited by bryce - 4/24/14 at 7:00pm
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
i7-6700k @ 4.6ghz ASUS Maximus VIII Hero Nvidia GTX 1080 Founders Edition Nvidia GTX 1080 Founders Edition 
RAMHard DriveHard DriveHard Drive
G.SKILL Ripjaws V DDR4.3200 2x8GB Samsung 950 Pro M2 SSD Samsung 850 Evo SSD Samsung 850 Pro SSD 
Optical DriveCoolingOSMonitor
Why??? Swiftech H240 X2 Windows 10 Pro Insider Build x64 ASUS ROG 27" P278Q 
MonitorMonitorKeyboardPower
ASUS ROG 27" P278Q ASUS ROG 27" P278Q Razer Blackwidow Ultimate EVGA G2 750W 
CaseMouseMouse PadAudio
Corsair 750D Logitech G600 Why??? Onboard Audio For Now 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › [ARCH] Fresh install hangs at different points every reboot?