Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire R9 290 artifacts
New Posts  All Forums:Forum Nav:

Sapphire R9 290 artifacts - Page 2

post #11 of 13
Quote:
Originally Posted by MAD100007 View Post

I can't change the clocks, because I don't have any drivers installed. Afterburner doesn't recognize it and I don't have CCC. My sister's pc doesn't recognizes the gpu in CCC...
Right, sounds like you have damaged the card.
Quote:
Originally Posted by MAD100007 View Post

I didn't see any sticker when removing the cooler. Should there be one?
That's good, because as long as you make it look as if you haven't touched anything, you should be able to RMA
 
Home Server
(11 items)
 
 
Reply
 
Home Server
(11 items)
 
 
Reply
post #12 of 13
What motherboard are you putting this card into? I ask because some mother boards actually require an updated bios to use some of the newer AMD cards.
post #13 of 13
Quote:
Originally Posted by Roxxas049 View Post

What motherboard are you putting this card into? I ask because some mother boards actually require an updated bios to use some of the newer AMD cards.

The card was working properly before...
Intel Killer
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD 8320 4.4ghz Gigabyte 990fx XFX R9 290 (1100/1250) 8GB DDR3 1866 
Hard DriveCoolingOSMonitor
750GB Momentus XT Corsair H80i Windows 8 3x 23" 1080p 
KeyboardPower
Logitech Mk 710 OCZ 1000 watts 
  hide details  
Reply
Intel Killer
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD 8320 4.4ghz Gigabyte 990fx XFX R9 290 (1100/1250) 8GB DDR3 1866 
Hard DriveCoolingOSMonitor
750GB Momentus XT Corsair H80i Windows 8 3x 23" 1080p 
KeyboardPower
Logitech Mk 710 OCZ 1000 watts 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire R9 290 artifacts