Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Having issues with overclocking, speedstep and turbo mode on i7-3720QM.
New Posts  All Forums:Forum Nav:

Having issues with overclocking, speedstep and turbo mode on i7-3720QM. - Page 4

post #31 of 37
http://i.imgur.com/s0PMBji.png

The sensors tab in GPU-Z and the graphs in MSI Afterburner should be showing the actual MHz your GPU is running at. The Heaven benchmark is not too stressful so my GT 755M is using lots of boost. Afterburner reports the GPU memory MHz as double what GPU-Z reports ( 1350 MHz x 2 = 2700 MHz ) but it means the same thing.

There is another GPU overclocking program called Nvidia Inspector.

http://www.guru3d.com/files-details/nvidia-inspector-download.html

I think the problem with some of the GTX 675M GPUs is that instead of always staying in the highest power state (P0), they will sometimes randomly throttle back to the (P1) state. That might be what is causing your overclock not to stick. If your GPU is supported, Nvidia Inspector might be able to give you access to some more of the P states so you can overclock them too. You will need to find a forum specific to your laptop and this GPU to find out what you need to do to overclock or to see if it is possible. It might not be possible with software. Sometimes the only way is with a modified GPU bios which some people would rather not get into.
Edited by unclewebb - 7/11/14 at 1:24pm
post #32 of 37
Thread Starter 
Quote:
Originally Posted by unclewebb View Post

http://i.imgur.com/s0PMBji.png

The sensors tab in GPU-Z and the graphs in MSI Afterburner should be showing the actual MHz your GPU is running at. The Heaven benchmark is not too stressful so my GT 755M is using lots of boost. Afterburner reports the GPU memory MHz as double what GPU-Z reports ( 1350 MHz x 2 = 2700 MHz ) but it means the same thing.

There is another GPU overclocking program called Nvidia Inspector.

http://www.guru3d.com/files-details/nvidia-inspector-download.html

I think the problem with some of the GTX 675M GPUs is that instead of always staying in the highest power state (P0), they will sometimes randomly throttle back to the (P1) state. That might be what is causing your overclock not to stick. If your GPU is supported, Nvidia Inspector might be able to give you access to some more of the P states so you can overclock them too. You will need to find a forum specific to your laptop and this GPU to find out what you need to do to overclock or to see if it is possible. It might not be possible with software. Sometimes the only way is with a modified GPU bios which some people would rather not get into.
Quote:
Originally Posted by unclewebb View Post

http://i.imgur.com/s0PMBji.png

The sensors tab in GPU-Z and the graphs in MSI Afterburner should be showing the actual MHz your GPU is running at. The Heaven benchmark is not too stressful so my GT 755M is using lots of boost. Afterburner reports the GPU memory MHz as double what GPU-Z reports ( 1350 MHz x 2 = 2700 MHz ) but it means the same thing.

There is another GPU overclocking program called Nvidia Inspector.

http://www.guru3d.com/files-details/nvidia-inspector-download.html

I think the problem with some of the GTX 675M GPUs is that instead of always staying in the highest power state (P0), they will sometimes randomly throttle back to the (P1) state. That might be what is causing your overclock not to stick. If your GPU is supported, Nvidia Inspector might be able to give you access to some more of the P states so you can overclock them too. You will need to find a forum specific to your laptop and this GPU to find out what you need to do to overclock or to see if it is possible. It might not be possible with software. Sometimes the only way is with a modified GPU bios which some people would rather not get into.

Yea so I downloaded NVidiad inspector. So the core clocks are greyed out there so I can't change any values unless I have missed a option to unlock this. Though when I change the value in MSI Afterburner Nvidia Inspector seems to recognize it and changes it also in the p0 state. I think your right about it randomly throttling back though, I see my p1 state is at 620Mhz thats where it stays at I havent seen it going to the p0 state. I wouldn't mind to go all the way to fix it even if it means going for a modified GPU bios. I find this all pretty interesting and fun. As long I don't **** up my system ^^.

Edit: Actually I wasn't looking right. Even my p0 state still is at 620Mhz


Edit edit tongue.gif :I think it does recognize my 680Mhz I'm just getting confused by the arrow pointing the start of the bar but the number in the middle does say 680Mhz.
So how could we get it running in the p0 state? Does it do that when I play games though?

Edit edit edit:I've tried some gaming and let GPU-Z make a log while doing so, I can confirm now, even when playing a game. My GPU never goes into p0 state but stays in p1. So yea never even reaching my default core clock.
Edited by Gerardn91 - 7/11/14 at 2:14pm
post #33 of 37
The throttling problem you have discovered has been around for quite a while. The GTX 675M is exactly the same as the previous GTX 580M. Over the years Nvidia has given new names to old GPUs. The hardware for these two is exactly the same, with the same throttling problem.

Mr. Fox on NBR came up with a fix / band-aid for this using Nvidia Inspector almost 3 years ago. If this works for you, it is safer than trying to do a bios mod.

http://forum.notebookreview.com/alienware-18-m18x/627874-m18x-gtx-580m-sli-throttle-fix-software-overclocking-no-vbios-flashing-required.html

He was using this on 2 cards in a SLI setup on an Alienware laptop but you should be able to modify his script so it only applies these settings to your single GPU.
post #34 of 37
Thread Starter 
Quote:
Originally Posted by unclewebb View Post

The throttling problem you have discovered has been around for quite a while. The GTX 675M is exactly the same as the previous GTX 580M. Over the years Nvidia has given new names to old GPUs. The hardware for these two is exactly the same, with the same throttling problem.

Mr. Fox on NBR came up with a fix / band-aid for this using Nvidia Inspector almost 3 years ago. If this works for you, it is safer than trying to do a bios mod.

http://forum.notebookreview.com/alienware-18-m18x/627874-m18x-gtx-580m-sli-throttle-fix-software-overclocking-no-vbios-flashing-required.html

He was using this on 2 cards in a SLI setup on an Alienware laptop but you should be able to modify his script so it only applies these settings to your single GPU.
Quote:
Originally Posted by Mr. Fox View Post

"Select GPU0 in the lower left corner, change the Performance Level (drop down at top right side) to P1 and set the Shader Clock to 1240. This will match your factory default for P0."

My p1 state shader clock already is at 1240, and if I change anything to it, it just puts it back at 1240 immediatly.

Edit: It worked! I made a batch file out of it like Mr Fox said on that page you linked me, turned Throttlestop on, got the latest Nvidia inspector. And it seems to run at the speeds I've putted in the batch files.

Though my ingame FPS in Arma 2 didn't change at all so I think we can now surely say the game is blocking something right? tongue.gif
Here's a new GPU-z log file with the changes I made: http://m.uploadedit.com/b037/1405173802419.txt

Edit edit: What about this line though: -setVoltage:0,2,870 are these voltage settings dangerous? I find it kinda wierd that if you change the shader clock in the batch file you automaticly change the core clock how does that work? Isn't it possible to just only change the core clock? This is the line that I used to get it at 725Mhz: start D:\nvidiaInspector\nvidiaInspector.exe -setShaderClock:0,2,1450 -setMemoryClock:0,2,1500 -setVoltage:0,2,870
Also, I've checked what happened at Nvidia Inspector, what this did is just change my p1 settings, my GPU still never gets into p0 state. Not that it matters as long as it runs my games at desired clocks. Does this btw lower the lifetime of my graphics card?
Edited by Gerardn91 - 7/12/14 at 7:35am
post #35 of 37
Thread Starter 
Also did a new unigine benchmark, I don't think I noticed any artifacts. I'm so paranoid about not destroying my GPU that somethimes I got confused if the red circle appearing was a lensflare or actually a graphical bug but I think all is okej tongue.gif

Here's the old benchmark again:http://pastebin.com/erJcQBXp *coreclock: 620Mhz *memmory: 1500Mhz *shader:1240
New benchmark: http://pastebin.com/7K4y6Y4F *coreclock 675Mhz *memory:1500Mhz *shader:1350
post #36 of 37
The problem is that these cards do not stick in P0. They throttle back to P1. The Nvidia Inspector fix sets P0 and P1 to the same speed so even when your GPU does throttle, it will still maintain the full speed that you have requested.

By default, Nvidia used to link the GPU Core MHz and the GPU shader MHz so the shader was always exactly GPU Core x 2. On your card this might be forced in hardware so when you adjust one the other automatically gets adjusted to maintain this x 2 ratio.

The GPU-Z log you posted shows your voltage at only 0.8500 volts. That's very low. Perhaps when your GPU was reporting much higher temperatures the GPU volts were significantly higher. The Nvidia recommended GPU core MHz for these are 620 MHz. I think MSI did a factory overclock up to 633 MHz and with this speed might also be using a higher voltage. You could reboot and not run Nvidia Inspector and do some more logging with GPU-Z. If 633 MHz ever shows up in the log file, check out what it shows for voltage. I use the Heaven benchmark because I can use it to run the bench in a very small screen so it puts a smaller amount of load on the GPU. This might allow your GPU to get into the P0 state and stay there just so you get a better understanding of how much voltage MSI was using.

The next place for a performance boost is the GPU memory. A Nvidia Inspector setting of 1500 seems to get you a reading of 750 in GPU-Z. With this card I have seen 900+ MHz in a GPU-Z screen shot so you might want to try working your way up from 1500 to 1800 if possible.

Are you having fun yet? biggrin.gif

As long as your voltage is as low as it is, I do not think you are going to hurt anything by playing a little with your GPU. Your temperatures are also very low. They are both lower than stock actually since the voltage is now so low.

Edit- Check out the minimum frame rate in your benchmark. 7.4 to 19.6 FPS. Those are the kind of numbers that make a huge difference in play ability of any game.

Lots of memory bandwidth is a good thing.

http://i.imgur.com/hl7wIpW.png
Edited by unclewebb - 7/12/14 at 8:28am
post #37 of 37
Thread Starter 
Quote:
Originally Posted by unclewebb View Post

The problem is that these cards do not stick in P0. They throttle back to P1. The Nvidia Inspector fix sets P0 and P1 to the same speed so even when your GPU does throttle, it will still maintain the full speed that you have requested.

By default, Nvidia used to link the GPU Core MHz and the GPU shader MHz so the shader was always exactly GPU Core x 2. On your card this might be forced in hardware so when you adjust one the other automatically gets adjusted to maintain this x 2 ratio.

The GPU-Z log you posted shows your voltage at only 0.8500 volts. That's very low. Perhaps when your GPU was reporting much higher temperatures the GPU volts were significantly higher. The Nvidia recommended GPU core MHz for these are 620 MHz. I think MSI did a factory overclock up to 633 MHz and with this speed might also be using a higher voltage. You could reboot and not run Nvidia Inspector and do some more logging with GPU-Z. If 633 MHz ever shows up in the log file, check out what it shows for voltage. I use the Heaven benchmark because I can use it to run the bench in a very small screen so it puts a smaller amount of load on the GPU. This might allow your GPU to get into the P0 state and stay there just so you get a better understanding of how much voltage MSI was using.

The next place for a performance boost is the GPU memory. A Nvidia Inspector setting of 1500 seems to get you a reading of 750 in GPU-Z. With this card I have seen 900+ MHz in a GPU-Z screen shot so you might want to try working your way up from 1500 to 1800 if possible.

Are you having fun yet? biggrin.gif

As long as your voltage is as low as it is, I do not think you are going to hurt anything by playing a little with your GPU. Your temperatures are also very low. They are both lower than stock actually since the voltage is now so low.

Edit- Check out the minimum frame rate in your benchmark. 7.4 to 19.6 FPS. Those are the kind of numbers that make a huge difference in play ability of any game.

Lots of memory bandwidth is a good thing.

http://i.imgur.com/hl7wIpW.png

Haha , yeah I've got nothing to do it keeps me busy, and it's fun to learn about this stuff. I'm wondering though, once I did a benchmark with these settings
-CoreClock 725Mhz -ShaderClock:1450 -MemoryClock:1500, and the temperatures were fine. Though I didn't see artifacts or wierd 3d buggs I did see like some parts of my screen were flickering away for like 1 seconds very few times. Could that be because of the low voltage? I canceled that benchmark because of seeing that.
I'm going to see what adding the memmory clock is going to bring as results.
Edit: I changed the -setMemoryClock to 1800 and made a new batch file. The core clock and shader clock correspond to what I wrote in the batch file, the memmory clock doesn't want to change and keeps itself at 750 Mhz(so 1500 with the x2 ratio). And btw I can't change any values in NVidia inspector, they only change because I run the batch file I made. When I want to change a value through Nvidia Inspector it keeps putting it back to the value it was set as before.

Also you said the voltage was very low, what would it help to put it higher and is that nessecary?
Edited by Gerardn91 - 7/13/14 at 8:20am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Laptops and Netbooks
Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Having issues with overclocking, speedstep and turbo mode on i7-3720QM.