Overclock.net › Forums › Components › Mice › Logitech G502 Firmware Update Fail (Fixed)
New Posts  All Forums:Forum Nav:

Logitech G502 Firmware Update Fail (Fixed) - Page 2

post #11 of 17
Quote:
Originally Posted by Oeshon View Post

It is one I purchased.
Contact customer care. If you have a retail unit that will not respond to the firmware updater, it likely needs an RMA.
Quote:
Originally Posted by TK421 View Post

Is there any preproduction G502?

What is the difference with retail G502?
Yes, we make some prototypes pre-production of every product for test purposes. These are given to employees and select external testers. There are none ever shipped to retail stores in retail packaging.

With Proteus Core specifically, some older versions of the pre-mass-production bootloader are not compatible with the LGS version of the firmware updater. This only affects people who received a Proteus Core prototype from Logitech before March 2014. It does not affect any retail product. Something different is happening in this case.
post #12 of 17
The exact same thing happened to me.

I had to plug in a second mouse to access the firmware updater (located in program files) and launch it manually as administrator.

Apparently it has something to do with virus software or a firewall blocking the update.

The fact that your mouse is still blinking (same thing mine did) makes me think it's just stuck in the update mode (won't be useable until the update completes).


Edit: I should also mention, it seems Logitech has some safety mechanisms in place to prevent you from bricking the mouse. After the firmware update appeared to freeze on me, I tried unplugging the mouse and restarting the computer. This didn't cause any permanent damage (upon plugging the mouse back in, it returned to the same "blinking light and unresponsive cursor" it was in during the firmware update). It appears that the mouse freezes itself in this "firmware update state" until the firmware update is successfully applied to prevent any permanent damage.
Edited by ShoehornHands - 8/6/14 at 8:33am
post #13 of 17
Thread Starter 
Could I try to run the firmware update in Safe Mode?
post #14 of 17
My G502 also did not work on first firmware update attempt while doing exactly as the instructions said. The light just blinked on and off forever. I think I had to unplug the mouse then plug it back in a second time. I don't remember exactly how I solved it.
post #15 of 17
Thread Starter 
I just ran the firmware application seperately again, but this time I clicked "Run as Administrator". It updated the firmware and now the mouse is working like a charm.
post #16 of 17
Good to know. I will add that to the list of things to have our Support people look at, and ask the engineering team if there's a way to make that not require user intervention.
post #17 of 17
thx dude must help
thumb.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Logitech G502 Firmware Update Fail (Fixed)