Overclock.net › Forums › Graphics Cards › NVIDIA › Gtx 970 x2 SLI - Not working?
New Posts  All Forums:Forum Nav:

Gtx 970 x2 SLI - Not working?

post #1 of 4
Thread Starter 
I recently purchased 2 Gigabyte Gaming G1 GTX 970s and installed them using the 3-way SLI bridge supplied with my motherboard (X99 deluxe). It's the flexible one if that matters.

I seem to be having an issue with SLI performance even after setting the 'Prefer Maximum Performance' in NVIDIA 3D settings. The cards are not being fully utilized. They sit around 1176 mhz even when gaming in an intense game like Arma 3, they should be boosting to up around 1329 mhz.

Just to test, I disabled SLI, and I am getting the same frame rate in Arma 3 that I was getting with it enabled, which is around 55 FPS. I should be getting much higher than this considering I'm running at 1080p on Ultra settings.

I am a bit confused and am not sure what is going on here, but it looks like SLI just isn't working or my cards aren't being fully utilized. Does anyone have any ideas as to what is going on? I'm lost.

ALSO: I'm on the latest Nvidia drivers 344.16, and am in the 'Maximize 3D performance' SLI mode.
Edited by Chip Pippins - 10/21/14 at 1:31am
post #2 of 4
I've never played ARMA 3, but from what I understand it's a very CPU heavy game. That could explain what you are seeing. Do you have any GPU heavy titles - say Metro 2033, Tomb Raider, Far Cry 3 to name a few? Any of those will give the SLI setup a good workout. thumb.gif
Hasmax
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 8700K Asus Maximus X Hero Asus Strix GTX1080 G.Skill Ripjaws V DDR4-2666 32GB 
Hard DriveHard DriveHard DriveCooling
Samsung 960 EVO 500GB Samsung 850 EVO 500GB Western Digital Black 4TB Noctua NH-U14S 
CoolingOSMonitorKeyboard
4x Noctua NF-A14 Windows 10 64-bit Dell Ultrasharp U2515H WASD V2 87-key (MX Clear, PBT, O-Rings) 
PowerCaseMouseMouse Pad
EVGA 750G3 CM MasterCase 5 Pro Logitech G703 Steelseries QcK+ Limited 
AudioAudioAudioAudio
FiiO E10K Mackie CR3 Sennheiser HD598 Blue Snowball (Black) 
Other
Logitech Brio 4K 
  hide details  
Reply
Hasmax
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 8700K Asus Maximus X Hero Asus Strix GTX1080 G.Skill Ripjaws V DDR4-2666 32GB 
Hard DriveHard DriveHard DriveCooling
Samsung 960 EVO 500GB Samsung 850 EVO 500GB Western Digital Black 4TB Noctua NH-U14S 
CoolingOSMonitorKeyboard
4x Noctua NF-A14 Windows 10 64-bit Dell Ultrasharp U2515H WASD V2 87-key (MX Clear, PBT, O-Rings) 
PowerCaseMouseMouse Pad
EVGA 750G3 CM MasterCase 5 Pro Logitech G703 Steelseries QcK+ Limited 
AudioAudioAudioAudio
FiiO E10K Mackie CR3 Sennheiser HD598 Blue Snowball (Black) 
Other
Logitech Brio 4K 
  hide details  
Reply
post #3 of 4
Thread Starter 
Quote:
Originally Posted by francisw19 View Post

I've never played ARMA 3, but from what I understand it's a very CPU heavy game. That could explain what you are seeing. Do you have any GPU heavy titles - say Metro 2033, Tomb Raider, Far Cry 3 to name a few? Any of those will give the SLI setup a good workout. thumb.gif

You are right I fired up Metro 2033 Vanilla. GPU utilization was at 95-99% both GPUs were being used was fantastic. I guess ARMA 3 just doesn't use gpus to their full capacity.
post #4 of 4
Quote:
Originally Posted by Chip Pippins View Post

You are right I fired up Metro 2033 Vanilla. GPU utilization was at 95-99% both GPUs were being used was fantastic. I guess ARMA 3 just doesn't use gpus to their full capacity.

Yeah it looks like that's the case. Nice to see Metro make good use of your cards...enjoy the 970's! thumb.gif
Hasmax
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 8700K Asus Maximus X Hero Asus Strix GTX1080 G.Skill Ripjaws V DDR4-2666 32GB 
Hard DriveHard DriveHard DriveCooling
Samsung 960 EVO 500GB Samsung 850 EVO 500GB Western Digital Black 4TB Noctua NH-U14S 
CoolingOSMonitorKeyboard
4x Noctua NF-A14 Windows 10 64-bit Dell Ultrasharp U2515H WASD V2 87-key (MX Clear, PBT, O-Rings) 
PowerCaseMouseMouse Pad
EVGA 750G3 CM MasterCase 5 Pro Logitech G703 Steelseries QcK+ Limited 
AudioAudioAudioAudio
FiiO E10K Mackie CR3 Sennheiser HD598 Blue Snowball (Black) 
Other
Logitech Brio 4K 
  hide details  
Reply
Hasmax
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 8700K Asus Maximus X Hero Asus Strix GTX1080 G.Skill Ripjaws V DDR4-2666 32GB 
Hard DriveHard DriveHard DriveCooling
Samsung 960 EVO 500GB Samsung 850 EVO 500GB Western Digital Black 4TB Noctua NH-U14S 
CoolingOSMonitorKeyboard
4x Noctua NF-A14 Windows 10 64-bit Dell Ultrasharp U2515H WASD V2 87-key (MX Clear, PBT, O-Rings) 
PowerCaseMouseMouse Pad
EVGA 750G3 CM MasterCase 5 Pro Logitech G703 Steelseries QcK+ Limited 
AudioAudioAudioAudio
FiiO E10K Mackie CR3 Sennheiser HD598 Blue Snowball (Black) 
Other
Logitech Brio 4K 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Gtx 970 x2 SLI - Not working?