Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › IconCache- Im going crazy
New Posts  All Forums:Forum Nav:

IconCache- Im going crazy

post #1 of 5
Thread Starter 
So I'm helping my buddy fix his computer after it wouldnt boot. I suspected a virus or some sorts that messed with everything. After taking a look in safe mode lo and behold optimizer pro, search bars, and the works. I noticed the icons were also missing. But I thought it was just safe mode + virus combo. Now everything is done and over with, and the icons are still missing!! mad.gif I ruled out missing programs since the shortcuts still work, I also ruled out missing icon art from the install folder since I installed new programs and those have missing icons too. Desktop,taskbar and desktop all generic white icons. I tried everything. I couldnt delete the iconcache.db because it didnt exist even with hidden folders + system files were toggled. The icon rebuild program over at sevenforum didnt work, and the deleting the iconhandler folder in regedit didnt either. I even went as far as to download the icon packager from stardock, and forced the pc into 16 bit color and brought it back to 32 bit. So I'm out of ideas short of a full format. He told me this happened a few days before the crash.
Warning: Spoiler! (Click to show)

tl;dr missing icons on desktop/startmenu/taskbar suggestions?
post #2 of 5
Thread Starter 
Anyone?
post #3 of 5
You need to delete the icon cache and rebuild it. Microsoft has an automated fix through that fix it deal. Ill see if I can find it.
Edit: Here is the manual method: http://support.microsoft.com/kb/2635447/en-us
Edited by xundeadgenesisx - 11/14/14 at 9:39pm
Xelf
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770k @ 4.0Ghz Asrock z87e-itx Sapphire Tri-X 290x GSkill Sniper 2x8GB 1866 
Hard DriveHard DriveCoolingOS
Samsung 840EVO 500GB HGST 1TB 7200 Noctua NH-D14 Arch Linux 
OSMonitorKeyboardPower
Debian 8 Qnix QX2710 Razer Black Widow Chroma Seasonic G series 650W 
CaseMouseMouse Pad
Node 304 Logitech G502 Roccat Taito mid-size 
  hide details  
Reply
Xelf
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770k @ 4.0Ghz Asrock z87e-itx Sapphire Tri-X 290x GSkill Sniper 2x8GB 1866 
Hard DriveHard DriveCoolingOS
Samsung 840EVO 500GB HGST 1TB 7200 Noctua NH-D14 Arch Linux 
OSMonitorKeyboardPower
Debian 8 Qnix QX2710 Razer Black Widow Chroma Seasonic G series 650W 
CaseMouseMouse Pad
Node 304 Logitech G502 Roccat Taito mid-size 
  hide details  
Reply
post #4 of 5
Thread Starter 
Yea tried. There is no IconCache.DB even with all things unhidden.
post #5 of 5
Have you tried going to a command prompt, and running SFC /SCANNOW ??

It could be corrupt/missing system files. Other option is the user profile is corrupted, in which case you'll have to create a new profile, then copy stuff across from the old one.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › IconCache- Im going crazy