Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 970 and weird glitches
New Posts  All Forums:Forum Nav:

GTX 970 and weird glitches

post #1 of 7
Thread Starter 
Hey guys,

I recently decided to overclock my Gigabyte GTX 970 Windforce and have been doing some gaming to test the OC. I first tried Crysis 3 and then Crysis 2. I've been noticing some weird bugs, but I'm not sure if they are from the OC or from the game. I'm starting to lean towards it being the games because I reset my GPU to the default clocks and it still happens. The glitches also appear in the same spots every time, which is not how artifacts usually appear. When OCing my GPU, I never touched the voltage or flashed the bios. I ended up with a final OC of 112% Power Limit (max up from 100), +190 Core and +500 Memory. All seems stable in Heaven 4.0 and Fire Strike with no crashing or artifacts. What are the chances I messed up my GPU some how?

The first issue I noticed is in Crysis 3 in the Welcome to the Jungle level, some of the foliage would flicker and become lighter or darker. Changing Object Detail from Very High to High fixed this for me.

Here's a video of the issue: http://youtu.be/lxal239_nUc

Another problem with Crysis 3 is also in the Welcome to the Jungle level, the grass in one spot near the gun you use to take down the tower flickers and has some black lines in it. This I have not been able to fix.

The final issue I'm having with Crysis 3 is kind of hard to notice, but every time Prophet has one of his visions where the screen goes a bit fuzzy and high tech graphics display on his visor there is a little bit of artifacts left behind which do not clear until after the level ends. I play on default brightness of 100 and it's pretty noticeable on that setting, especially if you use NanoVision in a dark area. After the level ends and the next one starts, the artifacts disappear until the next time a scene involving the visions occur.

In Crysis 2 I had a bunch of issues, some of which I have been able to solve.

Things I've been able to fix:

- Shadows on trees, fixed by setting Object Detail to Very High. For some reason Extreme and Ultra both have the issue.
- There's a puddle in the first level to the right of the stairs where the first vehicle drives up and 3 cell members get out, there's messed up textures around it, but setting Object Detail to Extreme or lower fixes it.
- There's a permanent shadow line following my character, setting Object Detail to Extreme fixes it.

The remaining issues I'm having are:

- Pop-in on the tree foliage, even when I'm close it happens.
- Shadow pop-in
- The reflection on car windows has flickering black textures when there are 2 windows aligned with each other. For example, if I shoot out all but 1 window of the car, the reflection is fine.

Specs:

Core i5 4670k @ 4.3 Ghz (1.2v)
CM Hyper212 EVO
8 (2x4) GB Kingston HyperBlu DDR3 1600 9-9-9-27 (XMP Profile)
Corsair CX600M
Gigabyte Windforce GTX 970 4 GB
MSI Z87-G41 PC-Mate

Thanks for the help!
Edited by -CJF- - 12/21/14 at 1:16am
post #2 of 7
Thread Starter 
I updated the post with a video and I will add videos of the other anomalies soon. It would be helpful if anyone could let me know if these are likely hardware problems or known driver/game glitches. Thank you!.
post #3 of 7
I'm pretty sure your seeing driver issues, The current driver(s) out for these new cards are not well optimized at all yet.

Also don't OC the card it already is very well OC'ed by default. In my opinion most of the GTX 970 problems are coming from OC'ing these cards past reference speeds with the current drivers its a mess.

For an example run Valley benchmark at default setting and fullscreen, Run the benchmark then once thats done let it still run but run the benchmark a second time it will always crash almost half way threw.
Edited by garikfox - 12/21/14 at 11:33am
Dreamland
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6800K ASRock X99 Taichi ASUS GTX 1060 Turbo 6GB 4x4GB G.SKILL DDR4-2400 
Hard DriveOptical DriveCoolingOS
Samsung SM961 128GB Pioneer BDR-208DBK Noctua NH-U9S Windows 10 Enterprise N 
MonitorKeyboardPowerCase
LG 32MP58 Razer Blackwidow Ultimate 2016 EVGA SuperNOVA 750 G2 Antec Three Hundred 
MouseAudio
Logitech G Pro Creative Gigaworks T40 Series II 
  hide details  
Reply
Dreamland
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6800K ASRock X99 Taichi ASUS GTX 1060 Turbo 6GB 4x4GB G.SKILL DDR4-2400 
Hard DriveOptical DriveCoolingOS
Samsung SM961 128GB Pioneer BDR-208DBK Noctua NH-U9S Windows 10 Enterprise N 
MonitorKeyboardPowerCase
LG 32MP58 Razer Blackwidow Ultimate 2016 EVGA SuperNOVA 750 G2 Antec Three Hundred 
MouseAudio
Logitech G Pro Creative Gigaworks T40 Series II 
  hide details  
Reply
post #4 of 7
Thread Starter 
I don't think my GTX 970 is overclocked much by default. I have the Windforce not the G1. The same glitches also happen if I reset the OC and run stock speeds so the only way the OC is the problem is if I somehow damaged my card with my mild overclock. As far as I can tell I did everything as safe as possible, raising core speeds by 10 MHz and stress testing with Heaven 4.0 in between. When it came time to OC memory I raised speeds by 25-50 MHz per test. I never raised the voltage and temps never exceeded 65c under load. Drivers sound like the problem but should be easy to confirm (are any other 970 owners having the same problem?)
post #5 of 7
Thread Starter 
Here's another video of a pop-in problem I am constantly having: http://youtu.be/pmIgwXaoMP4

In this case, the game is Crysis. You can clearly see around 40 seconds massive pop-in on the fence. I am not sure if it's supposed to be like this or not, or if this is a problem that could be caused by an overclock or just poor drivers. Is anybody else with the 970 experiencing this issue?

EDIT: I think my problem with the pop-in is the LOD setting in various games and probably not hardware or driver related. I have this issue with a LOT of games but I have just managed to resolve it in the first Crysis by using the console commands "con_restricted=0" and then e_lods=0, pop in is gone.
Edited by -CJF- - 12/24/14 at 5:53am
post #6 of 7
post #7 of 7
My windforce gigabyte is the same problem.https://youtu.be/CkQFOqTfIiE
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 970 and weird glitches