Overclock.net › Forums › Software, Programming and Coding › Coding and Programming › Web Coding › Dreaded Error 403 on XAMPP/WAMP from non localhost. Tried all the google fixes, no luck
New Posts  All Forums:Forum Nav:

Dreaded Error 403 on XAMPP/WAMP from non localhost. Tried all the google fixes, no luck - Page 2

post #11 of 19
wrong error log, we need the HTTPD logs smile.gif

the problem is in this part




Allow from all
Require all granted
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var



not sure why though, try hashing it out "cleanly" restarting and try again?

(nix is so much easier for web haha biggrin.gif)
Escobar
(9 items)
 
Supercomputer ^_^
(13 items)
 
 
CPUMotherboardGraphicsRAM
1055T M4A88T-D EVO USB3 ATI 6850 4 GB 
Optical DriveOSMonitorKeyboard
DVD RW Windows 8 Pro lp1900 + 2 X 15 inch dell Microsoft Comfort Curve 
PowerCase
600watt thermaltake antec 200 
  hide details  
Reply
Escobar
(9 items)
 
Supercomputer ^_^
(13 items)
 
 
CPUMotherboardGraphicsRAM
1055T M4A88T-D EVO USB3 ATI 6850 4 GB 
Optical DriveOSMonitorKeyboard
DVD RW Windows 8 Pro lp1900 + 2 X 15 inch dell Microsoft Comfort Curve 
PowerCase
600watt thermaltake antec 200 
  hide details  
Reply
post #12 of 19
Quote:
Originally Posted by Ulquiorra View Post

wrong error log, we need the HTTPD logs smile.gif

the problem is in this part




Allow from all
Require all granted
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var



not sure why though, try hashing it out "cleanly" restarting and try again?
No, that bit is correct. It's what stops anyone from accessing server-status et al (not so much an issue on a dev machine, but still worth keeping as is)

The problem is that there's no default host set up: (please change applicable)
Code:
NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot "C:/xampp/htdocs/dummy-host.example.com"
    ServerName dummy-host.example.com
    ServerAlias www.dummy-host.example.com
    ErrorLog "logs/dummy-host.example.com-error.log"
    CustomLog "logs/dummy-host.example.com-access.log" common
</VirtualHost>

To be honest, that whole config file looks a mess. If that's the defaults XAMPP uses then there's good reason they explicitly advice people against using XAMPP for non-dev systems.
post #13 of 19
hmm i was just pattern matching ^,^, i always assume theres a default in the "www" somewhere
Escobar
(9 items)
 
Supercomputer ^_^
(13 items)
 
 
CPUMotherboardGraphicsRAM
1055T M4A88T-D EVO USB3 ATI 6850 4 GB 
Optical DriveOSMonitorKeyboard
DVD RW Windows 8 Pro lp1900 + 2 X 15 inch dell Microsoft Comfort Curve 
PowerCase
600watt thermaltake antec 200 
  hide details  
Reply
Escobar
(9 items)
 
Supercomputer ^_^
(13 items)
 
 
CPUMotherboardGraphicsRAM
1055T M4A88T-D EVO USB3 ATI 6850 4 GB 
Optical DriveOSMonitorKeyboard
DVD RW Windows 8 Pro lp1900 + 2 X 15 inch dell Microsoft Comfort Curve 
PowerCase
600watt thermaltake antec 200 
  hide details  
Reply
post #14 of 19
Quote:
Originally Posted by Ulquiorra View Post

hmm i was just pattern matching ^,^, i always assume theres a default in the "www" somewhere

There usually is, but I can't see it on this occasion.
post #15 of 19
Thread Starter 
Quote:
Originally Posted by Plan9 View Post

No, that bit is correct. It's what stops anyone from accessing server-status et al (not so much an issue on a dev machine, but still worth keeping as is)

The problem is that there's no default host set up: (please change applicable)
Code:
NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot "C:/xampp/htdocs/dummy-host.example.com"
    ServerName dummy-host.example.com
    ServerAlias www.dummy-host.example.com
    ErrorLog "logs/dummy-host.example.com-error.log"
    CustomLog "logs/dummy-host.example.com-access.log" common
</VirtualHost>

To be honest, that whole config file looks a mess. If that's the defaults XAMPP uses then there's good reason they explicitly advice people against using XAMPP for non-dev systems.

Ok, ill try this when I get home. That being said, this is just for home dev stuff. I also tried WAMP but had the same issues.
Dagobah
(11 items)
 
Coruscant
(8 items)
 
Endor (retired)
(14 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 7700k Asus Strix Z270F Gaming EVGA GTX 1070 SC 16GB G.Skill Trident Z DDR4-3200 
Hard DriveCoolingOSKeyboard
500GB Samsung 960 Evo M.2 Cryorig H5 Universal Windows 10 x64 Microsoft Sidewinder X4 
PowerCaseMouse
EVGA SuperNOVA G3 650w Phanteks Enthoo Evolv ATX  Mionix Avior 7000 
  hide details  
Reply
Dagobah
(11 items)
 
Coruscant
(8 items)
 
Endor (retired)
(14 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 7700k Asus Strix Z270F Gaming EVGA GTX 1070 SC 16GB G.Skill Trident Z DDR4-3200 
Hard DriveCoolingOSKeyboard
500GB Samsung 960 Evo M.2 Cryorig H5 Universal Windows 10 x64 Microsoft Sidewinder X4 
PowerCaseMouse
EVGA SuperNOVA G3 650w Phanteks Enthoo Evolv ATX  Mionix Avior 7000 
  hide details  
Reply
post #16 of 19
Quote:
Originally Posted by clawlan View Post

Ok, ill try this when I get home. That being said, this is just for home dev stuff. I also tried WAMP but had the same issues.

In that case, if all else fails, you could just comment out all of the location match stuff below:
Code:
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
        Allow from all
   Require all granted
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>
post #17 of 19
Thread Starter 
Quote:
Originally Posted by Plan9 View Post

In that case, if all else fails, you could just comment out all of the location match stuff below:
Code:
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
        Allow from all
   Require all granted
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>

Commenting this out did not make a difference. Still getting 403 error.
Dagobah
(11 items)
 
Coruscant
(8 items)
 
Endor (retired)
(14 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 7700k Asus Strix Z270F Gaming EVGA GTX 1070 SC 16GB G.Skill Trident Z DDR4-3200 
Hard DriveCoolingOSKeyboard
500GB Samsung 960 Evo M.2 Cryorig H5 Universal Windows 10 x64 Microsoft Sidewinder X4 
PowerCaseMouse
EVGA SuperNOVA G3 650w Phanteks Enthoo Evolv ATX  Mionix Avior 7000 
  hide details  
Reply
Dagobah
(11 items)
 
Coruscant
(8 items)
 
Endor (retired)
(14 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 7700k Asus Strix Z270F Gaming EVGA GTX 1070 SC 16GB G.Skill Trident Z DDR4-3200 
Hard DriveCoolingOSKeyboard
500GB Samsung 960 Evo M.2 Cryorig H5 Universal Windows 10 x64 Microsoft Sidewinder X4 
PowerCaseMouse
EVGA SuperNOVA G3 650w Phanteks Enthoo Evolv ATX  Mionix Avior 7000 
  hide details  
Reply
post #18 of 19
Thread Starter 
OK, finally figured it out by enabling the debug info in the settings:
Code:
8:43:28 PM  [Apache]         Problem detected!
8:43:28 PM  [Apache]    Port 443 in use by "C:\Python27\python.exe" with PID 5104!
8:43:28 PM  [Apache]    Apache WILL NOT start without the configured ports free!
8:43:28 PM  [Apache]    You need to uninstall/disable/reconfigure the blocking application
8:43:28 PM  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port

I am running another program (PlexConnect) in python that is using port 443. I'm not sure how to change this port though.
Edited by clawlan - 1/12/15 at 5:55pm
Dagobah
(11 items)
 
Coruscant
(8 items)
 
Endor (retired)
(14 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 7700k Asus Strix Z270F Gaming EVGA GTX 1070 SC 16GB G.Skill Trident Z DDR4-3200 
Hard DriveCoolingOSKeyboard
500GB Samsung 960 Evo M.2 Cryorig H5 Universal Windows 10 x64 Microsoft Sidewinder X4 
PowerCaseMouse
EVGA SuperNOVA G3 650w Phanteks Enthoo Evolv ATX  Mionix Avior 7000 
  hide details  
Reply
Dagobah
(11 items)
 
Coruscant
(8 items)
 
Endor (retired)
(14 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 7700k Asus Strix Z270F Gaming EVGA GTX 1070 SC 16GB G.Skill Trident Z DDR4-3200 
Hard DriveCoolingOSKeyboard
500GB Samsung 960 Evo M.2 Cryorig H5 Universal Windows 10 x64 Microsoft Sidewinder X4 
PowerCaseMouse
EVGA SuperNOVA G3 650w Phanteks Enthoo Evolv ATX  Mionix Avior 7000 
  hide details  
Reply
post #19 of 19
Just disable 443 in XAMPP. I'm surprised the service even started though.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Web Coding
Overclock.net › Forums › Software, Programming and Coding › Coding and Programming › Web Coding › Dreaded Error 403 on XAMPP/WAMP from non localhost. Tried all the google fixes, no luck