Overclock.net › Forums › Components › Monitors and Displays › New ROG Swift monitor-locked at 85 Hz despite 3rd display port 1.2 cable
New Posts  All Forums:Forum Nav:

New ROG Swift monitor-locked at 85 Hz despite 3rd display port 1.2 cable

post #1 of 2
Thread Starter 
Hello to OC community. I'm reaching out for some assistance/guidance regarding my new monitor. I've searched multiple forums for an answer for this specific problem, but have not found an answer yet.

I had saved up a while and purchased a new OriginPC:

System Cooling: ORIGIN FROSTBYTE 360 Sealed Liquid Cooling System for 2011 Socket
Processors: Intel Extreme Core i7 5960X Octa-Core 3.0GHz (3.5GHz TurboBoost)
Power Supply: 1.3 Kilowatt EVGA Supernova 1300 G2
Graphic Cards: Triple 4GB NVIDIA GTX 980
Memory: 16GB Corsair Dominator Platinum 2800Mhz (4x4GB)
Operating System: Genuine MS Windows 8.1 64-Bit Edition
Operating System Drive #1 (Primary): 120GB ORIGIN PC Approved Solid State Drive
Operating System Drive #2: None
Hot Swap Bay Drive #1: 480GB ORIGIN PC Approved Solid State Drive
Hot Swap Bay Drive #2: None
Hot Swap Bay Drive #3: None
Hot Swap Bay Drive #4: None
Hot Swap Bay Drive #5: None
Optical Drive One: 12X Blu-ray Reader and DVD Combo
Hard Drive Cage: 5 Bay Hot-Swap Cage
Playback Software: CyberLink PowerDVD 14 Ultra
Audio: On Board High Definition 8-Channel Audio
Networking: Onboard Network Port

I bought the monitor from B&H Photo in November. Long story short, had to send back first OriginPC I purchased in November secondary to a CPU failure. I only used the monitor for a couple of hours before computer died. Didn't even have time to see whether or not monitor was working properly. I just received the replacement computer and started using it a couple days ago.

Downloaded ASUS monitor driver-multipanel driver-only one I could find on web site, but I'm not running multi-monitor setup. I didn't see any specific montiro driver on the ASUS product support site. I did notice when I went to computer devices-monitor, windows identifies the monitor as a generic monitor, not specifically ROG Swift.

For some reason, when I go into Nvidia control panel-screen resolution, the selectable screen refresh rate choices are 30, 60, and 85 Hz. There is no option to even choose 100, 125, or 144 Hz. After reading forums, I bought a new display port cable: Cable Matters Gold Plated DisplayPort to DisplayPort Cable 6 Feet - 4K Resolution Ready. Still same problem. Bought Monoprice 6-Feet Premium DisplayPort 1.2 Male to Male Cable - Black (110582), still same problem.

I have used the GeForce Nvidia experience and have the most up to date GPU driver recommended.

I'd appreciate any suggestions/help. On the bright side, there aren't any dead pixels on the screen.

Thanks,

KC
post #2 of 2
You could try DDU and reinstall the drivers properly.
http://www.wagnardmobile.com/DDU/

You can also swap the graphic cards and try another display port.

You can also try use Acronis and make a disc image of your c: drive and reformat your computer with a fresh install with just the nvidia drivers and see if you can get 120hz.
If it doesn't, you know it's the monitor and revert back to your disc image.
The whole process takes about 15-20 minutes.
pr1me
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4790K Asus Maximus VII Formula 2x GTX Titan Superclocked 16 GB Corsair 
Hard DriveCoolingOSMonitor
Samsung 850 Pro Corsair H110i GT Windows 10 x64 Asus RoG Swift PG278Q 
KeyboardPowerCaseMouse
CM Storm Novatouch Seasonic Platinum 1200 Corsair Obsidian 450D Roccat Nyth 
Mouse PadAudioOther
Zowie G-TF Speed Sound Blaster X7 Native Instrument Kontrol F1 
  hide details  
Reply
pr1me
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 4790K Asus Maximus VII Formula 2x GTX Titan Superclocked 16 GB Corsair 
Hard DriveCoolingOSMonitor
Samsung 850 Pro Corsair H110i GT Windows 10 x64 Asus RoG Swift PG278Q 
KeyboardPowerCaseMouse
CM Storm Novatouch Seasonic Platinum 1200 Corsair Obsidian 450D Roccat Nyth 
Mouse PadAudioOther
Zowie G-TF Speed Sound Blaster X7 Native Instrument Kontrol F1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › New ROG Swift monitor-locked at 85 Hz despite 3rd display port 1.2 cable