post #1 of 1
Thread Starter 
The mouse has worked for years and has worked with no issues since I installed 8.1 afew weeks ago. What is happening right now is in windows the light does not come on showing the optical drive is working.

In troubleshooting I can go into BIOS, it works fine there, load into windows no love. When I navigate into Device Manager and look under Mouse and other pointing devices I see an HID compliant mouse. I scroll down to other devices and I see Logitech USB Optical Mouse with a yellow exclamation next to it.

I have tried to update the Logitech Optical driver, Windows cannot find the file. I have also tried uninstalling both the HD compliant Mice driver and the Logitech Optical USB driver. Then restart the PC and then plugged the mouse in and still the same thing. The port works with a flash drive, and this is happening no matter what usb port I plug the mouse into.
I want to add this, when I was first installing my ATI GPU drivers this happened, I did a system restore and it resolved the issue. I have not tried yet to reinstall the GPU drivers as I have been wanting to get to the bottom of the issue. This is the second time this has happened, and very confident a restore will resolve the issue but I would like to get to the root cause.

Ok so I brought over my Logitech G500 and the install software. It booted up with the mouse in the USB port, nothing happened. I checked my driver and saw the G500 icon with the yellow exclamation next to it. I pulled my driver install, ran that. Once it finished and loaded into the logitech app gui it told me no device detected. I checked my device manager and the icon is still there with the yellow exclamation next to it. I rebooted into EFIU and again the mouse works great.

Any thoughts here?

Cheers!