Overclock.net › Forums › Intel › Intel Motherboards › help please, no post scrscreen
New Posts  All Forums:Forum Nav:

help please, no post scrscreen

post #1 of 6
Thread Starter 
Hi I have an asus P8H61-I R2.0, I turned off the pc because I was marking out where to put a fan in for a mod. Now here's the problem I turned it all back on and I have nothing not even a post screen to get to the bios, I have tried on 2 different monitor but nothing so if you have any ideas that would be brilliant.
Specs:
P8H61-I R2.0 asus motherboard
asus geforce GTX650
Corsair CX750M power supply
post #2 of 6
You will loose any settings in your bios you may have made in the past, but unplug the unit, pull out the battery on the MOBO and let it sit for a few mins (10-15). also Reseat your graphics card (assuming its add-in). try that, I have had pulling the battery solve strange things like that before.

Also, ive seen some MOBO not post if the CPU fan isn't pluged in
post #3 of 6
Thread Starter 
Ok thanks, trying it now I'll update the news
post #4 of 6
Thread Starter 
I have now tried that with no luck, I also unplugged any bootable device but that didn't work either, I'm starting to think the board has died now
post #5 of 6
Thread Starter 
as an update, I have dismantled it and I had to reseat the ram twice before it decided to work, I have lost my bios settings but I can live with it
post #6 of 6
excellent. yea, the bios settings get whipped when removing the battery, I say to try that first because sometimes for what ever reason (hard shutdown/power failure for example) a setting may change like the default graphics or something and cause what happened to you, glad to hear that re seating the ram fixed it... weired that there wasn't the traditional beep, beep from the mobo for ram.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › help please, no post scrscreen