Overclock.net › Forums › Intel › Intel CPUs › 5960X dead =(
New Posts  All Forums:Forum Nav:

5960X dead =( - Page 27

post #261 of 282
Quote:
Originally Posted by saintruski View Post

if they aren't even a month old id try RMAing the motherboard through wherever you bought it based on their policies. Do not bother with ASUS RMA/Customer support if you have another option, it is an absolute nightmare.

Quote:
Originally Posted by huzzug View Post

I'm not sure how returns are handled in your land, but over here the retailer has to provide for returns services for 1 year standard on all qualified devices. As suggested above, going to Asus would be breaking your head against the wall expecting the wall to yield, but all you're gonna get is paint flakes. Also, if you get a chance, swap out the Asus board for a better one like the MSI or Gigabyte or AsRock. Asus have better products on paper but in real world, they're just giving you Turds polished to the top.

So true man... I was blinded by the RGBness, I'm ashamed to say. I know I definitely won't be buying an Asus motherboard again that's for sure.

I called Scan (the retailer I bought my parts from) and I spoke to a representative who then emailed me a list of tests to do. I then sent screenshots of said email to my friend who's much more experienced with PC's than I am and he said they're pretty generic and that he's almost certain my CPU is toast.
post #262 of 282
Scan is rubbish with rmas
Turcoman Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i9 7920x Rampage VI  GTX 1080 Corsair 3000 c15 32gb 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Blue Seagate Barracuda 7200.14 Samsung 830 128 Sony Blu Ray 
CoolingOSMonitorKeyboard
Corsair h110 8+7+XP BenQ Xl2420T razer blackwidow ultimate stealth 2013 
PowerCaseMouseMouse Pad
Corsair AX1200W Corsair 900D Razer Mamba elite 2012 steelseries QcK+ heavy 
AudioOther
2.1 Speakers Nvidia 3D Vision 2 Kit 
  hide details  
Reply
Turcoman Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i9 7920x Rampage VI  GTX 1080 Corsair 3000 c15 32gb 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Blue Seagate Barracuda 7200.14 Samsung 830 128 Sony Blu Ray 
CoolingOSMonitorKeyboard
Corsair h110 8+7+XP BenQ Xl2420T razer blackwidow ultimate stealth 2013 
PowerCaseMouseMouse Pad
Corsair AX1200W Corsair 900D Razer Mamba elite 2012 steelseries QcK+ heavy 
AudioOther
2.1 Speakers Nvidia 3D Vision 2 Kit 
  hide details  
Reply
post #263 of 282
Quote:
Originally Posted by MerkageTurk View Post

Scan is rubbish with rmas

Well that fills me with hope. Thanks man haha
post #264 of 282
Haha it's true though hopefully they will sort your one out with no problems.
Turcoman Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i9 7920x Rampage VI  GTX 1080 Corsair 3000 c15 32gb 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Blue Seagate Barracuda 7200.14 Samsung 830 128 Sony Blu Ray 
CoolingOSMonitorKeyboard
Corsair h110 8+7+XP BenQ Xl2420T razer blackwidow ultimate stealth 2013 
PowerCaseMouseMouse Pad
Corsair AX1200W Corsair 900D Razer Mamba elite 2012 steelseries QcK+ heavy 
AudioOther
2.1 Speakers Nvidia 3D Vision 2 Kit 
  hide details  
Reply
Turcoman Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i9 7920x Rampage VI  GTX 1080 Corsair 3000 c15 32gb 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Blue Seagate Barracuda 7200.14 Samsung 830 128 Sony Blu Ray 
CoolingOSMonitorKeyboard
Corsair h110 8+7+XP BenQ Xl2420T razer blackwidow ultimate stealth 2013 
PowerCaseMouseMouse Pad
Corsair AX1200W Corsair 900D Razer Mamba elite 2012 steelseries QcK+ heavy 
AudioOther
2.1 Speakers Nvidia 3D Vision 2 Kit 
  hide details  
Reply
post #265 of 282
Quote:
Originally Posted by MerkageTurk View Post

Haha it's true though hopefully they will sort your one out with no problems.

They better... Otherwise if I have to buy a new cpu and motherboard I'm going to a different retailer and I'm 100% not buying another Asus X99 motherboard.
post #266 of 282
got some replacement 5960x's. tested one on the rampage v edition 10, clocks 4.6GHz @1.25v on the rampage v edition 10 and hasn't killed it yet.
post #267 of 282
Asus Strix x99 board here that died a couple of days ago which I too purchased from Scan computers. It just powered itself off mid game and wouldn't power back on. When I tried to turn it back on it kept power recycling every couple of seconds. frown.gif

I've taken everything out apart from CPU and this is now stays powered on but is showing the 00 QCode and doesn't post.

I've got a new board (same model) delivered today so I'm hoping the CPU hasn't been fried!

I'm at work at the moment but will update tonight on if CPU and/or Motherboard are dead. It's a 6850K processor which cost me a fair bob so would be gutted if it's dead. If the CPU is dead I'll be sending back the motherboards and getting a different brand I think.
post #268 of 282
Quote:
Originally Posted by ClericJK View Post

Asus Strix x99 board here that died a couple of days ago which I too purchased from Scan computers. It just powered itself off mid game and wouldn't power back on. When I tried to turn it back on it kept power recycling every couple of seconds. frown.gif

I've taken everything out apart from CPU and this is now stays powered on but is showing the 00 QCode and doesn't post.

I've got a new board (same model) delivered today so I'm hoping the CPU hasn't been fried!

I'm at work at the moment but will update tonight on if CPU and/or Motherboard are dead. It's a 6850K processor which cost me a fair bob so would be gutted if it's dead. If the CPU is dead I'll be sending back the motherboards and getting a different brand I think.

Hey, man. I sent my motherboard and cpu back to Scan yesterday so I'll see what happens with that and keep you guys updated.

It's interesting to hear of other people with similar issues when using the X99 Strix. I'm curious as to what seems to be causing these problems. Is it a bios problem? A hardware problem?

I'll refer you to this video I came across earlier today. Another person having an issue with their X99 Strix -


I76800k asus strix x99 gaming dead?: http://youtu.be/kBBgB25b4qk
post #269 of 282
CPU confirmed dead. frown.gif

I put it in new Asus Strix x99 I got today and it does the same thing, power comes on CPU fans spin board lights up and qcode displays 00. If I leave it on it eventually goes into a reset cycle. Have tried with a different PSU too just to rule that out.

For a little history, when I did the build it was fine, had realtemp, hwmonitor and gpuz to check all temps were fine. I bought on release day in UK and it worked perfectly until about a month ago when I got home and computer was off. It turned on and booted fine and didn't think anything more of it putting it down to windows update or power cut.

Then, about two weeks ago it shut off mid game and wouldn't come back on. I opened it up and switched to spare PSU thinking the PSU could be duff. The other PSU did the same. I put the original PSU back in and tried again and it booted fine. Confused I presumed it was a faulty connection. Then on Sunday it powered off again and wouldn't come on, only this time it hasn't come back to life.

I have ordered new CPU for delivery tomorrow as I can't be bothered waiting around for weeks with no machine. If I can't get a refund from scan the the replacements will make a nice upgrade from the wife's i3.

Just hoping new board doesn't explode CPU again. At this point I don't know if to risk it (for science) or send the strix x99 back and get a different brand board.

Edit: I didn't do any overclocking on anything.
Edited by ClericJK - 9/30/16 at 12:36pm
post #270 of 282
Quote:
Originally Posted by ClericJK View Post

CPU confirmed dead. frown.gif

I put it in new Asus Strix x99 I got today and it does the same thing, power comes on CPU fans spin board lights up and qcode displays 00. If I leave it on it eventually goes into a reset cycle. Have tried with a different PSU too just to rule that out.

For a little history, when I did the build it was fine, had realtemp, hwmonitor and gpuz to check all temps were fine. I bought on release day in UK and it worked perfectly until about a month ago when I got home and computer was off. It turned on and booted fine and didn't think anything more of it putting it down to windows update or power cut.

Then, about two weeks ago it shut off mid game and wouldn't come back on. I opened it up and switched to spare PSU thinking the PSU could be duff. The other PSU did the same. I put the original PSU back in and tried again and it booted fine. Confused I presumed it was a faulty connection. Then on Sunday it powered off again and wouldn't come on, only this time it hasn't come back to life.

I have ordered new CPU for delivery tomorrow as I can't be bothered waiting around for weeks with no machine. If I can't get a refund from scan the the replacements will make a nice upgrade from the wife's i3.

Just hoping new board doesn't explode CPU again. At this point I don't know if to risk it (for science) or send the strix x99 back and get a different brand board.

Hmm, it seems like the strix mobo is having a lot of issues. In my case the only thing that visibly worked were the component led's. No fans or anything else. I'm hoping scan can either figure out what went wrong or send me replacements. But even if that happens I'm concerned something similar will happen... I feel like having the strix x99 will just make me feel as though I'm waiting for something to go wrong.

It's true what people say, it really does leave a sour taste in your mouth. I know most people probably have great experiences but this has really put me off Asus motherboards.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › 5960X dead =(