Overclock.net › Forums › Graphics Cards › AMD/ATI › Hawaii Bios Editing ( 290 / 290X / 295X2 / 390 / 390X )
New Posts  All Forums:Forum Nav:

Hawaii Bios Editing ( 290 / 290X / 295X2 / 390 / 390X ) - Page 182

post #1811 of 3689
Quote:
Originally Posted by gupsterg View Post


I had a question about your "blackscreen" situation, you stated increased voltage is causing corruption of output signal are you upping GPU/RAM clocks in that test scenario?

I know I haven't increased voltage on the Tri-X 290 yet, well not by much. I just removed the offset in IR3567B which was reducing VDDC & VDDCI by -6.25mV and now 1100/1450 or 1100/1475 or 1110/1460 is not "blackscreening" like on stock ROM.

Here's another screenie of having run 1hr Heavensward benchmark looped.
Warning: Spoiler! (Click to show)

Marked in red on the i2cdump txt is the various offsets (currently we know about) 00 'd , what values do you have in your i2cdump?

Blackscreen or blackout? if you are talking about the out of sync situation (the card does not hang up, it simply stops displaying an image to the screen = blackout). then:

- gpu 1000mhz Mem 1250mhz @ 200mv = loses sync every two or three seconds
- gpu 1200mhz Mem 1250mhz @ 200mv = loses sync much faster.

After a certain gpu speed, the mhz do affect the speed that the blackouts occur. So 1200 @ 200mv have more blackouts than 1000 @ 200mv


How do I reproduce an ic2dump?
post #1812 of 3689
Quote:
Originally Posted by gungstar View Post

can you point me to that topic?

sure, here: http://www.overclock.net/t/1564219/r9-390x-bios-for-r9-290-290x-now-with-stock-and-modded-voltage-tables/0_50
post #1813 of 3689
Thread Starter 
Quote:
Originally Posted by spyshagg View Post

Blackscreen or blackout? if you are talking about the out of sync situation (the card does not hang up, it simply stops displaying an image to the screen = blackout).

I've experienced :-

a) "Blackscreen" where rendering is still going on but no display output, sometimes recovered by pressing "CTRL+ALT+DEL" to bring up task manager in my experience.

b) "Blackscreen" where rendering is not going on and no display output, not recoverable in my experience.

c) "Blackscreen" where it appears quick / full screen and goes away, like say a flicker.

Are we all in agreement these are the situations that can occur? and we can name them something which we'll clearly know which we are talking about when posting?
Quote:
Originally Posted by spyshagg View Post

loses sync every two or three seconds

Ahhh, this I'm relating to. Tell me if this is the same, Vapor-X 290X using stock ROM, set 1100/1525@+44mV using MSI AB. In 3dMark FS GT1 looped every so often (I didn't time it, but it repeated) I'd see a quick black flash on complete screen. ie no output but back again, I would say you could liken it to a flicker, very fast switch between display being outputted and not. Once I manually set VID, no more did I get it.

I'm not saying my solution is your fix, just getting my head around what's going on / being talked about smile.gif .
Quote:
Originally Posted by spyshagg View Post

How do I reproduce an ic2dump?
AiDA 64 i2cdump / SMBus (Click to show)

Will add this to OP smile.gif .
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
post #1814 of 3689
Quote:
Originally Posted by gupsterg View Post

I've experienced :-

a) "Blackscreen" where rendering is still going on but no display output, sometimes recovered by pressing "CTRL+ALT+DEL" to bring up task manager in my experience.

b) "Blackscreen" where rendering is not going on and no display output, not recoverable in my experience.

c) "Blackscreen" where it appears quick / full screen and goes away, like say a flicker.

Are we all in agreement these are the situations that can occur? and we can name them something which we'll clearly know which we are talking about when posting?
Ahhh, this I'm relating to. Tell me if this is the same, Vapor-X 290X using stock ROM, set 1100/1525@+44mV using MSI AB. In 3dMark FS GT1 looped every so often (I didn't time it, but it repeated) I'd see a quick black flash on complete screen. ie no output but back again, I would say you could liken it to a flicker, very fast switch between display being outputted and not. Once I manually set VID, no more did I get it.

I'm not saying my solution is your fix, just getting my head around what's going on / being talked about smile.gif . AiDA 64 i2cdump / SMBus (Click to show)

Will add this to OP smile.gif .

sure, around the forums they are named:

"a" is a blackout

"b" is a blackscreen

"c" is a blackout


Strange that you "solved" your blackouts by setting the vid directly on the bios (removing the offset also?). If it was this simple, then why does the 0.9v rail voltage mod exists?

I will mod my bios to test it. I dont even know if it has an offset or not lol


thanks for the link, will try to dump it once I get home if time allows
post #1815 of 3689
Thread Starter 
I and another member on Sapphire forum with same model card, having same black flicker when at 1100/1500 or 1525, fixed by manual VID. This was without -6.25mV VDDC/VDDCI offset removed at location 0x26 in i2cdump, we also had the VDDC only offset at location 0x8D in i2cdump, his +25mV mine +31.25mV.

Only recently I cracked the way IR3567B is programmed by VoltageObjectInfo, I had tried at the time of Guru3D thread but there was a) so much going on b) wasn't as experienced with rom,etc . We still don't know about all the registers and what values we can give for data to them.

I can not comment on when the 0.95V hard mod came out, but bios modding was not possible on Hawaii for a fair time, due to the digital signature enforcement in driver. The driver used to check the signature in rom to know if values are as manufacturer set. This is what I read when searching for info in early 2015.

It was only when the 390 bios was leaked on web and on Guru3D an exploration of bios started and bios modding came about (AFAIK). I then started this thread here as there were things we'd learned that I wanted in OP of a thread and not spread over the many pages.

Prior to me, ddsz and oneb1t exploring bios you only had PT1 & PT3 roms and Stilt's mining roms. If they existed I didn't find them when searching for info. Stilt's mining roms were no use to a non miner due to the disabled ROPs, to improve mining power efficiency. Stilt's MLU came about 9 days after we started looking at bios mods on Guru3D (3 days after this thread), there had been demand for alternative roms to stock ones for normal use prior to that.
Edited by gupsterg - 2/10/16 at 12:22pm
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
post #1816 of 3689
Hello everyone, ive been folowing the thread since a few weeks and im very impressed by all the research put into this, thanks !

I would now try to build a BIOS for 24/7 use with custom idle and load voltage/frequency and all those timing/MC mods, is the one in "R9 390X BIOS for R9 290/290X" thread the best one to start from ? (i have a 290 ref with hynix)

@gupsterg did you ever had the opportunity to play with "Radeon BIOS Editor" ? Damn that was a great tool for my HD6950 back in the day!
Im hope that Hawaii Bios Reader will grow that far smile.gif
post #1817 of 3689
Thread Starter 
Hi @eucalyptux,

I would create your own ROM TBH, firstly I'd use your stock factory ROM and modify that to get the most from card like I did. Secondly use a stock 390 ROM modded to get the max performance and whichever works best I'd use that as 24/7 usage ROM.

@Kizwan did a compare of 390 ROM with his own set of mods vs 290 ROM with same RAM strap timings and 390 Memory Controller timings. 1st and 2nd result in this Link:- 3dMark FS.

Today I was looking at the 290_HYNIX_MOD_V1.7.rom to do an edit for @Samuris and the table within the ROM which sets up voltage control chip (IR3567B) is not optimal IMO. It has hex values 26 00 65 00 in it, which makes it do this.

Besides the way that type of offset is setting up 2 voltages for increase, it's also not visible on say an OC app slider (ie MSI AB). It can be noticed by seeing how ROM is setting up per DPM voltage and noting if that is what you get as reading. ie lets say in DPM 0 is 0.993V if reading at idle is 1.031V you have an offset present.

There is a VDDC only offset which can be configured to that section of ROM, which will show on slider and a VDDCI (aka Aux Voltage) only offset. Thus user aware they already have a offset present quickly and easily. So when you add say +50mV in MSI AB to 290_HYNIX_MOD_V1.7.rom your technically at +87.5mV. VDDCI (Aux Voltage) with that ROM is already +31.25mV so when you add say +25mV your at +56.25mV.

I had no part in modding the ROMs in the R9 390X BIOS for R9 290/290X (Now with stock AND modded voltage tables!), AFAIK I am only mentioned due to info used out of the OP of this thread at the time of their creation (plus others input as highlighted in OP of that thread).

More info now is known about ROMs and looking at 290_HYNIX_MOD_V1.7.rom it isn't setup to be "optimal".
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
The Stilt Machine
(14 items)
 
XPS - i5 4690K
(12 items)
 
XPS - Q6600
(8 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Asus Crosshair VI Hero Sapphire Fury X@1145/545 G.Skill Trident Z 2x 8GB 3200MHz C14 
Hard DriveCoolingCoolingCooling
Samsung Evo 840 ThermalRight Archon IB-E X2 + 2x TY143 ThermalRight TY-143 2x front case intake Arctic Cooling F12 + 2x F9 as rear case exhaust 
OSMonitorKeyboardPower
Win 7 Pro x64 / Win 10 Pro x64 Asus MG279Q Cherry MX-Board 3.0 Cooler Master V850 
CaseMouse
SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
i5 4690K@4.9GHz 1.255V Asus Maximus VII Ranger Sapphire Fury X@1145/545 HyperX Savage 2x8GB 2400MHz C11 
Hard DriveCoolingOSMonitor
Samsung Evo 840 TR Archon SB-E X2 Win 7 Pro x64 / Win 10 x64 Asus MG279Q 
KeyboardPowerCaseMouse
Cherry MX-Board 3.0 Cooler Master V850 SilverStone TJ06 Logitech G700S 
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Asus P5K Premium Black Pearl Sapphire Toxic HD5850 Corsair Dominator 4GB 
Hard DriveCoolingOSPower
Crucial MX 100 256GB TR TRUE Rev.A Win 7 Pro x64 Cooler Master V650 
  hide details  
Reply
post #1818 of 3689
Well, this invisible offset make probably my card stable no ? cause she have a lot of bug without offset, or the offset is useless cause he is on Aux voltage and just up the temps of my card ? this rom give me the most performance atm, i try many room but no one have the performance of this rom on somes benchmark, i have less performance with more cadence with others roms.
post #1819 of 3689
i tryied with this rom, that was nice i had so low temps and i could have more cadence than with original bios and with 290_HYNIX_MOD_V1.7.rom roomlowtemp.zip 99k .zip file

and this is my actual room who gimme the most performance actualroom.zip 99k .zip file
post #1820 of 3689
Started modding the stock bios with some custom clocks and voltage.

Can't find the hex referring to my gpu/mem clock lol

according to Asus, its 1050/1350. But can't find neither that nor the standard 1000/1250 hex



what a great start! lol


edit: NEVER MIND! bad search option
Edited by spyshagg - 2/11/16 at 10:13am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Hawaii Bios Editing ( 290 / 290X / 295X2 / 390 / 390X )