Overclock.net › Forums › Graphics Cards › AMD/ATI › Modded R9 390X BIOS for R9 290/290X (Updated 02/16/2016)
New Posts  All Forums:Forum Nav:

Modded R9 390X BIOS for R9 290/290X (Updated 02/16/2016) - Page 185

post #1841 of 1845
meh
Edited by jeshuastarr - 4/17/17 at 9:31am
post #1842 of 1845
Hi. I have MSI gaming 290 4GB card (hynix) when i flash mod bioses all of them is for 8GB memory cards. Please tell me how to change this. Thanks
post #1843 of 1845
For those with a Sapphire R9 290 new edition (2015 version), this bios does not work and causes a black screen the moment the 390 drivers are installed. I have not found a way around this except to revert back to the stock or any other 290 bios. The Bios used is for the Samsung FS memory. I've tried this many months ago and again today thinking that maybe it was something the drivers but it's still happening. So those of you who may try the bios update on your Sapphire R9 290 new edition just be aware of this. Cheers.
post #1844 of 1845
Hi guys!

I'm having problems when trying to flash a custom bios on my XFX R9 290 card. I followed the instructions in the first post, created a bootable USB-drive, copied and renamed atiflash.exe and the custom bios on the drive. When I boot from the drive and try to run the command ATIFLASH.EXE -f -p 0 0_NEW.ROM, I get this message: This program cannot be run in dos mode.

What am I doing wrong? I did make sure to use the atiflash.exe, not the atiwinflash utility. When I download and unzip Atiflash 2.74 the folder contains atiflash, atiwinflash and many other files. Am I supposed to copy all or just some of these files to the flash drive?

Edit: I downloaded atiflash 4.17 and used that instead. It worked just fine and I was able to flash the modded bios on my card. 3DMark Time Spy graphics score improved by 120 points.
Edited by san1eri - 4/29/17 at 2:29am
post #1845 of 1845
hello i have 2 xfx r9 290 not unlockable and one asus matrix r9 290x on my system. In dx12, crossfire is enabled but time spy in 3d mark only uses the first card the asus one. If i test tomb raider with dx12 enabled only the first card works, but in dx11 all of them work, and in fire strike 3d mark again again all of them work. I think this is a problem with dx12 crossfire with different device ids in cards. I tryied to write bios from r9 290x to my 2 xfx cards, but ati flash changes device id from 67B1(290) TO 67B0(290X) but when i use gpu z in windows the device id is not changed it is still 67B1, SO NO LUCK WITH XFX cards, My second option is to try to change device id to the matrix card, can someone please if this a correct idea mod my bios from device id 67B0 to 67B1 so i can test the other option?
here is my bios
https://www.mediafire.com/?0vh6ucli8za7xgf
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Modded R9 390X BIOS for R9 290/290X (Updated 02/16/2016)