Overclock.net › Forums › Manufacturer Forums › EK Water Blocks › EK-Predator Club & Discussion Thread
New Posts  All Forums:Forum Nav:

EK-Predator Club & Discussion Thread - Page 143

post #1421 of 7088
my guess is the pump running at 100%
post #1422 of 7088
Post no longer relevant.
Edited by KickAssCop - 10/17/15 at 4:14am
post #1423 of 7088
Guys here is another video. Any help would be appreciated.

http://sendvid.com/nnwnv5ua

FYI POST. This is what happens when you set fan control to DC instead of PWM lol.
Edited by KickAssCop - 10/17/15 at 4:14am
post #1424 of 7088
Quote:
Originally Posted by RnRollie View Post

my guess is the pump running at 100%

How can I control the pump?
post #1425 of 7088
Quote:
Originally Posted by fixall View Post

So, I just put in an order for a 980Ti Poseidon... Any word on when the QDC will be available to purchase separately? Also... Any chance EK will be selling them through Amazon (Prime ftw), the $17 shipping for a tiny piece of plastic would be a bit hard to swallow.

Hi, let me answer that:
EK will sell QDC pre-filled GPU water blocks for majority of currently active models we have in our portfolio. There will be an option to order such variant of the water block on our shop. Our resellers will sell most popular variants I am sure, but not all of them, since there is a large spectrum of possible blocks to have on stock and not all will be demanded from Predator customers I am sure.

A bit later we might offer also just the QDCs but frankly due to high cost of those, you will be better off if you buy a pre-filled GPU block where the QDC is subsidized by us.

All this and more in our News release on Monday when Predator 360 officially launches.

Regards Mark
post #1426 of 7088
Quote:
Originally Posted by KickAssCop View Post

Here is a video of my horror. I have opened a support ticket.

http://sendvid.com/c3i4z9em

I quite literally have a headache due to the constant buzzing. It is unbearable even though I have closed my case and am sitting about 3 feet away. The noise is like coil whine gone rampant. It is like being at a construction site. I thought it was my PSU but I put my ear next to PSU and it didn't make any sounds. I have had the PSU for a month and nothing has changed in my system other than the CPU cooling. My Corsair 110i GT was completely silent.

Also seems like no one at EK answers their phones. I have been calling all morning (maybe it is a Saturday?). Corsair has about 24/7 support and I was able to talk to a rep and sort out my issues within minutes; they even created a return label for me (it is cheaper that way for the company).

Would be pissed if I don't get a cross ship on this product in case it is faulty.

I would be very annoyed till Monday mad.gif

Hi,

I am sorry to hear you have issues with noise. Unfortunately we do not offer 24/7 support (we are much smaller company then Corsair) and our guys will be able to suggest additional solutions on Monday if the forum members will not be able to help you out in the meanwhile. I also saw our CTO replied to you already with some comments.

We do test every unit before it leaves our facility so it would be strange that you would get a faulty pump/fans from us. Usually it's some kind of wrong setting/setup that is causing the issue. Still, do not worry, if there is no solution found you will get a new unit.

Regards
Mark
post #1427 of 7088
Quote:
Originally Posted by KickAssCop View Post

No, fans are already controlled using AI suite. I can't even hear the fans. The pump is connected to SATA connector as depicted in the picture. I don't know what else to do. If you notice, the fans quiet down when windows loads. It is the pump noise that is unbearable. Let me post another video. Fans are at 1400 rpm as suggested here earlier.

Also turn volume to max when watching video (both windows volume and video volume).
Hello!

What I hear is the sounds of Vardar fans running at full blast, i.e. 2200rpm. I would recognize that sound in the middle of a busy Manhattan monday. If the fan speed is turned down through BIOS then the pump speed will turn down as well. Please do all the fan speed modifications through BIOS, not AI Suite. You might be setting the wrong fan.

Please be so kind and show us your BIOS screens. Check here, start at 1m 35s:

Steps:
1. Go to QFAN control
2. Select the FAN header to edit to which you have connected the Predator's PWM cable.
3. Select PWM (instead of DC)
4. Select default profiles (Standard, Silent, ...) or make your own ramp-up curve there.

Hope this helps!

Best Regards,
Niko
    
CPUMotherboardGraphicsRAM
Ci7 5960XK @ 4.3GHz ASRock X99E-ITX NVIDIA GTX Titan X Pascal 32GB DDR4-3200 
Hard DriveHard DriveOptical DriveCooling
2x 256GB SSD RAID0 Adata SP550 960GB (storage) Samsung SE-506 EK-Supremacy MX 
OSMonitorKeyboardPower
Win10 Pro Dell P4317Q Cherry MX-Board 3.0 (MX Blue) EVGA 650W GS 
CaseMouseMouse Pad
In Win D-Frame Mini HP VoodooDNA Roccat Adrenaline 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Ci7 5960XK @ 4.3GHz ASRock X99E-ITX NVIDIA GTX Titan X Pascal 32GB DDR4-3200 
Hard DriveHard DriveOptical DriveCooling
2x 256GB SSD RAID0 Adata SP550 960GB (storage) Samsung SE-506 EK-Supremacy MX 
OSMonitorKeyboardPower
Win10 Pro Dell P4317Q Cherry MX-Board 3.0 (MX Blue) EVGA 650W GS 
CaseMouseMouse Pad
In Win D-Frame Mini HP VoodooDNA Roccat Adrenaline 
  hide details  
Reply
post #1428 of 7088
Niko, I just tried that fix and it seemed to have worked. I am now checking how I can get my other Corsair unit to quiet down since on PWN, it is going ape ****. lol.
Thanks for all your help guys thumb.gif
post #1429 of 7088
Quote:
Originally Posted by EK-CEO View Post

Hi,

I am sorry to hear you have issues with noise. Unfortunately we do not offer 24/7 support (we are much smaller company then Corsair) and our guys will be able to suggest additional solutions on Monday if the forum members will not be able to help you out in the meanwhile. I also saw our CTO replied to you already with some comments.

We do test every unit before it leaves our facility so it would be strange that you would get a faulty pump/fans from us. Usually it's some kind of wrong setting/setup that is causing the issue. Still, do not worry, if there is no solution found you will get a new unit.

Regards
Mark

Thank you for your support. Product is working fine. Seems was an error in my bios settings.
I have edited out posts that are no longer relevant.
post #1430 of 7088
Quote:
Originally Posted by KickAssCop View Post

Got my predator 360 installed and it is too noisy. Any way to fix this? I am really disappointed. Here is a picture. Still uploading a video on the tube.
vt1iAJy.jpg

EDIT: It was the fans indeed that were noisy. The noise was due to the CPU_FAN being set on DC mode in bios (not sure why that happened). Turning it to PWM mode now fixed the issue.

what case is that?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: EK Water Blocks
Overclock.net › Forums › Manufacturer Forums › EK Water Blocks › EK-Predator Club & Discussion Thread