Overclock.net › Forums › Manufacturer Forums › EK Water Blocks › EK-Predator Club & Discussion Thread
New Posts  All Forums:Forum Nav:

EK-Predator Club & Discussion Thread - Page 206

post #2051 of 7180
Finally got the rest of my build up and running. After a little fiddling with my motherboard software, the Predator is running wonderfully. smile.gif Looks like I'm running about three or four degrees cooler than I was getting on a Corsair H110 at load (4770K @4.5Ghz). The biggest noticeable difference is the noise... The Predator 360 is SO much quieter at load than the H110. I'm pretty excited to add the GPU to the loop here soon. After seeing Guru3d's CPU+GPU results I was pretty blown away.


IMG_0423_zpssub3st5w.jpg

P.S.
Sorry for the reflection, lol.
Main PC
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 - 4770k MSI z87 - g45 Gaming Titan X G.SKILL TridentX 
Hard DriveHard DriveCoolingCooling
Crucial mx200 ssd Western Digital Black Radiator - EKWB Predator 360 CPU Block - EKWB Supremacy MX 
CoolingMonitorKeyboardPower
GPU Block - EKWB Acetal FC Asus ROG Swift pg279q Filco Majestouch-2 Ninja tkl Corsair AX860 
CaseMouseMouse PadAudio
Phantek Evolv ATX Razer Deathadder Chroma Corsair MM200 Klipsch ProMedia 2.1 
  hide details  
Reply
Main PC
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 - 4770k MSI z87 - g45 Gaming Titan X G.SKILL TridentX 
Hard DriveHard DriveCoolingCooling
Crucial mx200 ssd Western Digital Black Radiator - EKWB Predator 360 CPU Block - EKWB Supremacy MX 
CoolingMonitorKeyboardPower
GPU Block - EKWB Acetal FC Asus ROG Swift pg279q Filco Majestouch-2 Ninja tkl Corsair AX860 
CaseMouseMouse PadAudio
Phantek Evolv ATX Razer Deathadder Chroma Corsair MM200 Klipsch ProMedia 2.1 
  hide details  
Reply
post #2052 of 7180
Quote:
Originally Posted by fixall View Post

Finally got the rest of my build up and running. After a little fiddling with my motherboard software, the Predator is running wonderfully. smile.gif Looks like I'm running about three or four degrees cooler than I was getting on a Corsair H110 at load (4770K @4.5Ghz). The biggest noticeable difference is the noise... The Predator 360 is SO much quieter at load than the H110. I'm pretty excited to add the GPU to the loop here soon. After seeing Guru3d's CPU+GPU results I was pretty blown away.


IMG_0423_zpssub3st5w.jpg

P.S.
Sorry for the reflection, lol.
Very nice man! Welcome to the club smile.gif
post #2053 of 7180
Will pump noise diminish over time as the air gets bled? I'm getting a high pitch noise for a second at random and frequent intervals. Think it's air bubbles going through the pump?
post #2054 of 7180
Quote:
Originally Posted by drop24 View Post

Will pump noise diminish over time as the air gets bled? I'm getting a high pitch noise for a second at random and frequent intervals. Think it's air bubbles going through the pump?
I had some noise too and fixed it by unplugging the pump from the hub and connecting it to my motherboard.
post #2055 of 7180
Quote:
Originally Posted by ChrisxIxCross View Post

I had some noise too and fixed it by unplugging the pump from the hub and connecting it to my motherboard.

I was thinking of doing that. What settings did you use in the BIOS for the pump? Just the same PWM setting as the fan?
post #2056 of 7180
Could you not sell the qdc fittings with a adapter to plug into the qdc's ,so you can bleed the gpu block and hoses prior to fitting them ?
post #2057 of 7180
Quote:
Originally Posted by drop24 View Post

I was thinking of doing that. What settings did you use in the BIOS for the pump? Just the same PWM setting as the fan?
Yep same PWM setting as the fan. Now I have the pump at 3k rpm and fans at 50%.
post #2058 of 7180
My mobo water pump header has a pump control settings page like this. Could someone from EK let me know what the onboard chip settings are for the pump so I could use those as a guideline? I just want to confirm I should be using PWM and not DC also.

post #2059 of 7180
It's the fans! The chirping is from the Vardars at low rpm. Maybe just some bearing noise or something. Well that's a relief that it's not a pump issue. ChrisxIxCross, isn't 3k rpm full speed for this pump? It's probably fine to run it full out all the time but why do it if you don't have to?
post #2060 of 7180
Doing some testing in the BIOS PWM fan control revealed that anything above 30% PWM signal gives the chirping from both fans. I ordered a couple Gentle Typhoon 1850 rpm PWM fans to replace them with.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: EK Water Blocks
Overclock.net › Forums › Manufacturer Forums › EK Water Blocks › EK-Predator Club & Discussion Thread