Overclock.net › Forums › Manufacturer Forums › EK Water Blocks › EK-Predator Club & Discussion Thread
New Posts  All Forums:Forum Nav:

EK-Predator Club & Discussion Thread - Page 358

post #3571 of 6981
Quote:
Originally Posted by Revan654 View Post

I have no place to install Pump and Res. Fu
I have no place to to put a pump or res. Custom loop is out of the question for me.


I know EK told me today, their currently having customs issues, It could be that.

Core X9 case is cheap and has some of the best pump/rad support of any case out there. biggrin.gif

http://www.overclock.net/t/1538271/thermaltake-core-x-case-owners-club-x1-x2-x9-x9-snow-ed/2400#post_24830831
    
CPUMotherboardGraphicsRAM
Intel Core i7 5960X Asus Sabertooth X99 Gigabyte 1080 Ti Founders Edition Corsair LPX 
Hard DriveHard DriveCoolingOS
1.2TB Intel 750 PCI-E SSD 2TB Western Digital Black EKWB Predator 360 With One Titan X In Loop. Windows 10 Anniversary Edition 
MonitorKeyboardPowerCase
Acer XB280HK 4K Gsync QNIX QX2710 LED 27" WQHD 2560x1440 Corsair AX1500i Thermaltake Core X9 
MouseMouse Pad
MadKatz R.A.T. 8 Zowie 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 5960X Asus Sabertooth X99 Gigabyte 1080 Ti Founders Edition Corsair LPX 
Hard DriveHard DriveCoolingOS
1.2TB Intel 750 PCI-E SSD 2TB Western Digital Black EKWB Predator 360 With One Titan X In Loop. Windows 10 Anniversary Edition 
MonitorKeyboardPowerCase
Acer XB280HK 4K Gsync QNIX QX2710 LED 27" WQHD 2560x1440 Corsair AX1500i Thermaltake Core X9 
MouseMouse Pad
MadKatz R.A.T. 8 Zowie 
  hide details  
Reply
post #3572 of 6981
Little embarrassed but thought I'd share anyway.

30 years of PC tweaking and gaming and I still managed to mount my 1.1 rma unit's block without removing the protective sticker!

Surprisingly enough I still got idle Temps around 60c.

Blame it on the early hour I guess.
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
4690k @ 4.6ghz MSI z97m gaming MSI GTX 980 gaming TF5 4x4gb Gskill Sniper ddr3 
Hard DriveHard DriveCoolingOS
Samsung 840 250gb Bunch'a mechanical hdds!  Cooler Master Seidon 120m (cpu)  Windows 8.1 64bit 
MonitorKeyboardPowerCase
Panasonic 55" 3d plasma / Qnix QX2710 Cooler Master Quickfire TK Silverstone sst-st85f-p 850w silver Fractal Design arc mini r2 
MouseMouse PadAudio
Logitech G600 Razer Vespula 7.1 Home theater 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
4690k @ 4.6ghz MSI z97m gaming MSI GTX 980 gaming TF5 4x4gb Gskill Sniper ddr3 
Hard DriveHard DriveCoolingOS
Samsung 840 250gb Bunch'a mechanical hdds!  Cooler Master Seidon 120m (cpu)  Windows 8.1 64bit 
MonitorKeyboardPowerCase
Panasonic 55" 3d plasma / Qnix QX2710 Cooler Master Quickfire TK Silverstone sst-st85f-p 850w silver Fractal Design arc mini r2 
MouseMouse PadAudio
Logitech G600 Razer Vespula 7.1 Home theater 
  hide details  
Reply
post #3573 of 6981
Quote:
Originally Posted by Jyve View Post

Little embarrassed but thought I'd share anyway.

30 years of PC tweaking and gaming and I still managed to mount my 1.1 rma unit's block without removing the protective sticker!

Surprisingly enough I still got idle Temps around 60c.

Blame it on the early hour I guess.
rofl...at least you didn't come here and cry the blues trashing ek for your mistake...ive seen that before back before water cooling got bigger with.the mass cool heatsinks...they came with protective plastic on them and it was just clear plastic no warning no remove me....I've actuary done this myself with the phanteks dx12 it also has no markings and doesn't really overhang the bottom of the block..quick glance and an install...oops...worst thing was in that case I had a hell of a time getting everything connected because it was such a tight fit then I got to do it again...so now I triple check everything especially since water cooling
NEWBIE
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD 8320e Asus Sabertooth R2.0 xfx r9 290 xfx r9 290 
RAMHard DriveHard DriveHard Drive
G.Skill rip jaws  Samsung 840 Pro WD BLUE 64MB Cache Ocz vertex 3 
CoolingCoolingCoolingCooling
Swiftech h220x  alphacool nexxos st30 280mm radiator alphacool coolplex pro LT10 100mm reservoir Swiftech h220 rad only 
OSMonitorMonitorKeyboard
Windows 7 64 Bit ENTERPRISE edition Acer 23" 1080p  asus 19" Dell Media Center  
PowerCaseMouseMouse Pad
Rosewill Photon 1200W Phanteks Enthoo Pro Logitech G5 or Steel Series MW2 edition Generic Cheapy 
AudioAudioAudio
GEMINI HSR-1000 Logitech 5.1 surround ZALMAN clip on mic 
  hide details  
Reply
NEWBIE
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD 8320e Asus Sabertooth R2.0 xfx r9 290 xfx r9 290 
RAMHard DriveHard DriveHard Drive
G.Skill rip jaws  Samsung 840 Pro WD BLUE 64MB Cache Ocz vertex 3 
CoolingCoolingCoolingCooling
Swiftech h220x  alphacool nexxos st30 280mm radiator alphacool coolplex pro LT10 100mm reservoir Swiftech h220 rad only 
OSMonitorMonitorKeyboard
Windows 7 64 Bit ENTERPRISE edition Acer 23" 1080p  asus 19" Dell Media Center  
PowerCaseMouseMouse Pad
Rosewill Photon 1200W Phanteks Enthoo Pro Logitech G5 or Steel Series MW2 edition Generic Cheapy 
AudioAudioAudio
GEMINI HSR-1000 Logitech 5.1 surround ZALMAN clip on mic 
  hide details  
Reply
post #3574 of 6981
Quote:
Originally Posted by Jyve View Post

Little embarrassed but thought I'd share anyway.

30 years of PC tweaking and gaming and I still managed to mount my 1.1 rma unit's block without removing the protective sticker!

Surprisingly enough I still got idle Temps around 60c.

Blame it on the early hour I guess.

lol. How'd you figure out it was there?
post #3575 of 6981
Quote:
Originally Posted by Alpina 7 View Post

lol. How'd you figure out it was there?
it usually doesn't fully melt but you can smell it....also when you see really high idle temps on any new mount you know something is up...mine wasn't easy getting of when I did this I had to scrape it off with a chisel and sand down the groove it left from the chisel...the good thing was it only bonded to the heatsink...I literally had the pc running maybe 3 minutes...I knew immediately when I was in the bios at 50c LOL
NEWBIE
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD 8320e Asus Sabertooth R2.0 xfx r9 290 xfx r9 290 
RAMHard DriveHard DriveHard Drive
G.Skill rip jaws  Samsung 840 Pro WD BLUE 64MB Cache Ocz vertex 3 
CoolingCoolingCoolingCooling
Swiftech h220x  alphacool nexxos st30 280mm radiator alphacool coolplex pro LT10 100mm reservoir Swiftech h220 rad only 
OSMonitorMonitorKeyboard
Windows 7 64 Bit ENTERPRISE edition Acer 23" 1080p  asus 19" Dell Media Center  
PowerCaseMouseMouse Pad
Rosewill Photon 1200W Phanteks Enthoo Pro Logitech G5 or Steel Series MW2 edition Generic Cheapy 
AudioAudioAudio
GEMINI HSR-1000 Logitech 5.1 surround ZALMAN clip on mic 
  hide details  
Reply
NEWBIE
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD 8320e Asus Sabertooth R2.0 xfx r9 290 xfx r9 290 
RAMHard DriveHard DriveHard Drive
G.Skill rip jaws  Samsung 840 Pro WD BLUE 64MB Cache Ocz vertex 3 
CoolingCoolingCoolingCooling
Swiftech h220x  alphacool nexxos st30 280mm radiator alphacool coolplex pro LT10 100mm reservoir Swiftech h220 rad only 
OSMonitorMonitorKeyboard
Windows 7 64 Bit ENTERPRISE edition Acer 23" 1080p  asus 19" Dell Media Center  
PowerCaseMouseMouse Pad
Rosewill Photon 1200W Phanteks Enthoo Pro Logitech G5 or Steel Series MW2 edition Generic Cheapy 
AudioAudioAudio
GEMINI HSR-1000 Logitech 5.1 surround ZALMAN clip on mic 
  hide details  
Reply
post #3576 of 6981
Quote:
Originally Posted by Jyve View Post

Little embarrassed but thought I'd share anyway.

30 years of PC tweaking and gaming and I still managed to mount my 1.1 rma unit's block without removing the protective sticker!

Surprisingly enough I still got idle Temps around 60c.

Blame it on the early hour I guess.

Post a picture please, not sure how it is possible, although I guess it can happen smile.gif
post #3577 of 6981
No pics to show. Caused no permanent damage. Noticed cuz the idle Temps were too high. Was only on for a minute or 2. Shut 'er down and fixed it.

Just dumb on my part.

Edit: sticker came right off, no problem.
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
4690k @ 4.6ghz MSI z97m gaming MSI GTX 980 gaming TF5 4x4gb Gskill Sniper ddr3 
Hard DriveHard DriveCoolingOS
Samsung 840 250gb Bunch'a mechanical hdds!  Cooler Master Seidon 120m (cpu)  Windows 8.1 64bit 
MonitorKeyboardPowerCase
Panasonic 55" 3d plasma / Qnix QX2710 Cooler Master Quickfire TK Silverstone sst-st85f-p 850w silver Fractal Design arc mini r2 
MouseMouse PadAudio
Logitech G600 Razer Vespula 7.1 Home theater 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
4690k @ 4.6ghz MSI z97m gaming MSI GTX 980 gaming TF5 4x4gb Gskill Sniper ddr3 
Hard DriveHard DriveCoolingOS
Samsung 840 250gb Bunch'a mechanical hdds!  Cooler Master Seidon 120m (cpu)  Windows 8.1 64bit 
MonitorKeyboardPowerCase
Panasonic 55" 3d plasma / Qnix QX2710 Cooler Master Quickfire TK Silverstone sst-st85f-p 850w silver Fractal Design arc mini r2 
MouseMouse PadAudio
Logitech G600 Razer Vespula 7.1 Home theater 
  hide details  
Reply
post #3578 of 6981
Ncix has the 1.1 in stock now. My replacement was shipped out to me. Hopefully have it today or tomorrow smile.gif
post #3579 of 6981
Quote:
Originally Posted by Jyve View Post

No pics to show. Caused no permanent damage. Noticed cuz the idle Temps were too high. Was only on for a minute or 2. Shut 'er down and fixed it.

Just dumb on my part.

Edit: sticker came right off, no problem.

Oh good lord what a nightmare! I know I'm gonna quadruple check for tim and stickers from now on lol
post #3580 of 6981
Is EK-EKOOLANT EVO Clear Coolant Mayhem's X1 clear rebranded? Also, does anyone know if the 240 Predator will fit in front of a SilverStone PS07 with a Titan X? Thanks!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: EK Water Blocks
Overclock.net › Forums › Manufacturer Forums › EK Water Blocks › EK-Predator Club & Discussion Thread