Overclock.net › Forums › Components › Mice › Zowie EC1-A - Help me mod it!
New Posts  All Forums:Forum Nav:

Zowie EC1-A - Help me mod it! - Page 5

post #41 of 68
Quote:
Originally Posted by cookieboyeli View Post

Yup, the button PCB is unresponsive. I can't tell if it has power or not because I removed the LED. I'll get a multimeter and test or perhaps reattach the LED although I don't know in what configuration it was in and it has 4 leads so maybe I shouldn't.

It DOES have a little tiny pinhole in it, but shining a flashlight through it reveals the pinhole goes smack dab in the middle of the wires without breaking them. At least that's how it appears no matter how I look at it. The ribbon cable was definitely roughed up in the process though.

I'll take some macro shots of the PCB likely tomorrow when I get a charger cable for this damn camera. (And a screwdriver since my helper took my only one that worked).

you can basically break any trace on the board of a component, but the others should still work, so doesn't matter if the traces for the LED would be broken badly, switches and scrollwheel should still work.
PC
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon E3-1230v3  MSI Z87-G43 MSI GTX 970 Gaming 4G 16 GB Corsair Vengeance LP 
Hard DriveHard DriveHard DriveCooling
Samsung evo 830 120GB  Samsung evo 840 250GB 2x Samsung Spinpoint F1 Scythe Mugen 4 PCGH ed. 
OSMonitorKeyboardPower
Win 10 Pro x64  Acer Predator XB240HA(G-SYNC) Logitech G410  be quiet! Straight Power E7 580W 
CaseMouseMouse PadAudio
Corsair Carbide Series 300R Logitech G403(w/ paracord) Artisan Shiden Snow White L XSOFT  Soundblaster Z 
AudioAudio
Sennheiser HD-590 AKG K712 Pro 
  hide details  
Reply
PC
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Xeon E3-1230v3  MSI Z87-G43 MSI GTX 970 Gaming 4G 16 GB Corsair Vengeance LP 
Hard DriveHard DriveHard DriveCooling
Samsung evo 830 120GB  Samsung evo 840 250GB 2x Samsung Spinpoint F1 Scythe Mugen 4 PCGH ed. 
OSMonitorKeyboardPower
Win 10 Pro x64  Acer Predator XB240HA(G-SYNC) Logitech G410  be quiet! Straight Power E7 580W 
CaseMouseMouse PadAudio
Corsair Carbide Series 300R Logitech G403(w/ paracord) Artisan Shiden Snow White L XSOFT  Soundblaster Z 
AudioAudio
Sennheiser HD-590 AKG K712 Pro 
  hide details  
Reply
post #42 of 68
Thread Starter 
Quote:
Originally Posted by thuNDa View Post

Quote:
Originally Posted by cookieboyeli View Post

Yup, the button PCB is unresponsive. I can't tell if it has power or not because I removed the LED. I'll get a multimeter and test or perhaps reattach the LED although I don't know in what configuration it was in and it has 4 leads so maybe I shouldn't.

It DOES have a little tiny pinhole in it, but shining a flashlight through it reveals the pinhole goes smack dab in the middle of the wires without breaking them. At least that's how it appears no matter how I look at it. The ribbon cable was definitely roughed up in the process though.

I'll take some macro shots of the PCB likely tomorrow when I get a charger cable for this damn camera. (And a screwdriver since my helper took my only one that worked).

you can basically break any trace on the board of a component, but the others should still work, so doesn't matter if the traces for the LED would be broken badly, switches and scrollwheel should still work.
Oh I see... I was thinking of my Objective 2 AMP where the 2.1v forward voltage LED is a critical component for it to function.

I'm going to get that charging cable now so I can take some pictures of this thing.
EDIT: Nope, gonna have to get a cable by mail. frown.gif
Edited by cookieboyeli - 10/19/15 at 5:12pm
post #43 of 68
Thread Starter 
Hey guys, I'm 90% sure it's the ribbon cable! I tested stuff with a multimeter and the switches all work (though left click seems to actuate possibly before the click, may have to swap it out). There is no electrical connection between the two ends of the ribbon cable. It's dead. I'm ordering a new one.
I've also ordered all new soldering tools so the process goes smoother. I think I'm going to have to resolder a switch or two as well to get it to meet the shell properly. I overestimated the boost in height so putting it together clicks all the switches.


I can't find that exact ribbon cable anywhere. Most are going for ridiculous amounts too! I'm not paying $12 for a half ounce cable. Not going to happen.

I sent this to Zowie, let's see what happens...
Quote:
Hi, I decided to mod my Zowie EC1-A. I installed Omron switches and removed the LED. It went well, except I somehow accidentally damaged the ribbon cable.

I've been searching high and low but for the life of me cannot seem to find the exact cable on ebay or elsewhere, I've even tried searching in other languages!

Could you send me a link to where you buy them from or perhaps let me buy one from you?

Right now I'm stuck using my... *pukes in mouth* Razer Deathadder 2013.

Here's my new tools! biggrin.gif
http://www.amazon.com/gp/product/B00Y9UW2XA
http://www.amazon.com/gp/product/B0002LLWEU
http://www.amazon.com/gp/product/B000RB38X8
http://www.amazon.com/gp/product/B00L2HRW92
http://www.amazon.com/gp/product/B00FZPGDLA
Edited by cookieboyeli - 10/24/15 at 1:09am
post #44 of 68
it's an fpc cable

measure the pitch, count the number of wires and look on digikey
main
(15 items)
 
old
(14 items)
 
 
CPUMotherboardGraphicsRAM
4770k maximus vii impact nvidia gtx 970 crucial ballistix tactical 16gb 
Hard DriveCoolingOSMonitor
crucial mx100 noctua nh-c14 windows 7 ultimate sony cpd-g520 
KeyboardPowerCaseMouse
kbp v80 matias quiet silverstone sx500-lg ncase m1 v3 logitech g100s with mcu replaced by teensy2.0 
Mouse PadAudioAudio
allsop raindrop xl chord mojo hifiman re-600 
CPUMotherboardGraphicsRAM
i7 920 evga x58 sli le galaxy gtx 460 crucial something 3x1gb 
Hard DriveCoolingOSMonitor
intel 330 180gb scythe kotetsu windows 8.1 pro sony cpd-g520 
KeyboardPowerCaseMouse
logitech k120 silverstone st75f-gs nxzt h440 evga torq x5 
Mouse PadAudio
allsop raindrop mobo 
  hide details  
Reply
main
(15 items)
 
old
(14 items)
 
 
CPUMotherboardGraphicsRAM
4770k maximus vii impact nvidia gtx 970 crucial ballistix tactical 16gb 
Hard DriveCoolingOSMonitor
crucial mx100 noctua nh-c14 windows 7 ultimate sony cpd-g520 
KeyboardPowerCaseMouse
kbp v80 matias quiet silverstone sx500-lg ncase m1 v3 logitech g100s with mcu replaced by teensy2.0 
Mouse PadAudioAudio
allsop raindrop xl chord mojo hifiman re-600 
CPUMotherboardGraphicsRAM
i7 920 evga x58 sli le galaxy gtx 460 crucial something 3x1gb 
Hard DriveCoolingOSMonitor
intel 330 180gb scythe kotetsu windows 8.1 pro sony cpd-g520 
KeyboardPowerCaseMouse
logitech k120 silverstone st75f-gs nxzt h440 evga torq x5 
Mouse PadAudio
allsop raindrop mobo 
  hide details  
Reply
post #45 of 68
Thread Starter 
Quote:
Originally Posted by qsxcv View Post

it's an fpc cable

measure the pitch, count the number of wires and look on digikey
It's 12 pin, 70mm long, 0.050" (1.27mm) pitch...

Still can't find one on digikey.

All I can find https://www.digikey.com/product-search/en?pv88=4&pv89=2&FV=fff40018%2Cfff80232&mnonly=0&newproducts=0&ColumnSort=0&page=1&quantity=0&ptm=0&fid=0&pageSize=25
thinking.gif
Edited by cookieboyeli - 10/24/15 at 2:57pm
post #46 of 68
post #47 of 68
Thread Starter 
Quote:
Originally Posted by trism View Post

http://www.digikey.com/product-search/en?pv316=16&FV=ffec4d3d&mnonly=0&newproducts=0&ColumnSort=0&page=1&quantity=0&ptm=0&fid=0&pageSize=25

Think you have to ask a deal though. Please don't buy 152 meters of that stuff. biggrin.gif
First, how do I do that?

And how do I get the ends I need?

If I'm going to have to put the ends on myself then why can't I just fix the ends in my cable? I'm pretty sure it's disconnected at one end since no wires conduct out of 12.
post #48 of 68
Try. You could even rip off the connectors and solder in 12 individual wires if you wanted to...
post #49 of 68
Thread Starter 
Quote:
Originally Posted by trism View Post

Try. You could even rip off the connectors and solder in 12 individual wires if you wanted to...
That would add a lot of weight.

I have no idea how I'd do that. I probably have 10mm to get it right with so I don't want to try blindly. If I'm successful this will be a very slight weight reduction. Cable weight 0.4g.
post #50 of 68
Thread Starter 
Here, I took some close up shots of where I think the break is. It bends far too easily and looks as if the wires have a small gap before the connector. It could be just part of it but the rest of the cable is looks fine. Multimeter says there's no connection for any wires. How would I go about repairing this? Is it even possible?


New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Zowie EC1-A - Help me mod it!